Home of the Squeezebox™ & Transporter® network music players.
Page 13 of 13 FirstFirst ... 3111213
Results 121 to 127 of 127
  1. #121
    Junior Member
    Join Date
    Jan 2021
    Posts
    11
    Quote Originally Posted by mherger View Post
    > I started to have this problem after installing Tailscale on my server
    > hosting Slimserver. Does anyone know how to add the httpaddr value to
    > an instance running in a docker container?


    Edit the server.prefs file while the server is shut down.
    I thought that was the file to edit but adding this to the server.prefs file does nothing:

    httpaddr: 192.168.1.100

    I still get this in the logs:

    [22-01-22 12:09:25.9103] Slim::Plugin::CLI::Plugin::cli_socket_accept (250) Access to CLI is restricted to the local network or localhost: <tailscale ip here>

    I'm thinking I am not entering the correct cmd.

    Thx.

  2. #122
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,718

    Forbidden: settings/index.html

    > -[22-01-22 12:09:25.9103] Slim::Plugin::CLI::Plugin::cli_socket_accept
    > (250) Access to CLI is restricted to the local network or localhost:
    > <tailscale ip here>-


    Can you tell us a little more about your environment? Tailscale would
    not run in the container, would it? What IP networks are being used
    where (inside and outside the container)?

  3. #123
    Junior Member
    Join Date
    Jan 2021
    Posts
    11
    Quote Originally Posted by mherger View Post
    >
    Can you tell us a little more about your environment? Tailscale would
    not run in the container, would it? What IP networks are being used
    where (inside and outside the container)?
    I've decided to uninstall Tailscale for the time being, but to answer the above, I was running Tailscale in a docker container (https://github.com/ido1990/tailscale-relay) on an Ubuntu server.

    Thanks for your help. I'll have to troubleshoot another time.

  4. #124
    Junior Member
    Join Date
    Nov 2009
    Posts
    4
    servus michael,

    i'm having the same or similar issue as the last poster.

    running LMS on a raspi4 (raspbian 10) in a docker container which is connected to the host network. so i can access it with 192.168.1.11 (ip of raspi) on the LMS port. which works fine and i did so on several machines yet.


    recently i installed tailscale (which plain rocks) so the raspi got another network device with the ip of the tailscale network (100.70.x.x) and can be accessed from anywhere. i can access LMS fine with this IP - but get a 'forbidden' for the settings page. which is kind of expected.

    additionally i figured it would make sense to set this raspi as a relay node on the tailscale network https://tailscale.com/kb/1019/subnets/ (which rocks even more). that way one can access any internal ip (192.168.1.x) from anywhere in the tailscale network without running the tailscale client on every device on the network. so i can use 192.168.1.11:9000 from anywhere - which works - but again i get a 403 for the settings page. annoyingly - set up this way - also when accessing LMS via the local ip on the local network.

    checking the logs:
    Code:
    Slim::Web::HTTP::generateHTTPResponse (1022) Access to settings pages is restricted to the local network or localhost: 100.76.xxx.xxx -> 192.168.1.11 (settings/index.html)
    so it would be really cool if there was a way to whitelist IPs/subnets to allow accessing settings.

    thanks,
    markus.

  5. #125
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,718

    Forbidden: settings/index.html

    > but get a 'forbidden' for the settings page. which is kind of expected.

    You currently have two options to deal with the situation:

    * enable password protection (and optionally add your networks to the IP
    allow list)
    * disable the check by setting the protectSettings value to a falsy
    value (vi is your UI to this setting :-))


  6. #126
    Senior Member madpatrick's Avatar
    Join Date
    Apr 2006
    Location
    Hellevoetsluis, Netherlands
    Posts
    170
    Quote Originally Posted by mherger View Post
    > I'm running LMS on ClearOS7 (Centos 7)

    Ok, then you should have a file /etc/sysconfig/squeezeboxserver. Add
    --httpaddr to the startup parameters, telling LMS which IP address to
    bind to.

    --

    Michael
    Replying to an old issue.
    After every update of LMS i was facing the same problem and needed to add --httpaddr

    I've found aout that the parameters of /etc/sysconfig/squeezeboxserver were not loaded somehow

    After investigating the startup file i found a type in the systems startup file which i think is in the compiled package

    in "/etc/systemd/system/multi-user.target.wants/squeezeboxserver.service"

    Code:
    EnvironmentFile=-/etc/sysconfig/squeezeboxserver
    must be

    Code:
    EnvironmentFile=/etc/sysconfig/squeezeboxserver
    there is "-" after "="

    now the squeezeboxserver is starting up correctly
    Last edited by madpatrick; 2022-05-11 at 14:59.
    -
    Patrick

  7. #127
    Senior Member madpatrick's Avatar
    Join Date
    Apr 2006
    Location
    Hellevoetsluis, Netherlands
    Posts
    170
    forget my previous post.
    Some how it is starting good , but after a few minutes is see the following in the log

    Code:
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:50:48.9289] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","language","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:50:48.9381] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","language","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:50:48.9428] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","language","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:50:48.9464] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","language","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:50:48.9515] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","language","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:55:49.0012] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","plugin.musicartistinfo:browseArtistPictures","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:55:49.0084] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","plugin.onlinelibrary:enableServiceEmblem","?"]]}
    May 12 16:57:06 pdebrabander squeezeboxserver: [22-05-12 16:55:49.0207] Slim::Web::JSONRPC::handleURI (213) Access to settings is restricted to the local network or localhost: 192.168.1.238 {"id":0,"method":"slim.request","params":["",["pref","plugin.state:DontStopTheMusic","?"]]}

    added --httpaddr=MYIP in /etc/systemd/system/multi-user.target.wants/squeezeboxserver.service and the errors are gone
    This in only a temp fix since this file is change after every LMS update
    -
    Patrick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •