Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 111 FirstFirst 123451353103 ... LastLast
Results 21 to 30 of 1109
  1. #21
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,858
    Quote Originally Posted by bwaldron View Post
    I had this problem running the Squeeze Control app on my PC running LMS. I used Windows Loopback Exemption Manager (http://loopback.codeplex.com/) to resolve the issue.
    I have a vague memory that Soundicity allowed something like this

  2. #22
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    614

    Crashes Anyone?

    I'm looking at telemetry info on Squeezelite-X from the Microsoft Store that indicates occasional crashes are happening out there. I believe something might be going wrong relating to the media key integration and the keyboard hook I have implemented to capture media key presses even when the application is running in the background.

    Has anyone experienced any crashes lately? If you have, I'd sure like to know about it. Thanks.

    R Greg Dawson
    Last edited by rgdawson; 2018-01-19 at 16:52.
    Squeezelite-X

  3. #23
    Senior Member
    Join Date
    Aug 2008
    Location
    Norway
    Posts
    362
    My client PC (a Dell running Win 10) runs 24/7 and SL-X is connected to my LMS which runs in a docker container on a QNAP NAS.
    I haven't had any isolated SL-X "crashes" in a long time now, but occasionally, music playback randomly just stops. Often in the middle of a track.
    I use "Don't Stop the music" on LMS, and this may just as well be related to that plugin.
    QNAP TS-453Mini 4x3TB RAID5 QTS 4.3.4
    LMS 7.9.1 running in Docker
    Madsonic 6.2 running in Docker
    Plex running in Docker

    QNAP HS-251 2x2TB RAID0, QTS 4.3.4
    Kodi 16.1 Jarvis

    QNAP TS-119 1TB Single, QTS 4.3.3
    Almost Retired

  4. #24
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    614
    Quote Originally Posted by rgdawson View Post
    I'm looking at telemetry info on Squeezelite-X from the Microsoft Store that indicates occasional crashes are happening out there. I believe something might be going wrong relating to the media key integration and the keyboard hook I have implemented to capture media key presses even when the application is running in the background.

    Has anyone experienced any crashes lately? If you have, I'd sure like to know about it. Thanks.

    R Greg Dawson
    My theory is that it could be possible for the application termination sequence to terminate such that the Media Key hook could get called by the O/S after the application's callback routine is unloaded. (That is my theory, I cannot reproduce it). The result is that the application terminates anyway, so it goes unnoticed. So I have replaced the Low-Level keyboard hook I was using, with a simpler, safer approach using "RegisterHotKey" windows API method.

    I have also improved a feature some might find useful, that is the mini-player. In the main browser interface, you can open a mini-player by pressing a little button just to the right of the On/Off button. This opens a pop-up window that is the mini-player. Previously, I just allowed the popup provided by the LMS. The size wrong, and I never liked the standard big title bar and the fact that it was white when the mini-player did not have focus. So now, I intercept this call and open a custom version of the mini-browser, with a smaller title bar that stays dark, and is automatically sized correctly. Another change is that pressing "Help" or "Settings" from the browser interface now opens Help and Settings in a regular browser window. I did this in order to provide full browser functionality when working with help and settings, particularly search. All this is in Version 1.2.7, which I submitted to Store today, so should be available in a few days.

    R Greg Dawson
    Squeezelite-X

  5. #25
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    614

    Using LMS with non-standard Web or CLI Ports, anyone?

    Currently, if your LMS Command Line Interface port id is configured as anything other than the default 9090, Squeezelite-X will hang because it is expecting 9090. I don't know if anyone has had issues with this, I'm not aware of any. I'm guessing 99.9% of LMS instances are using the default port ids.

    But, I am making this configurable on the Squeezelite-X side. A version that supports configuration of the CLI port id will be released next week, after I run it through its paces.

    R Greg Dawson
    Squeezelite-X

  6. #26
    Senior Member
    Join Date
    Jan 2006
    Location
    South Coast, NSW, Australia
    Posts
    1,256
    Just got home after a month away.
    Loaded Squeezelite-X 1.3.2. Works perfectly, saw the port config option, available if you want it but if you don't then it stays hidden. Good way of doing it as the screen stays uncluttered.

    There was a plugin update notice at the bottom of the LMS screen, so I updated the plugin, restarted LMS but the update notice was still there. Couldn't remember how to refresh Squeezelite-X so just closed and restarted.
    Is there a way (apart from close / restart) of refreshing the LMS screen ?
    A camel is a racehorse designed by a committee.

    Seen sprayed on the outside wall of the local library -
    Three things I hate in life :
    1. Vandalism
    2. Irony
    3. Lists

  7. #27
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    614
    Quote Originally Posted by Wirrunna View Post
    Just got home after a month away.
    Loaded Squeezelite-X 1.3.2. Works perfectly, saw the port config option, available if you want it but if you don't then it stays hidden. Good way of doing it as the screen stays uncluttered.

    There was a plugin update notice at the bottom of the LMS screen, so I updated the plugin, restarted LMS but the update notice was still there. Couldn't remember how to refresh Squeezelite-X so just closed and restarted.
    Is there a way (apart from close / restart) of refreshing the LMS screen ?
    You can just lick on the label "Logitech Media Server" in the browser window and that will refresh it.

    R Greg Dawson
    Squeezelite-X

  8. #28
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,383
    Quote Originally Posted by rgdawson View Post
    You can just lick on the label "Logitech Media Server" in the browser window and that will refresh it.

    R Greg Dawson
    That just makes the screen all smeary
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 8.0 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  9. #29
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    614
    Quote Originally Posted by Jeff07971 View Post
    That just makes the screen all smeary
    I might have read your post too fast. If you update LMS while SLX is running, what will happen is that the server will be stopped in order to do the update. SLX will detect it is no longer connected and try to reconnect about every 8 seconds. When the server is back on line, SQL will successfully connect. That will also trigger a refresh of the browser.

    But re-reading your post you updated a plugin and I'm not sure if the message is referring to a plugin update or an LMS update. But it should work the same assuming you have to restart the server to take the updated plugin, so the same thing should happen.

    What do you mean by "screen all smeary"?

    R Greg Dawson
    Squeezelite-X

  10. #30
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,383
    Quote Originally Posted by rgdawson View Post
    I might have read your post too fast. If you update LMS while SLX is running, what will happen is that the server will be stopped in order to do the update. SLX will detect it is no longer connected and try to reconnect about every 8 seconds. When the server is back on line, SQL will successfully connect. That will also trigger a refresh of the browser.

    But re-reading your post you updated a plugin and I'm not sure if the message is referring to a plugin update or an LMS update. But it should work the same assuming you have to restart the server to take the updated plugin, so the same thing should happen.

    What do you mean by "screen all smeary"?

    R Greg Dawson
    "You can just lick on the label"
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 8.0 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •