Home of the Squeezebox™ & Transporter® network music players.
Page 103 of 114 FirstFirst ... 35393101102103104105113 ... LastLast
Results 1,021 to 1,030 of 1137
  1. #1021
    Junior Member
    Join Date
    Mar 2010
    Posts
    10
    Quote Originally Posted by rgdawson View Post
    We can re-look at this when the next version update publishes. It has some improvements in the discovery process that may solve your issue or at least make it easier to isolate.

    R Greg Dawson
    Nice done.
    It is now me to do my job.
    Code:
     23:12:47.910   Program Start (08/10/2019)
     23:12:48.017   Squeezelite-X, Version: 2.4.18
                    Windows Version: Windows 10, version 1903 (Windows 10 May 2019 Update)
                    Squeezelite Version: 1.9.4-1193
                    CEF Version: 76.1.13.0 (Chrome: 76.0.3809.132)
     23:12:48.017   ----------------------------------------------------------------------------------------------------
                    Creating Main Form
                    ----------------------------------------------------------------------------------------------------
     23:12:48.063   Creating Main Browser
     23:12:48.073   Log Window Created
    *23:12:48.086   Main Browser Created - PostMessage(Handle, CEF_AFTERCREATED, 0, 0)
    *23:12:48.086   Set Mouse Hook - Success
     23:12:48.096   Received in main thread - Message(CEF_AFTERCREATED) - PostMessage(Handle, SLX_INITPROGRAM, 0, 0)
     23:12:48.100   ----------------------------------------------------------------------------------------------------
                    Start InitProgram
                    ----------------------------------------------------------------------------------------------------
     23:12:48.106   Read Settings From Registry
     23:12:48.117   SyncMemo called.
     23:12:48.117   Init Tray Menu
     23:12:48.128   Registering MediaKeys
     23:12:48.290   ConnectAll Called
     23:12:48.294   Broadcast Discovery packet 'e' with 'eNAME'#0'JSON'#0'CLIP'#0'VERS'#0 to [192.168.3.255]
     23:12:48.347   Server Discovery Complete: Ouessant,RPI-audio [54ms]
     23:12:48.348   SyncMemo called.
     23:12:48.348   Save Settings To Registry
     23:12:48.350   CheckHost(http://RPI-audio:9000)
     23:12:48.359   PositionCefWindow(SKIN_DEFAULT);
     23:12:54.358   WARNING: WaitForTask Timed Out
     23:12:54.358   CheckHost Result = HTTP_HOST_NOT_FOUND [6007 ms]
     23:12:54.358   ConnectAll Complete.
     23:12:54.360   Logitech Media Server did not respond - RPI-audio:9000
     23:12:54.360   Not worth retrying because unauthorized or WOL = false
     23:12:54.365   TrayMenu Assigned
     23:12:54.365   ----------------------------------------------------------------------------------------------------
                    End InitProgram [6455 ms]
                    ----------------------------------------------------------------------------------------------------
     23:12:54.444   MainViewForm.Show (Begin)

  2. #1022
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    623
    Quote Originally Posted by ronlog View Post
    Nice done.
    It is now me to do my job.
    The server is not responding when SLX checks it using the server name. I have seen cases where my network could not resolve the server name, in your case "RPI-audio", due to how I had my network configured. Try using the IP address of RPI-audio as the server name and see if that works. If it does, then the problem is the networks ability to resolve the server's name. In my case I think I had the DHCP/Router configured to use a reserved IP address (or something like that) and I think I ran into a similar problem.

    R Greg Dawson
    Squeezelite-X

  3. #1023
    Quote Originally Posted by rgdawson View Post
    Perhaps another app has previously registered the media keys as Hot Keys. Only one app can do it at a time.

    R Greg Dawson
    I have no other media app open at the same time. Is there any way of finding out if they're registered by another app ?

  4. #1024
    Senior Member left channel's Avatar
    Join Date
    Mar 2018
    Location
    Silicon Valley
    Posts
    378
    Quote Originally Posted by Stan Pulsar View Post
    I have no other media app open at the same time. Is there any way of finding out if they're registered by another app ?
    I hope these ideas will help:

    If you have Google Music or another music extension in Chrome, that may take over your media keys when Chrome is open. Check your Chrome extensions and disable any relevant items you find. Get there via the three-dot menu at the top right, choose Settings, then Extensions on the lower right.

    Maybe also set SLX as your default music app in Windows, though I haven't had to do that here. In Win 10 press the key combination <Windows-R> and enter "control panel". Go into "Default Programs", and change the music app to SLX.
    Last edited by left channel; 2019-10-09 at 05:48.
    LMS: SGC microJukebox running Sonicorbiter OS
    Control apps: Squeezelite-X on Win 10; Squeezer or Material web app on Android
    Players: Duet, Touch (two), Mac SqueezePlay, Win Squeezelite-X on laptop and HTPC

  5. #1025
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    623
    Quote Originally Posted by left channel View Post
    I hope these ideas will help:

    If you have Google Music or another music extension in Chrome, that may take over your media keys when Chrome is open. Check your Chrome extensions and disable any relevant items you find. Get there via the three-dot menu at the top right, choose Settings, then Extensions on the lower right.

    Maybe also set SLX as your default music app in Windows, though I haven't had to do that here. In Win 10 press the key combination <Windows-R> and enter "control panel". Go into "Default Programs", and change the music app to SLX.
    I didn't think you could select SLX as the Windows 10 default music app. But that should not matter to get the media keys to work.

    R Greg Dawson
    Squeezelite-X

  6. #1026
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    623
    Quote Originally Posted by Stan Pulsar View Post
    I have no other media app open at the same time. Is there any way of finding out if they're registered by another app ?
    If you press F12, you will see a log window. Look for a log entry shortly after "Start InitProgram" that says "Registering Media Keys". If they cannot be registered you will see a log entry saying such.

    R Greg Dawson
    Squeezelite-X

  7. #1027
    Thanks for the suggestions.

    Chrome is not my main browser (although installed, but without any further extension than the few default "Google docs" ones)
    Firefox is, but I have no such "multimedia" extension.

    SL-X log after startup says :
    Code:
    09:06:42.492   ----------------------------------------------------------------------------------------------------
                    Start InitProgram
                    ----------------------------------------------------------------------------------------------------
     09:06:42.497   Read Settings From Registry
     09:06:42.513   SyncMemo called.
     09:06:42.514   Init Tray Menu
     09:06:42.514   Registering MediaKeys
     09:06:42.601   ConnectAll Called
     09:06:42.609   Broadcast Discovery packet 'e' with 'eNAME'#0'JSON'#0'CLIP'#0'VERS'#0 to [192.168.0.255]
     09:06:42.666   Server Discovery Complete: JOES-CLOUD,V-RADIO [59ms]
     09:06:42.668   SyncMemo called.
     09:06:42.668   Save Settings To Registry
    SL-X is not part of the possible choices for the default music app. (maybe it would be if I chose "open with..." from a right click on an audio file, but anyway this is not a setting I want)

    BTW : I have a logitech keyboard with media keys (and other shortcuts) accessible by 'Fn' + pressing on F keys.
    There's an option in the kb settings to switch behaviour and have shortcuts/media keys accessible on direct F key action. Tried this too, no change.
    Again, when I launch my default media player ('Media Player Classic'), media keys are working. (MPC is not running when I try SL-X)

    I browsed trough running processed in task manager, saw nothing media related.
    Last edited by Stan Pulsar; 2019-10-10 at 00:28. Reason: added "BTW ..."

  8. #1028
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    623
    Quote Originally Posted by Stan Pulsar View Post
    Thanks for the suggestions.

    Chrome is not my main browser (although installed, but without any further extension than the few default "Google docs" ones)
    Firefox is, but I have no such "multimedia" extension.

    SL-X log after startup says :
    Code:
    09:06:42.492   ----------------------------------------------------------------------------------------------------
                    Start InitProgram
                    ----------------------------------------------------------------------------------------------------
     09:06:42.497   Read Settings From Registry
     09:06:42.513   SyncMemo called.
     09:06:42.514   Init Tray Menu
     09:06:42.514   Registering MediaKeys
     09:06:42.601   ConnectAll Called
     09:06:42.609   Broadcast Discovery packet 'e' with 'eNAME'#0'JSON'#0'CLIP'#0'VERS'#0 to [192.168.0.255]
     09:06:42.666   Server Discovery Complete: JOES-CLOUD,V-RADIO [59ms]
     09:06:42.668   SyncMemo called.
     09:06:42.668   Save Settings To Registry
    SL-X is not part of the possible choices for the default music app. (maybe it would be if I chose "open with..." from a right click on an audio file, but anyway this is not a setting I want)

    BTW : I have a logitech keyboard with media keys (and other shortcuts) accessible by 'Fn' + pressing on F keys.
    There's an option in the kb settings to switch behaviour and have shortcuts/media keys accessible on direct F key action. Tried this too, no change.
    Again, when I launch my default media player ('Media Player Classic'), media keys are working. (MPC is not running when I try SL-X)

    I browsed trough running processed in task manager, saw nothing media related.
    Judging from the log, it appears that the media Windows media keys are not failing to register as hot keys. So I am not sure why they are not working for you.I'll have to dig deeper into this. It may be something odd with that keyboard.

    You are also correct about SLX not a possible choice for making the default music app. SLX is not designed to do that (at least at this point).

    R Greg Dawson
    Squeezelite-X

  9. #1029
    Senior Member
    Join Date
    Jan 2016
    Location
    Colorado Springs, CO, USA
    Posts
    623

    Version 2.4.19 Submiitted to MS Store

    I just submitted version 2.4.19 to MS Store. Should see it in a couple days.

    Changes:

    • Latest version of Chromium Embedded Framework
    • Startup speed improvements
    • The persistent cache has returned. It is faster not to clear the cache on startup, so I returned to using a persistent browser cache as part of my recent focus on speed improvements.
    • Some plumbing improvements beneath the covers.
    • Accommodate/deconflict Material Skin shortcut keys. I guess I never documented SLX's shortcut keys. Ctrl-Enter takes you into settings (It used to be F2). F12 brings up the log Window. F1 will show help screen if you are already in settings. Drop-down combos can be operated with keyboard using F4. Spacebar will toggle toggle switches, or push buttons that have focus. Ctrl-Shift-D will make some debug/testing controls visible in settings. F5 refreshes the browser.


    R Greg Dawson
    Squeezelite-X

  10. #1030
    Junior Member
    Join Date
    Oct 2019
    Posts
    1

    New install of Squeezelite-X won't launch in Windows 10?

    on a new windows 10 build I downloaded Squeezelite-X from the windows store. It launches with an incomplete splash screen and then disappears. Trying to run as an administrator does the same thing. I browsed the forum - but didn't seem to see anything. Any suggested troubleshooting steps would be appreciated. Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •