Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Junior Member
    Join Date
    Mar 2011
    Posts
    15

    MPEG-4 AAC, France Musique Podcasts

    Hello All.

    First Apologizes if this question has already been asked. I 've been unable to solve my problem.

    I'm used to listen France-Musique Podcast.
    It seems that they change the stream format from mp3 to m4a. Now I cannot listen to them anymore.

    I'm Using Logitech Media Server Version : 7.7.6 - 1452060463 @ Thu Jan 21 02:17:04 UTC 2016 on a *Synology Nas DS115J* (DSM 6.1.4-15217 Update 2)
    The stream that I try to listen is http://media.radiofrance-podcast.net...21518069-0.m4a

    From Open-Jazz RSS : radiofrance-podcast.net/podcast09/rss_12283.xml

    I have no relevant events in log file
    Dec 10 09:34:38 squeezeplay: INFO applet.NowPlaying - NowPlayingApplet.lua:422 enable volume UI in NP
    Dec 10 09:34:47 squeezeplay: INFO applet.NowPlaying - NowPlayingApplet.lua:422 enable volume UI in NP

    The File format (once downloaded) is MPEG-4 encapsulated AAC codec :

    General
    Complete name : \\nasdelicat\downloads\12283-08.12.2017-ITEMA_21518069-0.m4a
    Format : MPEG-4
    Format profile : Base Media
    Codec ID : isom (isom/iso2/mp41)

    Audio
    ID : 1
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 55 min 0 s
    Bit rate mode : Variable
    Bit rate : 192 kb/s
    Maximum bit rate : 195 kb/s
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 kHz
    Frame rate : 46.875 FPS (1024 spf)
    Compression mode : Lossy
    Stream size : 75.5 MiB (99%)
    Default : Yes


    I try to set to "Désactivé" . (Disabled in English language ?) The files type in advanced settings of LMS


    MPEG-4 AAC Désactivé
    FLAC faad/flac
    MP3 Désactivé
    PCM faad

    That does not fix my issue.

    The wiki explains the way to get AAC playable on Synology Disk Station( with http://wiki.slimdevices.com/index.php/AAC ). I'm not sure that this solution is ok for DS115J since it is an ARM processor (MARVELL Armada 370).
    In fact I wonder now if it is a DS115J issue or LMS issue



    What could I Try ?

    Thank you for your help.

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,792
    The issues is not audio encoding (AAC) but the transport MP4.

    The podcast will identified as MP4 type by LMS but standard LMS convert utility faad cannot handle streaming MP4 only MP4 files. One solution is to use a custom-convert.conf and use ffmpeg (or avconv) instead of faad - not sure if they available for your NAS.

  3. #3
    Junior Member
    Join Date
    Mar 2011
    Posts
    15
    Server is able to read the file once downloaded.
    What is not working is playing directly from remote URL.

    (I try fo find the issue, someone post about this in this forum).

  4. #4
    Junior Member
    Join Date
    Mar 2011
    Posts
    15
    Quote Originally Posted by bpa View Post
    The issues is not audio encoding (AAC) but the transport MP4.

    The podcast will identified as MP4 type by LMS but standard LMS convert utility faad cannot handle streaming MP4 only MP4 files. One solution is to use a custom-convert.conf and use ffmpeg (or avconv) instead of faad - not sure if they available for your NAS.

    Thank you for your answer . I replyed before seeing It !


  5. #5
    Junior Member
    Join Date
    Mar 2011
    Posts
    15
    I created a custom-convert.conf and edit it with vi. (using Tabs not space)
    fmp4 mp3 * *
    # FRB:{BITRATE=-B %B}T:{START=-ss %s}
    [ffmpeg] -loglevel info -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

    mp4 pcm * *
    # FRB:{BITRATE=-B %B}T:{START=-ss %s}
    [ffmpeg] -loglevel info -f mp4 -i $FILE$ -f u16le -

    mp4 flc * *
    # FRB:{BITRATE=-B %B}T:{START=-ss %s}
    [ffmpeg] -loglevel info -f mp4 $START$ -i $FILE$ -f flac -

    ~


    log level info to try to find why it does not still work.
    On player side, it tries to listen mp3 streams from LMS on my NAS, but stops after 7s

    Dec 10 17:09:38 squeezeplay: INFO audio.decode - decode_start_handler:279 init decoder flc
    Dec 10 17:09:38 squeezeplay: INFO audio.decode - Playback.lua:476 connect 192.168.0.10:9002 GET /stream.mp3?player=00:04:20:2e:64:28 HTTP/1.0^M
    Dec 10 17:09:39 squeezeplay: WARN applet.AlarmSnooze - AlarmSnoozeApplet.lua:323 notify_playerModeChange: - audioState is 0
    Dec 10 17:09:44 squeezeplay: WARN applet.AlarmSnooze - AlarmSnoozeApplet.lua:323 notify_playerModeChange: - audioState is 0
    Dec 10 17:09:47 squeezeplay: WARN net.thread - NetworkThread.lua:146 network thread timeout for Task(SocketHttp {nasdelicat_Request}(R))
    Dec 10 17:18:28 squeezeplay: INFO audio.decode - decode_start_handler:279 init decoder flc
    Dec 10 17:18:28 squeezeplay: INFO audio.decode - Playback.lua:476 connect 192.168.0.10:9002 GET /stream.mp3?player=00:04:20:2e:64:28 HTTP/1.0^M
    Dec 10 17:18:29 squeezeplay: WARN applet.AlarmSnooze - AlarmSnoozeApplet.lua:323 notify_playerModeChange: - audioState is 0
    Dec 10 17:18:35 squeezeplay: WARN applet.AlarmSnooze - AlarmSnoozeApplet.lua:323 notify_playerModeChange: - audioState is 0


    On server side .. Nothing concerning playing in the server.log file (Last event is the restart of LMS)

    ffmpeg is present on my NAS .


    ..

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,792
    The following works oK on my system.
    Code:
    mp4 mp3 * *
    	# FRB:{BITRATE=-B %B}T:{START=-ss %s}
    	[avconv] -loglevel quiet  -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -
    
    mp4 pcm * *
    	# FRB:{BITRATE=-B %B}T:{START=-ss %s}
    	[avconv] -loglevel quiet  -f mp4 -i $FILE$ -f u16le -
    
    mp4 flc * *
    	# FRB:{BITRATE=-B %B}T:{START=-ss %s}
    	[avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -
    Remember you need a tab before the "# FRB" and the [avconv] or [ffmpeg]

    check your filetypes has under mp4 has ffmpeg/flac and not faad/flac. make sure all entries under mp4 are not disabled.

    Use the LMS logging player.source set to debug - not the squeezlite log.
    Last edited by bpa; 2017-12-10 at 15:05.

  7. #7
    Junior Member
    Join Date
    Mar 2011
    Posts
    15
    OK
    Thanks for your response.
    unfortunaly lame is not available on my NAS
    I will try to build it this week-end with toolchain provided by syno
    https://sourceforge.net/projects/dsgpl/

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,792
    Quote Originally Posted by Curl_ View Post
    OK
    Thanks for your response.
    unfortunaly lame is not available on my NAS
    I will try to build it this week-end with toolchain provided by syno
    https://sourceforge.net/projects/dsgpl/
    Lame is not used unless transcoding to MP3. No need to install unless you really need bit rate limiting or are playing to a SliMP3 player.

    I think the problem with your custom-convertt.conf file is that you are missing tabs before the "[ffmpeg]" and then "# FRB" lines.
    Last edited by bpa; 2017-12-12 at 13:12.

  9. #9
    Junior Member
    Join Date
    Mar 2011
    Posts
    15
    Quote Originally Posted by bpa View Post
    I think the problem with your custom-convertt.conf file is that you are missing tabs before the "[ffmpeg]" and then "# FRB" lines.
    I wish it could be !

    cat -A custom-convert.conf
    mp4 mp3 * *$
    ^I# FRB:{BITRATE=-B %B}T:{START=-ss %s}$
    ^I[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -$
    $
    mp4 pcm * *$
    ^I# FRB:{BITRATE=-B %B}T:{START=-ss %s}$
    ^I[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f u16le -$
    $
    mp4 flc * *$
    ^I# FRB:{BITRATE=-B %B}T:{START=-ss %s}$
    ^I[ffmpeg] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -$

  10. #10
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    15,792
    What are the entries for MPEG-4 in WebUI Setting/Advanced/Filetypes ?

    enable the logging of player.source set to DEBUG to see what is happening when playing the podcast - it is possible your LMS is not accessing podcasts as it does on my system.

    check whether ffmpeg actually runs on your system (i.e. there are no missing libraries)
    Last edited by bpa; 2017-12-16 at 02:38.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •