Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Senior Member
    Join Date
    Feb 2009
    Posts
    234

    LMS search doesn't support Unicode?

    I have a number of Unicode (Chinese) tagged files in my library, which are properly indexed and playable on lms. However, I just found out that I can't search for them with the search function on lms, i.e. I search for the exact keyword that should come up with something, but the search comes out empty. Maybe it has been like that all along for the many years I've been using the lms ecosystem and I just never tried before? Or is there a setting i missed?

    Thanks.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,004

    LMS search doesn't support Unicode?

    > I have a number of Unicode (Chinese) tagged files in my library, which
    > are properly indexed and playable on lms. However, I just found out
    > that I can't search for them with the search function on lms, i.e. I


    Could you please check whether this is a web UI only issue? Or mobile?
    What if you disabled the fulltext search plugin?

    --

    Michael

  3. #3
    Senior Member
    Join Date
    Feb 2009
    Posts
    234
    Quote Originally Posted by mherger View Post
    > I have a number of Unicode (Chinese) tagged files in my library, which
    > are properly indexed and playable on lms. However, I just found out
    > that I can't search for them with the search function on lms, i.e. I


    Could you please check whether this is a web UI only issue? Or mobile?
    What if you disabled the fulltext search plugin?

    --

    Michael
    It happens on both web ui and app. However, disabling full text search plugin seems to solve the issue. What is the difference with using fulltext search anyway?

    Thanks.

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,004

    LMS search doesn't support Unicode?

    > It happens on both web ui and app. However, disabling full text search
    > plugin seems to solve the issue.


    Ok... not good. Thanks for the heads up.

    > What is the difference with using
    > fulltext search anyway?


    "tender elvis" would easily give you Elvis Presley's "Love Me Tender",
    but not "Try a little Tenderness" by The Committments. It allows you to
    search across titles, names, genres etc. without the need to respect
    word order etc.

    --

    Michael

  5. #5
    Senior Member
    Join Date
    Feb 2009
    Posts
    234
    Thanks. I'll do without the plugin for now and look forward to a fix.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,004
    The few files I've found in my test library seems to be working just fine (with Cyrillic this is):

    Name:  Bildschirmfoto 2017-11-29 um 16.57.18.png
Views: 153
Size:  91.5 KB

    Maybe you can send me a copy of a sample file?

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  7. #7
    Senior Member
    Join Date
    Feb 2009
    Posts
    234
    Quote Originally Posted by mherger View Post
    The few files I've found in my test library seems to be working just fine (with Cyrillic this is):

    Name:  Bildschirmfoto 2017-11-29 um 16.57.18.png
Views: 153
Size:  91.5 KB

    Maybe you can send me a copy of a sample file?

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a
    Just did that. For example, if you search for the character " 李 ", I would expect this artist would come up, but it doesn't.

    Thanks.

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,004
    Like this?...

    Name:  Bildschirmfoto 2017-12-01 um 05.43.25.png
Views: 135
Size:  54.6 KB

    Must be something about your configuration. What OS are you running LMS on? What LMS build? What country settings?

    Maybe you could post Settings/Information.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  9. #9
    Senior Member
    Join Date
    Feb 2009
    Posts
    234
    Quote Originally Posted by mherger View Post
    Like this?...

    Name:  Bildschirmfoto 2017-12-01 um 05.43.25.png
Views: 135
Size:  54.6 KB

    Must be something about your configuration. What OS are you running LMS on? What LMS build? What country settings?

    Maybe you could post Settings/Information.
    Interesting. I'm running digimaster's qpkg on my qnap 469L. Is there a country setting? Here's the settings information page.
    Name:  Screenshot_2017-12-01-20-36-00_1.jpg
Views: 132
Size:  162.8 KB Thanks.

  10. #10
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,004

    LMS search doesn't support Unicode?

    > Interesting. I'm running digimaster's qpkg on my qnap 469L. Is there a
    > country setting? Here's the settings information page.


    Hmm... the configuration imho is looking good. I'm running out of idea
    here...


    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •