Home of the Squeezebox™ & Transporter® network music players.
Page 5 of 72 FirstFirst ... 345671555 ... LastLast
Results 41 to 50 of 718
  1. #41
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Oke could be, my Qnap is a ts-453a and starting developing Qnap-LogitechMediaServer, after the update to QTS 4.3.
    Because after the upgrade SSOTS/SSODS was giving trouble.
    The big problem is, that i can not make it for any other arch then 64 bits/ELF64, because i only have the ts-453a.
    Do you have a working perl with LogitechMediaServer on you're Qnap, if so let me know so i can suply you a version with out Perl.
    Spotty/YouTube wont work, because they are perl/cpan modules and part of the perl installation.

    But be aware LogitechMediaServer is accepting Perl to reside in /usr/bin, a work around is to symlink it there.

    Compiling/make perl from source on a Qnap systems is a big problem.

    Another qeustion why don't you upgrade to QTS4.3 ?

    Quote Originally Posted by qnapfan View Post
    Hi digimaster, tanks for your answer.
    The perl package you are delivering uses dynamic libs, in this case libnsl, the libnsl that on my system resides is somehow 32-bit, that causes the Problem. In case i did not installed this lib.
    Just for testing i installed via entware-ng per 5.24.1 (64 bit) this runs without any problems (the libnsl is not beeing loaded) but is not compatible with your package. So i need to find out where the lib came from. Your System is a QTS 4.3 mine is a QTS 4.2.6 so the enviroment is different, maybe that is also a Problem. Or my lib directroy is somehow broken, i need a way to compare it against a plain QTS 4.2.6 (TS-459-Pro+) System.

    EDIT
    The more dig into that issue, i'll quess the QTS 4.2X releases are mixed 64/32 bit, kernel is 64 bit but the most libs are 32bit only a few are 64 bit, sop that is my Problem with you package.
    Are you able to compile a 32bit perl Version of your package or can you share your build scripts ?
    regards

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  2. #42
    Junior Member
    Join Date
    Dec 2017
    Posts
    15
    Hi digimaster,

    well the QTS 4.3 relases are not available for the TS-459Pro+.
    I have a running perl 5.2.4.1, i even compiled some of the missing modules, and was able to pass the start phase, but then other problems occur (to many to count).

    I'll tried to start from scratch, but unfortunatly my entware-ng is 64 so, perl start to compile in 64 bit, and other things.
    Now i created a cross-Compile enviroment so start from scartch in my case an enviroment for GlibC 2.6.1 for x86 progress is ongoing, even compiling arm (did a small test) is working.

    The same could be done in "minutes" on a one off my raspberrys or a the tinkerboard, but my ts-459 is running good and has power enough ;-) I will keep you updated

  3. #43
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Do you already have a work perl on you're Qnap.
    If so then thats whats the problem, it comes with it own perl which will be active in the QTS system of Qnap.
    If so this will give complications, and should be uninstalled.
    If other programs depend on perl, the installed version is 5.24.0 ELF64.

    Could you do /bin/ls -l /usr/bin/
    And post the outcome here ?


    Quote Originally Posted by qnapfan View Post
    Hi digimaster,

    well the QTS 4.3 relases are not available for the TS-459Pro+.
    I have a running perl 5.2.4.1, i even compiled some of the missing modules, and was able to pass the start phase, but then other problems occur (to many to count).

    I'll tried to start from scratch, but unfortunatly my entware-ng is 64 so, perl start to compile in 64 bit, and other things.
    Now i created a cross-Compile enviroment so start from scartch in my case an enviroment for GlibC 2.6.1 for x86 progress is ongoing, even compiling arm (did a small test) is working.

    The same could be done in "minutes" on a one off my raspberrys or a the tinkerboard, but my ts-459 is running good and has power enough ;-) I will keep you updated

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  4. #44
    Junior Member
    Join Date
    Dec 2017
    Posts
    15
    Hi Digimaster,

    i tried all options regarding your release, with and without perl pre installed, that fact is, the 64 bit release does not match my system and that causes the problems.

    I used a toolchain, compiled perl 5.24 from scratch, compiled the slimserver vendor libs, oppenssl, Mozilla-CA-20160104, Net-SSLeay-1.82 ( build with openssl-1.0.2m ) IO-Socket-SSL-2.052
    After some Problems as my INC path was not matching, i used your qpkg, copied my perl + modules, now after some tweaking (permissions) etc i got it starting :-).

    Thanks for your QPKG, that moved into the right direction

    I will do some more testing, if you like i can send you the reuslt, so you propably can use it for your QPKG as an multi processor architecture QPKG
    regards

  5. #45
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by qnapfan View Post
    Hi Digimaster,

    i tried all options regarding your release, with and without perl pre installed, that fact is, the 64 bit release does not match my system and that causes the problems.

    I used a toolchain, compiled perl 5.24 from scratch, compiled the slimserver vendor libs, oppenssl, Mozilla-CA-20160104, Net-SSLeay-1.82 ( build with openssl-1.0.2m ) IO-Socket-SSL-2.052
    After some Problems as my INC path was not matching, i used your qpkg, copied my perl + modules, now after some tweaking (permissions) etc i got it starting :-).

    Thanks for your QPKG, that moved into the right direction

    I will do some more testing, if you like i can send you the reuslt, so you propably can use it for your QPKG as an multi processor architecture QPKG
    regards
    If you got a perl ELF32, which works with lms and has spotty and youtube work. Sure would be a extra arch from Qnap for those users.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  6. #46
    Junior Member
    Join Date
    Dec 2017
    Posts
    15
    Quote Originally Posted by digimaster View Post
    If you got a perl ELF32, which works with lms and has spotty and youtube work. Sure would be a extra arch from Qnap for those users.
    Yes it is a ELF32 Perl.
    Just for my understanding, you used /usr/local/perl during build why not /opt/perl ?
    Anyway i am matching now my build to your locations.

    I forgot to compile JSON 2.90, the youtube plugin works in a short test also with the older JSON relase, but i fix that also.

  7. #47
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by qnapfan View Post
    Yes it is a ELF32 Perl.
    Just for my understanding, you used /usr/local/perl during build why not /opt/perl ?
    Anyway i am matching now my build to your locations.

    I forgot to compile JSON 2.90, the youtube plugin works in a short test also with the older JSON relase, but i fix that also.
    The locations is important for lms, it looks in /usr/bin/ and /usr/local. And /opt is used by Optware / Entware solutions.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  8. #48
    Junior Member
    Join Date
    Jan 2018
    Posts
    6

    Can't log in ip:9001 after install ok

    Hi Digimaster,

    My Qnap NAS is QTS 4.2.5 (TS-669-Pro) System. I can't log in ip:9001 after install "LogitechMediaServer for Qnap x86_64 version 1.02 ( 25-12-2017 )"
    and with following message from ssh:
    "/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer$ ./LogitechMediaServer.sh restart
    Stopping LogitechMediaServer in Background.
    Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    renice: -10: setpriority: No such process
    Starting LogitechMediaServer in Background.
    /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer$ ./LogitechMediaServer.sh failsafe
    ls: /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/templates/: No such file or directory
    Failsafe modus activated, no plugins will be loaded
    Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    renice: -10: setpriority: No such process
    Starting LogitechMediaServer in Background."

    Do you have any suggestions for me? thanks!

  9. #49
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by david572366 View Post
    Hi Digimaster,

    My Qnap NAS is QTS 4.2.5 (TS-669-Pro) System. I can't log in ip:9001 after install "LogitechMediaServer for Qnap x86_64 version 1.02 ( 25-12-2017 )"
    and with following message from ssh:
    "/share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer$ ./LogitechMediaServer.sh restart
    Stopping LogitechMediaServer in Background.
    Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    renice: -10: setpriority: No such process
    Starting LogitechMediaServer in Background.
    /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer$ ./LogitechMediaServer.sh failsafe
    ls: /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/Cache/templates/: No such file or directory
    Failsafe modus activated, no plugins will be loaded
    Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    renice: -10: setpriority: No such process
    Starting LogitechMediaServer in Background."

    Do you have any suggestions for me? thanks!
    Could you do uname - m, and tell me what shows?

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  10. #50
    Junior Member
    Join Date
    Dec 2017
    Posts
    15
    @digimaster
    it bet will show
    Code:
    x86_64
    hell will need the i686 binary, as off the 32bit lib dependencies. i could provide an package

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •