Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 72 FirstFirst ... 234561454 ... LastLast
Results 31 to 40 of 714
  1. #31
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    As SSOTS/SSODS can give conflits, it should be uninstalled.
    Before doning this, you could backup the Cache and prefs directories from the SlimServer/ directory.

    Then after installating Qnap-LogitechMediaServer, you can copy them back in the LogitechMediaServer/SlimServer directory.
    Don`t forget to do chmod -R 0775 SlimServer/ from the .qpkg/LogitechMediaServer directory.

    LMS has no root/admin rights, it runs on squeezeboxserver:nogroup.

    Also very important all the directory`s and file, you want to use in LMS should have 0775, otherwise LMS can not see/read not use them.
    LMS has limited right, and only can read directory and file with 0775.


    Quote Originally Posted by earthbased View Post
    Hi, I have a TS-251A with Celeron N3060 X86-64. Some questions: 1) Since I currently use SSOTS, will using DIGIMASTER package use same install location? 2) If so, will SSOTS cause problems if not uninstalled? 3) In App Center I have LMS listed as 7.7.2 but it stops and starts my current version 7.9.1 so I see no way to use DIGIMASTER package from this App Center as DIGIMASTER stated it could be; do I have to REMOVE LMS from App Center and if so will this cause any problems since I use SSOTS currently? Thx

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  2. #32
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    A shame need more time, getting error trying to add it.
    But will come back on this, once i can fix the errors.

    Quote Originally Posted by scala View Post
    Excellent initiative! This will fill a very huge gap!
    I will try it for sure: I'm currently struggling between maintaining my current ailing installation via SSOTS and a new installation via Container, which seems OK but on which I cannot manage to have spotty working.
    However, before giving it a try, I'd like to ask a couple of questions:
    I definitely need ShairTunes2W, which in turn needs Crypt::OpensSSL::Bignum, Crypt::OpenSSL:Random and Crypt::OpenSSL::RSA. Are these installed in your QPKG?
    Also, I have made many changes to the basic preferences both of the LMS server and of each of the players. Do you know if there is an easy way to copy/paste preferences (I suppose copying some files) from the old LMS to the new installed one?

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  3. #33
    Senior Member
    Join Date
    Apr 2005
    Location
    Milwaukee, WI USA
    Posts
    605
    Quote Originally Posted by digimaster View Post
    As SSOTS/SSODS can give conflits, it should be uninstalled.
    Before doning this, you could backup the Cache and prefs directories from the SlimServer/ directory.

    Then after installating Qnap-LogitechMediaServer, you can copy them back in the LogitechMediaServer/SlimServer directory.
    Don`t forget to do chmod -R 0775 SlimServer/ from the .qpkg/LogitechMediaServer directory.

    LMS has no root/admin rights, it runs on squeezeboxserver:nogroup.

    Also very important all the directory`s and file, you want to use in LMS should have 0775, otherwise LMS can not see/read not use them.
    LMS has limited right, and only can read directory and file with 0775.
    Will installing Qnap-LogitechMediaServer fix the App Center LMS version info mismatch? After all installed, how do I update to new nightly? Thx

  4. #34
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    Quote Originally Posted by earthbased View Post
    Will installing Qnap-LogitechMediaServer fix the App Center LMS version info mismatch? After all installed, how do I update to new nightly? Thx
    Just download it, and put it in the download share off your Qnap. And then stop and start Qnap-LogitechMediaServer from the appstore.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  5. #35
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    785
    Quote Originally Posted by digimaster View Post
    Also very important all the directory`s and file, you want to use in LMS should have 0775, otherwise LMS can not see/read not use them.
    LMS has limited right, and only can read directory and file with 0775.
    Maybe it's a QNAP thing, but my music libraries have 0770 (that's what I get when copying files from Windows to the share) and it works just fine now. I gave RW access to squeezeboxserver in QNAP's ControlPanel / Shared Folders to my music library share.

    Quote Originally Posted by earthbased
    Will installing Qnap-LogitechMediaServer fix the App Center LMS version info mismatch?
    You can change it by editing the entry "Version = 1.01a" under "[LogitechMediaServer]" in /mnt/HDA_ROOT/.config/qpkg.conf

    @Digimaster: I noticed that LMS is not listed as a process in Resource Monitor but filed under "System Processes" instead. Is there a way to fix this?
    Last edited by dolodobendan; 2017-12-21 at 10:27.

  6. #36
    Junior Member
    Join Date
    Dec 2017
    Posts
    15
    @digimaster
    Thanks for your package, unfortunatly ist is not running on TS-459Pro+
    Running qts 4.2.6

    uname shows
    Code:
    Linux qnap459 3.4.6 #1 SMP Tue Sep 5 01:29:53 CST 2017 x86_64 GNU/Linux
    while trying to start
    Code:
    [/opt/LogitechMediaServer] # ./LogitechMediaServer.sh start
    /usr/bin/perl: error while loading shared libraries: libnsl.so.1: wrong ELF class: ELFCLASS32
    Starting LogitechMediaServer in Background.
    [/opt/LogitechMediaServer] # Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    i i tried to to map the libraryh path for testting to:
    Code:
    LD_LIBRARY_PATH=/opt/lib
    result is
    Code:
    [/opt/LogitechMediaServer] # export LD_LIBRARY_PATH=/opt/lib
    [/opt/LogitechMediaServer] # ./LogitechMediaServer.sh start
    Starting LogitechMediaServer in Background.
    [/opt/LogitechMediaServer] # ./LogitechMediaServer.sh: line 103: 27031 Segmentation fault      ${QPKG_ROOT}/SlimServer/slimserver.pl ${COMMAND} > ufuk
    Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    There is someting wrong on my qnap, propably you have an idea.

  7. #37
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    There is something wrong, with you're Qnap, Perl is ELF64/64 bits.
    And this error on you're system should be fixed.
    As that's says it ELF32/32 bits,
    /usr/bin/perl: error while loading shared libraries: libnsl.so.1: wrong ELF class: ELFCLASS32

    greetings

    Quote Originally Posted by qnapfan View Post
    @digimaster
    Thanks for your package, unfortunatly ist is not running on TS-459Pro+
    Running qts 4.2.6

    uname shows
    Code:
    Linux qnap459 3.4.6 #1 SMP Tue Sep 5 01:29:53 CST 2017 x86_64 GNU/Linux
    while trying to start
    Code:
    [/opt/LogitechMediaServer] # ./LogitechMediaServer.sh start
    /usr/bin/perl: error while loading shared libraries: libnsl.so.1: wrong ELF class: ELFCLASS32
    Starting LogitechMediaServer in Background.
    [/opt/LogitechMediaServer] # Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    i i tried to to map the libraryh path for testting to:
    Code:
    LD_LIBRARY_PATH=/opt/lib
    result is
    Code:
    [/opt/LogitechMediaServer] # export LD_LIBRARY_PATH=/opt/lib
    [/opt/LogitechMediaServer] # ./LogitechMediaServer.sh start
    Starting LogitechMediaServer in Background.
    [/opt/LogitechMediaServer] # ./LogitechMediaServer.sh: line 103: 27031 Segmentation fault      ${QPKG_ROOT}/SlimServer/slimserver.pl ${COMMAND} > ufuk
    Something went wrong, check youre configuration. try do ./LogitechMediaServer.sh failsafe !
    There is someting wrong on my qnap, propably you have an idea.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  8. #38
    Senior Member
    Join Date
    May 2017
    Location
    Netherlands
    Posts
    627
    New release of LogitechMediaServer for Qnap x86_64 version 1.02 ( 25-12-2017 )
    MDS5 check [ caa0ba05cca9d7d0f5748605637f8908 build/LogitechMediaServer_1.02_x86_64.qpkg ]

    LogitechMediaServer for Qnap x86_64 version 1.02

    ================= Qnap LogitechMediaSever version 1.02 ===================

    * Major update release, completely redesign installation and inti-script
    * Includes a fix so sox supplied by LogitechMediaSever will work ( libgomp.so.2 missing error )
    * Log-file function expaned, now there also be errors from LMS included. ( can be found in the LogitechMediaServer/ directory. Can help you finding the error.) Also error will be shown in the Qnap webgui.
    * Update routine changed, now there is no downgraded possible anymore. ( see footnote )
    * Change upgrade routine, where only the right tar file will be used.
    * On trouble add extra feature besides ./LogitechMediaServer.sh failsafe.
    Now you can make a file called FAILSAFE in the root directory off .qpkg/LogitechMediaServer. ( see footnote )
    * Installation will keep track of download and installed version.
    * There is no LogitechMediaServer included anymore, at installation will download the latest.
    * Auto-update can be enabled, to always have the latest nightly build from the website.( see footnote )
    * Be aware the directory with you’re music must have reading rights for every group ( chmod -R 0775 [directory] ).

    Included Software :

    LogitechMediaServer Version : On new installation will get latest nightly version.
    Perl 5.24.0
    Mozilla-CA-20160104
    Net-SSLeay-1.82 ( build with openssl-1.0.2m ).
    IO-Socket-SSL-2.052.
    JSON-2.90.

    ----------------------------------------- footnote ----------------------------------------------
    Place a file called UPDATE in the directory /share/*/.qpkg/LogitechMediaServer, will activated auto updated for LogitechMediaServer. If you removed it, this will stop.

    If you want to still downgraded, place the file in the download section off you’re Qnap. Log-on to you’re Qnap system by ssh shell and do [ cd /share/*/.qpkg/LogitechMediaServer ], [ rm .VERSION ] , [ rm SlimServer/.INSTALLED ] and [ ./LogitechMediaServer.sh restart ] .

    Want to activated auto-update to always have the latest release off the nightly build. Log-on to you’re Qnap system by ssh shell and do [ cd /share/*/.qpkg/LogitechMediaServer ], [ touch UPDATE ] and [ ./LogitechMediaServer.sh restart ] .
    Stopping it, do Log-on to you’re Qnap system by ssh shell and do [ cd /share/*/.qpkg/LogitechMediaServer ], [ rm UPDATE ] and [ ./LogitechMediaServer.sh restart ] .

    You're LogitechMediaServer installation wont start, then there are two options. The first Log-on to you’re Qnap system by ssh shell and do [ cd /share/*/.qpkg/LogitechMediaServer ], [ ./LogitechMediaServer.sh stop ] and [ ./LogitechMediaServer.sh failsafe ] . ( it will start LogitechMediaServer without loading the plug-ins, so you can fix or remove any plug-in causing the trouble)
    The second way, if Log-on to you’re Qnap system by ssh shell and do [ cd /share/*/.qpkg/LogitechMediaServer ], [ touch FAILSAFE ] and [ ./LogitechMediaServer.sh restart ]. ( also will then start with loading any plug-in, and will keeping doning this until you remove the file FAILSAFE)
    Stopping it, do Log-on to you’re Qnap system by ssh shell and do [ cd /share/*/.qpkg/LogitechMediaServer ], [ rm FAILSAFE ] and [ ./LogitechMediaServer.sh restart ].
    -----------------------------------------------------------------------------------------------------------------------------------------------------

    LogitechMediaServer for Qnap x86_64 version 1.02

    Last edited by digimaster; 2017-12-25 at 10:16.

    maintainer of QLogitechMediaServer, QOptware-NG and QAutoSub.

    Qnap TS-453a, with LogitechMediaSever 7.9.2 Nightly ( with spotty, youtube, Radio Paradise a.m. )
    Several raspberry with hifiberry amp+ and picoreplayer.
    Love logitechmediaserver for it flexibel way, to play music from different sources.

  9. #39
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    785
    * Includes a fix so sox supplied by LogitechMediaSever will work ( libgomp.so.2 missing error )
    Thank you, now HD FLACs work with my SB Receiver (again?)!

    * Be aware the directory with you’re music must have reading rights for every group ( chmod -R 0775 [directory] ).

    As I've said before, 0770 works (at least in my case) fine, too. Better even, as new files on the share get 0770 by default. (I've granted user "squeezeboxserver" R/W access in QNAP's ControlPanel / Shared Folders).

    @Digimaster: I noticed that LMS is not listed as a process in Resource Monitor but filed under "System Processes" instead. Is there a way to fix this?
    Just curious. I'm now happy again with LMS. I also think it's faster now with your installer. Thank you!

    Merry Christmas!

    Edit: Using 0770 breaks LMS entry "Music Folder", though...
    Last edited by dolodobendan; 2017-12-25 at 14:24. Reason: Update

  10. #40
    Junior Member
    Join Date
    Dec 2017
    Posts
    15
    Quote Originally Posted by digimaster View Post
    There is something wrong, with you're Qnap, Perl is ELF64/64 bits.
    And this error on you're system should be fixed.
    As that's says it ELF32/32 bits,
    /usr/bin/perl: error while loading shared libraries: libnsl.so.1: wrong ELF class: ELFCLASS32

    greetings
    Hi digimaster, tanks for your answer.
    The perl package you are delivering uses dynamic libs, in this case libnsl, the libnsl that on my system resides is somehow 32-bit, that causes the Problem. In case i did not installed this lib.
    Just for testing i installed via entware-ng per 5.24.1 (64 bit) this runs without any problems (the libnsl is not beeing loaded) but is not compatible with your package. So i need to find out where the lib came from. Your System is a QTS 4.3 mine is a QTS 4.2.6 so the enviroment is different, maybe that is also a Problem. Or my lib directroy is somehow broken, i need a way to compare it against a plain QTS 4.2.6 (TS-459-Pro+) System.

    EDIT
    The more dig into that issue, i'll quess the QTS 4.2X releases are mixed 64/32 bit, kernel is 64 bit but the most libs are 32bit only a few are 64 bit, sop that is my Problem with you package.
    Are you able to compile a 32bit perl Version of your package or can you share your build scripts ?
    regards
    Last edited by qnapfan; 2017-12-25 at 17:50. Reason: corrections

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •