Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Oct 2017
    Posts
    4

    Installing Material skin manually

    Hi,

    Been searching the answer in the forum for a few days, apologies if is there, couldn't find a solution.

    I'm trying to install Material skin on the LMS. The HW is an old ARM platform running old Debian port, not supported for a few years now, but still functions well for running the LMS. When enabling the skin in the plugins, nothing happens, checking the log files shows that an https request to fetch the skin times out. The address used there is correct. I tried to install it manually, extracting the ZIP file and placing it in the InstalledPlugins, this fails on Perl unable to find the skin module in the @INC path.

    I was wondering if there is a solution to the above issues, or a way to install the skin manually.

    Thanks,
    Amit

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    Installing Material skin manually

    > I tried to install it manually, extracting the ZIP file and placing it
    > in the InstalledPlugins, this fails on Perl unable to find the skin
    > module in the @INC path.


    Don't mess with the InstalledPlugins folder. See Settings/Information
    where the Plugins folder is.

    --

    Michael

  3. #3
    Junior Member
    Join Date
    Oct 2017
    Posts
    4
    Plugins line in settings/information is:

    Plugin Folders /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins, /usr/sbin/Plugins, /usr/share/squeezeboxserver/Plugins

    Copied the Material folder to these folders. The plugin the settings/plugin was still reporting failed to load. On the setting/interface/Web Interface there was a new option for Material. Selecting it and restarting the server, ended with nothing displayed when reloading it. That is, a blank page instead of the regular LMS web interface. A step forward, seems that something is still missing to generate the page.

    Thanks,
    Amit

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430
    Only copy the folder to /usr/share/squeezeboxserver/Plugins, not in all these places! I said don't mess with InstalledPlugins...

    The folder should be called just MaterialSkin, no version number etc.
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  5. #5
    Junior Member
    Join Date
    Oct 2017
    Posts
    4
    Thanks a lot, working perfectly.

    Amit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •