Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    LMS only accepts wrong password oldfor mysqueezebox

    Platform: amd64, windows 8
    Logitech Media Server Versjon: 7.7.6 - 1521467459 @ Thu Mar 29 16:46:01 WEDT 2018

    I haven't started LMS locally for a long time, and when I started it
    today everything looked a bit strange:
    1. No iTunes songs were shown
    2. The plugins I had been using previously (e.g. TIDAL) weren't shown
    3. Basically nothing worked: no internet radio stations, nothing

    But LMS did pick up a squeezebox duet that haven't been running for two
    years (which was the purpose of starting LMS).

    I suspected something was wrong with the mysqueezebox connection. I have
    switched password on mysqueezebox since LMS was last started.

    When I opened the settings from LMS and selected the mysqueezebox.com
    tab and typed in the new mysqueezebox password and clicked on the "Use"
    button, I was told "Illegal username or password".

    When I typed in the old password, LMS didn't complain (but things don't
    work).

    Does anyone know why only the old password is accepted?

    Thanks!



  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,002
    If you want to use internet radio - you should upgrade to 7.9.2 as https support in 7.7 might be minimal. I suspect a lot of other issue might also be fioxed using a latest version.

    7.7.6 is last Logitech version of LMS. 7.9.* is community version which is where all new code and fixes are added.
    http://downloads.slimdevices.com/nightly/?ver=7.9

  3. #3

    LMS only accepts wrong passwordoldfor mysqueezebox

    >>>>> bpa <bpa.9c58rz (AT) no-mx (DOT) forums.slimdevices.com>:

    > If you want to use internet radio - you should upgrade to 7.9.2 as https
    > support in 7.7 might be minimal. I suspect a lot of other issue might
    > also be fioxed using a latest version.


    > 7.7.6 is last Logitech version of LMS. 7.9.* is community version which
    > is where all new code and fixes are added.
    > http://downloads.slimdevices.com/nightly/?ver=7.9


    Thanks!

    More stuff is working. It rescanned the old iTunes database.

    And it shows the TIDAL playlist the duet receiver was playing when it
    dies, and is able to play it.

    But TIDAL is not showing up under "My services" (even though the SB duet
    receiver is able to play the existing play lost).

    And when I click on "Service list" it says "www.mysqueezebox.com
    rejected the connection attempt".

    I am sure the password is correct.

    Is there a firewall I need to open?



  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,002
    [QUOTE=steinarb;959616]>>>>> bpa <bpa.9c58rz (AT) no-mx (DOT) forums.slimdevices.com>:

    > If you want to use internet radio - you should upgrade to 7.9.2 as https
    > support in 7.7 might be minimal. I suspect a lot of other issue might
    > also be fioxed using a latest version.


    > 7.7.6 is last Logitech version of LMS. 7.9.* is community version which
    > is where all new code and fixes are added.
    > http://downloads.slimdevices.com/nightly/?ver=7.9


    Thanks!

    More stuff is working. It rescanned the old iTunes database.
    And it shows the TIDAL playlist the duet receiver was playing when it
    dies, and is able to play it.

    But TIDAL is not showing up under "My services" (even though the SB duet
    receiver is able to play the existing play lost).
    Can't help with TIDAL as I don't use it.
    I also don't actively use mysqueezebox.com - so where do you see the "my Services" is it a TIDAL menu ?

    Please clarify your status.
    Do you now have two problems.
    1. Can't play TIDAL when connected to LMS
    2. Can't get Receiver on mysqueezebox.com

    And when I click on "Service list" it says "www.mysqueezebox.com
    rejected the connection attempt".

    I am sure the password is correct.
    But it could be wrong ?

    Is there a firewall I need to open?
    No.

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,355

    LMS only accepts wrong passwordoldfor mysqueezebox

    > And when I click on "Service list" it says "www.mysqueezebox.com
    > rejected the connection attempt".


    Could you please check the server.log? It seems to me we're recently
    seeing more issues with LMS instances being rate limited... which
    doesn't make sense to me, as this part of the code hasn't been touched
    in years.

    --

    Michael

  6. #6

    LMS only accepts wrong passwordoldfor mysqueezebox

    >>>>> bpa <bpa.9c5c3z (AT) no-mx (DOT) forums.slimdevices.com>:

    > Can't help with TIDAL as I don't use it.


    TIDAL itself wasn't too important to me in this context.

    It was just strange that it worked (in the active playlist) but didn't
    show up in the top meny.

    > I also don't actively use mysqueezebox.com - so where do you see the
    > "my Services" is it a TIDAL menu ?


    No, "My services" is on my local LMS. I'm also translating from
    Norwegian text shown in the on screen text (and my translation may be
    off...?)).

    > Please clarify your status.
    > Do you now have two problems.
    > 1. Can't play TIDAL when connected to LMS
    > 2. Can't get Receiver on mysqueezebox.com


    Point 2. is what I'm trying to do.

    Point 1. was just strangeness I saw on the local LMS.

    >>> I am sure the password is correct.


    >> But it could be wrong ?


    Well, I can use the same password to log in directly to https://www.mysqueezebox.com

    I have typed the password carefully and slowly twice, and I have copy
    pasted it in, all with the same results, so I'm as sure I can be that it
    is correct.

    >>> Is there a firewall I need to open?> >


    > No.


    Ok, thanks!


  7. #7

    LMS only accepts wrong passwordoldfor mysqueezebox

    >>>>> Michael Herger <slim (AT) herger (DOT) net>:

    >> And when I click on "Service list" it says "www.mysqueezebox.com
    >> rejected the connection attempt".


    > Could you please check the server.log? It seems to me we're recently
    > seeing more issues with LMS instances being rate limited... which
    > doesn't make sense to me, as this part of the code hasn't been touched
    > in years.


    Here's the server.log going back to january 2017 (before the SB duet
    receiver died on me), going through three versions of LMS (two upgrades
    yesterday):
    https://gist.github.com/steinarb/0f3...20de5870eb1ff8

    The LMS have been running when that PC has been booted, but no SBs have
    been listening (I have a SB Radio talking to mysqueezebox.com and I have
    an SB duet receiver that died in 2017 and now has risen from the dead).

    Starting in October 27 2019, it started complaining about "Illegal
    username and password" and I guess it could be then I switched password
    on mysqueezebox.com:
    ...
    [19-10-27 10:26:54.1609] Slim::Networking::SqueezeNetwork::Players::_player s_error (334) Unable to get players from SN: Invalid JSON response: {"players":[],"error":"Session cookie required","strings":[],"search_providers":[{"after":"top","URL":"http://opml.radiotime.com/Search.aspx?query={QUERY}&partnerId=16","text":"IN TERNET_RADIO"}],"next_poll":86400}, retrying in 86400 seconds
    [19-10-27 10:27:25.1720] Slim::Networking::SqueezeNetwork::_error (596) Unable to login to SN: Ugyldig brukernavn eller passord for mysqueezebox.com.
    [19-10-27 10:27:25.1730] Slim::Networking::SqueezeNetwork::Players::_player s_error (334) Unable to get players from SN: Ugyldig brukernavn eller passord for mysqueezebox.com., retrying in 172800 seconds


  8. #8

    LMS only accepts wrong passwordoldfor mysqueezebox

    >>>>> Steinar Bang <sb (AT) dod (DOT) no>:

    > Here's the server.log going back to january 2017 (before the SB duet
    > receiver died on me), going through three versions of LMS (two upgrades
    > yesterday):
    > https://gist.github.com/steinarb/0f3...20de5870eb1ff8


    Would I be better off uninstalling and reinstalling? Is there a
    procedure describing how to scrub an LMS install on windows?

    Thanks!


  9. #9
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,002
    Quote Originally Posted by steinarb View Post
    >>>>> Steinar Bang <sb (AT) dod (DOT) no>:

    > Here's the server.log going back to january 2017 (before the SB duet
    > receiver died on me), going through three versions of LMS (two upgrades
    > yesterday):
    > https://gist.github.com/steinarb/0f3...20de5870eb1ff8


    Would I be better off uninstalling and reinstalling? Is there a
    procedure describing how to scrub an LMS install on windows?
    I think it is unlikely.
    If really necessary, you can easily delete just LMS settings.

    It is better to find and solve the underlying problem - it is is possible it is a Windows and not LMS issue.

  10. #10
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,002
    Had a quick look at the log.

    - Old logs are no use - I'd clear the log so that only recent info is shown - it'll make it easier to post.
    - Try to sort out database issues - use "clear library and rescan everything" to remove the database messages.
    - IIRC there have been issues about use of "unusual" characters in passwords. For testing, try changing the mysqueezebox password to a simple alphanumeric A-Z,a-z,0-9 (no blanks, tabs, accents, punctuation marks, asterisks, underscore etc) and probably only 8 characters.
    - after changing password on mysqueezebox and LMS enabling logging network.squeezenetwork to DEBUG and check the box "Save logging settings for use at next application restart" or "Lagre innstillinger for loggf°ring og bruk dem ved neste programstart" and save the logging settings
    - then restart LMS and post the log entries since the latest restart.
    Last edited by bpa; 2020-01-05 at 07:36.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •