Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Member kezz's Avatar
    Join Date
    Jul 2016
    Location
    Long Island, NY
    Posts
    43

    LMS is stuck in "Starting" on OSX El Capitan

    So I just did a full re-install of LMS on my new server because I could never get it to go into the "Started" phase according to the Preference Pane; after all that I'm still having the same problem. It will reach that state only once, if you restart the server or the computer it will never go back into it again.

    Here's the weird part, everything is up and accessible through the web interface: it can even play streaming media and my apps but it always instantly forgets my library.
    Not great.

    I've ran the commands recommended in posts like these but none of them seem to do anything

    here's a copy of my log:
    Code:
    [17-08-27 21:04:20.2829] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:04:21.8015] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:04:23.5852] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:2a:c6:04, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    [17-08-27 21:04:53.3752] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:04:54.9215] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:44:51.4402] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:44:53.2477] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:44:53.9489] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [17-08-27 21:44:53.9517] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [17-08-27 21:44:54.3838] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [17-08-27 21:44:54.3868] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [17-08-27 21:44:54.5028] Slim::Plugin::MusicMagic::Plugin::initPlugin (155) Can't connect to port 10002 - MusicIP disabled.
    [17-08-27 21:44:54.6901] main::checkDataSource (1110) Warning: Schema updated or no media found in the database, initiating scan.
    [17-08-27 21:48:01.5380] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:48:03.0896] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:48:05.5987] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:27:2b:2b, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    [17-08-27 21:49:04.1390] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:49:05.6609] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:53:48.5176] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:53:50.0478] main::init (387) Starting Logitech Media Server (v7.9.1, 1503129892, Wed Aug 23 20:48:03 PDT 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 21:53:52.4962] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:2a:c6:04, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    Anything look suspicious? Also I'm running 7.9.1; after the reinstall I can see the system information:
    Name:  Screen Shot 2017-08-27 at 10.02.45 PM.png
Views: 133
Size:  54.0 KB

    Hopefully it's not to difficult to resolve; I think I'm just gonna keep my Arch machine on until this gets figured out

    Thanks!
    Last edited by kezz; 2017-08-27 at 19:11. Reason: colon

  2. #2
    Member kezz's Avatar
    Join Date
    Jul 2016
    Location
    Long Island, NY
    Posts
    43

    Nightly

    I'm aware 7.9.1 is a Beta release but I had the same problem with the last release of 7.9.0.

    For some reason on this form only the original post seems to be visible to other people, and edits don't appear for some reason but at least I tried

  3. #3
    Member kezz's Avatar
    Join Date
    Jul 2016
    Location
    Long Island, NY
    Posts
    43

    7.9.0

    This is what my logs looked like when I uninstalled and went back to 7.9.0:
    Code:
    [17-08-27 22:48:49.6618] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar  8 06:00:57 PST 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 22:48:50.3458] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [17-08-27 22:48:50.3483] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [17-08-27 22:48:50.7903] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [17-08-27 22:48:50.7924] Slim::Schema::forceCommit (2149) Warning: Trying to commit transactions before DB is initialized!
    [17-08-27 22:48:50.8965] Slim::Plugin::MusicMagic::Plugin::initPlugin (155) Can't connect to port 10002 - MusicIP disabled.
    [17-08-27 22:48:51.0735] main::checkDataSource (1111) Warning: Schema updated or no media found in the database, initiating scan.
    Bareword "main::SCANNER" not allowed while "strict subs" in use at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OS.pm line 37.
    Compilation failed in require at (eval 3) line 2.
    	...propagated at /System/Library/Perl/5.18/base.pm line 84.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OS/OSX.pm line 9.
    Compilation failed in require at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OSDetect.pm line 74.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/Light.pm line 86.
    Compilation failed in require at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.
    [17-08-27 22:49:58.0767] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar  8 06:00:57 PST 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 22:49:59.5969] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar  8 06:00:57 PST 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-27 22:50:01.7338] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:2a:c6:04, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    [17-08-27 22:50:02.1735] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:27:2b:2b, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    Bareword "main::SCANNER" not allowed while "strict subs" in use at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OS.pm line 37.
    Compilation failed in require at (eval 3) line 2.
    	...propagated at /System/Library/Perl/5.18/base.pm line 84.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OS/OSX.pm line 9.
    Compilation failed in require at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OSDetect.pm line 74.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/Light.pm line 86.
    Compilation failed in require at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.
    Maybe it's the same issue? Something related to SQL?

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,543

    LMS is stuck in "Starting" on OSXEl Capitan

    > I've ran the commands recommended 'in posts like these'
    > (http://forums.slimdevices.com/showth...n-on-Mac/page2)
    > but none of them seem to do anything


    Did you try to run LMS from the command line, too? What did that give you?

    --

    Michael

  5. #5
    Member kezz's Avatar
    Join Date
    Jul 2016
    Location
    Long Island, NY
    Posts
    43
    Well the only thing I know how to do to interact with it via command line is:
    Code:
    /Library/PreferencePanes/Squeezebox.prefPane/Contents/Resources/start-server.sh
    to get it started, but that runs silently and doesn't produce any visible output.

    The good news is for now, inexplicably the system seems to be up and running; I've run the scanner successfully in an attempt to get up and running again and while I still get freaky things in my log like this:
    Code:
    [17-08-28 18:15:11.8772] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar  8 06:00:57 PST 2017) perl 5.018002 - darwin-thread-multi-2level
    [17-08-28 18:15:14.1949] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:27:2b:2b, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    Bareword "main::SCANNER" not allowed while "strict subs" in use at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OS.pm line 37.
    Compilation failed in require at (eval 3) line 2.
    	...propagated at /System/Library/Perl/5.18/base.pm line 84.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OS/OSX.pm line 9.
    Compilation failed in require at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/OSDetect.pm line 74.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/../../Slim/Utils/Light.pm line 86.
    Compilation failed in require at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.
    BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.
    technically right now nothing is broken, but I'll let you know if it stays that way- thanks!

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,543

    LMS is stuck in "Starting" on OSXEl Capitan

    > BEGIN failed--compilation aborted at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Bin/darwin/check-update.pl line 18.

    7.9.0 on macOS unfortunately has this little bug which would prevent the
    automated update check in the background. But this shouldn't limit the
    use of the server itself in any way.

    > technically right now nothing is -broken-, but I'll let you know if it
    > stays that way- thanks!


    Good luck! :-)


    --

    Michael

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •