Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Steven Moore
    Guest

    Is this a bug? song search problem.

    Using a G4 800 mhz imac 512mb, 10.3.7. slim server 5.4.0. Wired
    squeezebox. Netgear adsl router. Music on external FW HD in itunes
    folder, index for itunes is in users directory. No symbolic links.

    I have noticed on a couple of occasions that if I try and search for a
    song. The Squeezebox will display searching.... Then it will display
    empty, but flash an error every 10 seconds or so : "Problem connecting
    to server, check server software is running" and this will continue for
    about 3 mins. Then it will return to normal.
    The SB will not take any input via the remote during this time, any
    songs playing will continue playing okay.
    On checking the computer the server seems to be doing a rescan as the
    external HD is read/writing as when it's doing a rescan.
    Has anyone else found this?
    Should I report this as a bug?
    Thank you.

    Steven Moore

  2. #2
    Steven Moore
    Guest

    Is this a bug? song search problem.

    On looking at the logs for the time the SB stopped taking input I found
    the following:

    2004-12-31 00:25:25.0367 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:25:25.3217 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    2004-12-31 00:25:25.4121 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    Use of uninitialized value in addition (+) at
    /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
    Buttons/Playlist.pm line 183.
    Use of uninitialized value in addition (+) at
    /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
    Buttons/Playlist.pm line 186.
    2004-12-31 00:30:20.7050 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    Use of uninitialized value in addition (+) at
    /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
    Buttons/Playlist.pm line 183.
    Use of uninitialized value in addition (+) at
    /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/
    Buttons/Playlist.pm line 186.
    2004-12-31 00:35:13.5941 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:36:57.7790 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:36:57.7935 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    print() on closed filehandle GEN516 at
    /System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Handle.pm line
    400.
    print() on closed filehandle GEN516 at
    /System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Handle.pm line
    400.
    print() on closed filehandle GEN516 at
    /System/Library/Perl/5.8.1/darwin-thread-multi-2level/IO/Handle.pm line
    400.
    2004-12-31 00:37:56.0502 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:37:56.0735 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    2004-12-31 00:37:56.0889 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:46:58.6271 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:47:59.9660 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    2004-12-31 00:48:00.0255 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:48:00.0563 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:48:00.0664 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    2004-12-31 00:48:38.9792 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    2004-12-31 00:48:39.0776 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:48:39.1103 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 00:48:39.1294 Could not open
    /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    2004-12-31 00:53:01.7891 Could not open
    /Users/steven/Music/Playlists/__history.m3u for writing.
    2004-12-31 01:15:42.7353 Got sigterm.
    2004-12-31 01:15:42.8476 SlimServer cleaning up.
    2004-12-31 01:15:44.0505 Got to the END.
    2004-12-31 01:15:44.1568 Got sigint.
    2004-12-31 01:15:44.1572 SlimServer cleaning up.

    Any help?

    Steven Moore
    On 31 Dec 2004, at 11:24 am, Steven Moore wrote:

    > Using a G4 800 mhz imac 512mb, 10.3.7. slim server 5.4.0. Wired
    > squeezebox. Netgear adsl router. Music on external FW HD in itunes
    > folder, index for itunes is in users directory. No symbolic links.
    >
    > I have noticed on a couple of occasions that if I try and search for a
    > song. The Squeezebox will display searching.... Then it will display
    > empty, but flash an error every 10 seconds or so : "Problem connecting
    > to server, check server software is running" and this will continue
    > for about 3 mins. Then it will return to normal.
    > The SB will not take any input via the remote during this time, any
    > songs playing will continue playing okay.
    > On checking the computer the server seems to be doing a rescan as the
    > external HD is read/writing as when it's doing a rescan.
    > Has anyone else found this?
    > Should I report this as a bug?
    > Thank you.
    >
    > Steven Moore
    >
    >

  3. #3
    Jack Coates
    Guest

    Is this a bug? song search problem.

    Steven Moore wrote:
    > On looking at the logs for the time the SB stopped taking input I found
    > the following:
    >
    > 2004-12-31 00:25:25.0367 Could not open
    > /Users/steven/Music/Playlists/__history.m3u for writing.
    > 2004-12-31 00:25:25.3217 Could not open
    > /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    > 2004-12-31 00:25:25.4121 Could not open
    > /Users/steven/Music/Playlists/__history.m3u for writing.


    which ever user the slimserver is running as doesn't have write access
    to that directory.

    --
    Jack at Monkeynoodle dot Org: It's a Scientific Venture...
    Riding the Emergency Third Rail Power Trip since 1996!

  4. #4
    Steven Moore
    Guest

    Is this a bug? song search problem.

    Thanks John, I checked and the Playlists directory was not there, I
    created it and did a rescan and it seems to have cured the problem.
    Does the Playlists directory get created during installation? If you
    check the server settings the playlists folder is set to
    ...../Playlists. If it's not there there, there could be a problem.

    Thanks for the help.

    Steven Moore
    On 1 Jan 2005, at 3:55 pm, Jack Coates wrote:

    > Steven Moore wrote:
    >> On looking at the logs for the time the SB stopped taking input I
    >> found the following:
    >> 2004-12-31 00:25:25.0367 Could not open
    >> /Users/steven/Music/Playlists/__history.m3u for writing.
    >> 2004-12-31 00:25:25.3217 Could not open
    >> /Users/steven/Music/Playlists/__00_04_20_05_67_f2.m3u for writing.
    >> 2004-12-31 00:25:25.4121 Could not open
    >> /Users/steven/Music/Playlists/__history.m3u for writing.

    >
    > which ever user the slimserver is running as doesn't have write access
    > to that directory.
    >
    > --
    > Jack at Monkeynoodle dot Org: It's a Scientific Venture...
    > Riding the Emergency Third Rail Power Trip since 1996!
    >

  5. #5
    Jack Coates
    Guest

    Is this a bug? song search problem.

    Steven Moore wrote:
    > Thanks John, I checked and the Playlists directory was not there, I
    > created it and did a rescan and it seems to have cured the problem.
    > Does the Playlists directory get created during installation? If you
    > check the server settings the playlists folder is set to ..../Playlists.
    > If it's not there there, there could be a problem.
    >
    > Thanks for the help.
    >


    good point -- what's the platform and how did you install? package or
    tarball?

    --
    Jack at Monkeynoodle dot Org: It's a Scientific Venture...
    Riding the Emergency Third Rail Power Trip since 1996!

  6. #6
    Steven Moore
    Guest

    Is this a bug? song search problem.

    Mac OS X 10.3.7
    Just downloaded the .dmg file, double clicked the installer.

    Steven Moore
    On 1 Jan 2005, at 8:12 pm, Jack Coates wrote:

    > Steven Moore wrote:
    >> Thanks John, I checked and the Playlists directory was not there, I
    >> created it and did a rescan and it seems to have cured the problem.
    >> Does the Playlists directory get created during installation? If you
    >> check the server settings the playlists folder is set to
    >> ..../Playlists. If it's not there there, there could be a problem.
    >> Thanks for the help.

    >
    > good point -- what's the platform and how did you install? package or
    > tarball?
    >
    > --
    > Jack at Monkeynoodle dot Org: It's a Scientific Venture...
    > Riding the Emergency Third Rail Power Trip since 1996!
    >

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •