Home of the Squeezebox™ & Transporter® network music players.
Page 26 of 26 FirstFirst ... 16242526
Results 251 to 255 of 255
  1. #251
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,417
    hi christi_ko,

    I have spent weeks trying to script "adding alternative screens" to piCorePlayer to no avail.

    There are just too many models.

    Here's just Waveshare's RPi screens: https://www.waveshare.com/product/ra...s/lcd-oled.htm

    Then there are all the clones.

    Unfortunately most of the screen manufacturers don't even bother to get their drivers included in the RPi Linux distribution.

    All their install scripts are written for Raspbian (Raspberry Pi OS) and won't work on piCore.

    There is a generic display driver that stopped development years ago. It supports 20 or so screens. Why I mention this is you will see instructions on the web on how to use this driver. I think most screen drivers are based on this generic driver with their long string of parameters hard coded.

    Sorry, not much help.

    regards
    Greg

  2. #252
    Junior Member
    Join Date
    May 2021
    Posts
    5
    Hello,
    I'm trying to connect a 3.5 HDMI touch screen to piCorePlayer+PiZero. A cheap one from aliexpress.

    Everything works fine except the touchscreen and calibration.

    the input devices are changing every few seconds.
    some times: ls /dev/input =event2 mice ts0
    others: ls /dev/input = event0 event1 event2 event2 mice mouse0 mouse0 ts0

    I have tested connecting an external mouse and it works quite well with JIVILITE and 3,5 skin.
    but the touch screen is impossible to center.
    TS_CALIBRATE and TS_TEST work sometimes (depending on the devices).

    the calibration seems to work fine, but the test always comes out wrong, it seems that the X axis and Y axis are reversed.
    any idea about this?
    has it happened to anyone before?
    Thanks!

  3. #253
    Quote Originally Posted by vwpolo View Post
    Hello,
    I'm trying to connect a 3.5 HDMI touch screen to piCorePlayer+PiZero. A cheap one from aliexpress.

    Everything works fine except the touchscreen and calibration.

    the input devices are changing every few seconds.
    some times: ls /dev/input =event2 mice ts0
    others: ls /dev/input = event0 event1 event2 event2 mice mouse0 mouse0 ts0

    I have tested connecting an external mouse and it works quite well with JIVILITE and 3,5 skin.
    but the touch screen is impossible to center.
    TS_CALIBRATE and TS_TEST work sometimes (depending on the devices).

    the calibration seems to work fine, but the test always comes out wrong, it seems that the X axis and Y axis are reversed.
    any idea about this?
    has it happened to anyone before?
    Thanks!
    Yes, I've seen it, where I'm using the screen in landscape, but the touch is set for portrait.

    A simple example of how I fix it in code (Python in this case):

    Code:
      x1 = dev.absinfo(ecodes.ABS_X).value
      y1 = dev.absinfo(ecodes.ABS_Y).value
      x=800-int((y1/480)*800)
      y=480-int(480-(x1/800)*480)
    YMMV.
    piTouchÖ w/JustBoom DigiHat -> RME ADI-2 DAC FS -> JBL 305P MkII monitors; LMS 8.2 on piCorePlayer/Pi 4; Material Skin.

  4. #254
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,965
    Quote Originally Posted by vwpolo View Post
    Hello,
    I'm trying to connect a 3.5 HDMI touch screen to piCorePlayer+PiZero. A cheap one from aliexpress.

    Everything works fine except the touchscreen and calibration.

    the input devices are changing every few seconds.
    some times: ls /dev/input =event2 mice ts0
    others: ls /dev/input = event0 event1 event2 event2 mice mouse0 mouse0 ts0

    I have tested connecting an external mouse and it works quite well with JIVILITE and 3,5 skin.
    but the touch screen is impossible to center.
    TS_CALIBRATE and TS_TEST work sometimes (depending on the devices).

    the calibration seems to work fine, but the test always comes out wrong, it seems that the X axis and Y axis are reversed.
    any idea about this?
    has it happened to anyone before?
    Thanks!
    There's an invert module available in /usr/local/etc/ts.conf which should help.

    To save any changes you make to ts.conf you need to add it to .filetool.lst and backup your config before rebooting.

    Code:
    $ grep ts.conf /opt/.filetool.lst 
    usr/local/etc/ts.conf
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  5. #255
    Junior Member
    Join Date
    May 2021
    Posts
    5
    @ chicks,
    thank you very much for your quick response
    I think it is not applicable.
    I am not programming, I just want to use jivelite.

    @ ralphy
    I'm going to have a look at that module.

    It's looks like a calibration problem. maybe the whole touchscreen system is broken, these aliexpress ones are like that.
    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •