Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27
  1. #21
    Thanks Greg,
    The boot order will help, and it is an easy way to remember the location.
    The logs do no help me much, at least not more than when I tried to find the cause of the driver load failures.
    I fear the timing is the key , and I will see if I can halt and split the automatic startup to check in that part of the process.
    Regards M-H

  2. #22
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,129
    Yes its timing, as you have to work around the soft dependencies.

    I just finished integrating kmod mod utilities, which will upgrade pCP's modprobe to include support for the softdeps.

  3. #23
    Paul ,

    Can I help testing this at this moment ?

    Edit:
    Manually starting the script from the cli does work.
    I reverted to starting a bump.sh, that now does copy a asound.conf and reload the modules and restart squeezelite
    So it does give me an automated start in PCP322, crude but effective

    greetz M-H
    Last edited by M-H; 2017-11-02 at 16:09.

  4. #24
    Junior Member
    Join Date
    Feb 2018
    Posts
    1
    Hello all.

    I have this thread and I still have issue to enable my Wolfson card.
    I just bought it from reichelt.de : "rasp wolf audio"

    I have a Raspberry Pi B and have installed piCorePlayer 3.22 :
    piCorePlayer | piCorePlayer v3.22 | linux 4.9.50-pcpAudioCore | piCore v8.01 | Squeezelite v1.8.7-999

    I have applied those actions :
    tce-load -wi nano.tcz

    mount /mnt/mmcblk0p1/
    sudo nano -w /mnt/mmcblk0p1/config.txt
    --> add dtoverlay=rpi-cirrus-wm5102 - then save your changes

    When I do that, the system doesn't boot.
    So I have removed this line for the moment.

    sudo nano /etc/modprobe.conf
    Add a the following line
    softdep arizona-spi pre: arizona-ldo1

    Then :
    dmesg | egrep 'irrus|rizona'
    --> Nothing found.

    aplay -l
    Code:
    tc@piCorePlayer:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
      Subdevices: 7/8
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
      Subdevice #2: subdevice #2
      Subdevice #3: subdevice #3
      Subdevice #4: subdevice #4
      Subdevice #5: subdevice #5
      Subdevice #6: subdevice #6
      Subdevice #7: subdevice #7
    card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    squeezelite -l
    Code:
    tc@piCorePlayer:~$ squeezelite -l
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      sysdefault:CARD=ALSA           - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
    I also tried these :
    sudo modprobe arizona_micsupp
    sudo modprobe gpio_arizona
    sudo modprobe snd_soc_wm5102
    sudo modprobe snd_soc_arizona

    --> modprobe: module gpio_arizona not found in modules.dep


    Could you please help me to make this card working on my Raspberry ?

    I would be very thankful.

  5. #25
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,129
    This card is not working under 3.22 without alot of tricks. The next version has support for this card. There is not a timeline yet for the next release, there are some bugs we are still working through

  6. #26
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,302
    add dtoverlay= rpi-cirrus-wm5102

    Remove space after "="

  7. #27

    Just adding my voice

    Pi Model B and Wolfson Card - It would be wonderful to get it up and running automatically. I'll give the solutions in the thread a go this weekend in the meantime

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •