Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Aug 2016

    USB Stick Mount Issue PiCore 3.02? Anyone?


    I have installed on a Pi3 PicorePlayer 3.02 (latest version). All seems to work properly but I can't get the USB stick mounted.
    I reformatted the USB stick but no luck. Reformatted with FAT32 or NTFS, does not matter, does not work.
    I tried another USB stick, not working.

    I installed linux.utils as well. No change.

    When I connect the USB stick (any) I can see 4 partitions for some reason.
    When I try to mount one of them I am getting an error, could not mount and reboot.

    Anyone got an idea?

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Sydney, Australia
    Hi jags,

    In my experience USB sticks automatically load under /mnt/sda1. (use df command)

    If it doesn't dynamically load try rebooting or using the command $ sudo mount /dev/sda1

    A USB stick won't have 4 partitions unless you added them.

    You need to supply more info, like type of USB stick, error messages, output of df, what you tried to do to mount it, what were you expecting?

    BTW: I assume you are using piCorePlayer 3.20 beta?


  3. #3
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Vństerňs Sweden
    Reformat the USB stick it may have these extra partitions with bundled spamware.
    Main hifi: Rasbery PI digi+ MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Loggia: Raspi hifiberry dac + Adams
    Bathroom : Radio (with battery)
    iPad with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server Intel NUC Esxi VM Linux mint 18 LMS 7.9.2


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts