Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Senior Member milosz's Avatar
    Join Date
    Apr 2007

    Cannot connect Duet Controller to Receiver for set up

    I have a used Duet; trying to set it up on my network.

    I have re-set the controller to "Factory Default" and reset the Receiver (hold button until fast red blink... then it goes to slow red blink)

    I do NOT see "squeezebox xyz" where xyz is the last part of the Mac address in the Networks list on the controller. I see plenty of WiFi networks but no "squeezebox..." anything.

    So, I plugged the Duet Receiver into my LAN using Ethernet. I can see it has acquired an IP address via DHCP from my router, so I know it's on the LAN. I followed the instructions from http://support.logitech.com/en_sg/article/11914 "Connecting Squeezebox Duet in Hybrid Mode" and it says "After your Controller successfully connects to your network, select ‘Set up Receiver’ and click the center button." <= there is no option anywhere on the Controller labelled 'Set Up Receiver' after my Duet Controller successfully connects to my WLAN.

    What do I do??? How do I configure the receiver?

    I tried connecting the Receiver via Ethernet to a PC and using the UDAP Perl stuff, but after installing all the modules that the error messages complained about I got to an error message that complained that Term::Shell was not found, and no matter what I did I could not find a Term::Shell that I could use, and trying to install it from cpan resulted in errors complaining abut the compiler etc. After 3 hours screwing around trying to get UDAP to work I gave up.

    Am I screwed? Is there any WINDOWS utility that I can use? I've given up trying to use UDAP....

  2. #2
    Senior Member
    Join Date
    Dec 2008
    Alexandria, Va USA
    Your controller is connected to Your wifi, yes?
    The controller should then see the LMS server and allow you to complete the connection.
    2 Duets controllers, 1 X Boom, 1 X Radio
    1 X Receiver + Audioengine A5
    1 X Receiver + Yamaha RX-A2000, Polk M70
    1 X Receiver + Boston MicroSystem CD
    Raspberry Pi 2 B, HiFiBerry Dac+ & Max2play
    HTC 10 w/ Squeeze Ctrl
    ReadyNAS 516 LMS 7.9.1

  3. #3
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Utah, USA
    It doesn't say squeezebox. The controller only show the last portion of the MAC address of the receiver.
    Main system - Rock Solid with LMS 7.9.1 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.1 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave

  4. #4
    Senior Member milosz's Avatar
    Join Date
    Apr 2007

    Doesn't show MAC address or LMS

    Yes the Duet Controller is connected to my WLAN, as I said. I can see it in the network map provided by my router. The WLAN is the same IP network that the Squeezebox Receiver is connected to by Ethernet . There is no option appearing on the Duet Controller to connect to the Duet Receiver. I followed the instructions from Logitech (http://support.logitech.com/en_sg/article/11914) but there's no option showing on the Duet Controller that allows a connection to the Receiver for setting up the Receiver.

    When I tried Wireless mode I followed Logitech's instructions http://support.logitech.com/en_us/article/11915. The only things that appeared in the list of wireless networks on the Duet Controller were local WiFi routers. The Logitech instructions explicitly say "NOTE: Your Squeezebox will be identified by the word ‘Squeezebox’ followed by the last 6 digits of the Receiver’s MAC address. The MAC address is on a sticker on the bottom of the Receiver." No such thing was listed on the Duet Controller's display. There was no string of MAC numbers of any kind appearing in the list of wireless networks on the Duet Controller. All that were listed were WiFi routers that are near me, which I recognized. Things like "Johnson" and "media room" and "Netgear-AC1200" - these are all wifi routers near me. There was nothing appearing in the list that was just a string of numbers, hexadecimal or otherwise.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts