Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Senior Member
    Join Date
    Jun 2010
    Location
    California, USA
    Posts
    222
    I used MBL live before. Fine until my collection getting larger than 30,000 songs (all FLAC) or so. A full scan will take hours and often failed. You will have better luck by removing the cache directory before a full scan. The MBL's hardware has only 256M ram and is not enough for LMS. I am running LMS on a Raspberry pi with a USB attach drive now. A full scan of 50k songs takes less than in 30 minutes.

  2. #12
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Västerås Sweden
    Posts
    16,528
    Also deselect pictures and movies from the scan .
    Tick boxes when selecting the directory to scan .
    These are known to sometimes cause trouble don't use them unless you actually use the features and plugins needing this.
    --------------------------------------------------------------------
    Main hifi: Rasbery PI digi+ MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Loggia: Raspi hifiberry dac + Adams
    Bathroom : Radio (with battery)
    iPad with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server Intel NUC Esxi VM Linux mint 18 LMS 7.9.2

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  3. #13
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    LMS 7.9.0 on WD My Book Live Duo -running after severel tries - than died over night

    > The initial scan as desribed above took less than 10 h - the rescan -
    > even after moving the DB to a larger partition is now performing more
    > than two days.


    Do you know how much memory this device has? Past test have shown that
    there's a "magic number" in the region of 40-50k+ tracks where more
    memory becomes crucial. Where being able to give LMS a maximum memory
    (Settings/Advanced/Performance) would make a huge difference. But you
    should have 1GB at least.

    --

    Michael

  4. #14
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    LMS 7.9.0 on WD My Book Live Duo -running after severel tries - than died over night

    > All scans aborted after little less than 8 minutes! Progress shows a

    Please show us your log files...

    --

    Michael

  5. #15
    Member Black Senator's Avatar
    Join Date
    Apr 2017
    Location
    Region Hannover
    Posts
    31
    First of all thank you for the answers and attempts to help. I really appreciate that.

    Because in the threads single facts are lost here again a summary:

    0. System: MyBookLive Duo 4 TB RAID 1, disks and system without errors (self-test) with 800MHz PowerPC CPU and 256MB of memory
    1. the music collection was already so extensive, as I have installed for the first time LMS and has since grown only insignificantly
    2. old installation with LMS 7.7. * Was "out of the box" - so no changes to the cache, the preinstalled plugins, ... ran smoothly for a long time
    3. Manual scan to capture a few new albums recently resulted in no result
    4. Therefore change the decision to 7.9.0
    5. Several installation attempts broke, therefore try with logitechmediaserver_7.9.1 ~ 1492077569_all.deb
    6. Scan only worked once after several attempts to start
    7. the next day, the server is not reachable and neither after completive reboot nor via via Putty to restart
    8. several more attempts of complete installation with logitechmediaserver_7.9.1 ~ 1492077569_all.deb last with cache moved to "/ Datavolume / .." and all plugins deactivated or only "full text search"
    9. complete scan aborts after 8 minutes
    10. Latest finding: the scan actually ends until the abort, but after 1 minute the progress indicator (recent filename) in the WEB UI is not updated - only the runtime is updated

    Screenshot of last scan - this was the last updated label
    Name:  error4.JPG
Views: 179
Size:  17.9 KB

    till abortion:
    Name:  error5.JPG
Views: 179
Size:  23.4 KB


    Matching log file:
    scanner.log.zip


    Hope for help

    Black Senator

  6. #16
    Member Black Senator's Avatar
    Join Date
    Apr 2017
    Location
    Region Hannover
    Posts
    31

    Claryfication

    Quote Originally Posted by Mnyb View Post
    Also deselect pictures and movies from the scan .
    Tick boxes when selecting the directory to scan .
    Always done so

    Quote Originally Posted by Mnyb View Post
    These are known to sometimes cause trouble don't use them unless you actually use the features and plugins needing this.
    I do not use any plugins except "Full text scan"


    Regards

    Black Senator


    scanner.log.zip
    Last edited by Black Senator; 2017-04-24 at 05:34.

  7. #17
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600
    Quote Originally Posted by Black Senator View Post
    0. System: MyBookLive Duo 4 TB RAID 1, disks and system without errors (self-test) with 800MHz PowerPC CPU and 256MB of memory
    Are you sure about your CPU & RAM? If so, I'd strongly suggest not to waste any more time, but get a Pi instead (to run LMS, keeping the files on the NAS). I'd really be surprised if 256MB would even be enough to scan a library the size of yours. Maybe it did until recently. But at some point one additional album might just be too much.
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  8. #18
    Member Black Senator's Avatar
    Join Date
    Apr 2017
    Location
    Region Hannover
    Posts
    31
    Hi Michael,

    I must disappoint you: If your thesis is correct, then the scan should not break off with a much smaller collection - but he does it in the usual way.

    I moved some 20% of my music library to another location and set the path there.
    The scan aborts as before after about a minute.

    scanner.log.zip

    Regards


    Black Senator

  9. #19
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    LMS 7.9.0 on WD My Book Live Duo -running after severel tries - than died over night

    > I must disappoint you: If your thesis is correct, then the scan should
    > not break off with a much smaller collection - but he does it in the
    > usual way.


    Well, it still dies with the same disk i/o error as before. Disk failure
    isn't limited to memory usage, indeed.

    --

    Michael

  10. #20
    Member Black Senator's Avatar
    Join Date
    Apr 2017
    Location
    Region Hannover
    Posts
    31

    “When you discover you’re riding a dead horse, the best strategy is to dismount.”

    That's what I've done. Fortunately, I had anyway still an alternative parallel: some time after I had put LMS 7.7. * in service, I have additionally a volumio on a Raspberry PI put into operation to feed my livingroom hifi.
    Although I have not found any actual instructions whether volumio 2 and LMS 7.9.0 are operating together - but what I have to lose? I have made a security copy of the SD card and simply installed LMS 7.9.0.
    Runs like clockwork ...

    So problem is solved in dismounting the horse.

    Regards

    Black Senator
    Last edited by Black Senator; 2017-04-29 at 12:39.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •