Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Junior Member
    Join Date
    Feb 2017
    Posts
    13

    LMS : Qobuz plugin stops on connect

    Hello

    Installed Qobuz plugin on LMS (Debian).

    Player don't read files. Qobuz plugin in debug mode says :

    "Plugins::Qobuz::API::_get (642) here qobuz server/api.json/0.2/track/getFileUrl?app_id=&format_id=5&request_sig=a60ab9e e04bf295562d87403780dda87&request_ts=1486375984&tr ack_id=17110879&user_auth_token=

    Nothing after token ?

    Qobuz Premium, set mp3, entered id and pw in plugin config

    Thanks for help!

  2. #2
    Junior Member
    Join Date
    Feb 2017
    Posts
    13

    Bad thread

    Sorry, I did not see the thread

    3rd Party Software : Qobuz.com streaming plugin

    Maybe admin can deplace the post ?

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    LMS : Qobuz plugin stops on connect

    > Player don't read files. Qobuz plugin in debug mode says :

    What do you mean by "don't read files"? Do they not play? Can't you
    browse them?

    > "Plugins::Qobuz::API::_get (642) here qobuz
    > server/api.json/0.2/track/getFileUrl?app_id=&format_id=5&request_sig=a60ab9e e04bf295562d87403780dda87&request_ts=1486375984&tr ack_id=17110879&user_auth_token=
    >
    > Nothing after token ?


    The token is removed from the log file as it is considered sensitive
    data. There's no error message? Neither in the log file nor on the player?

    > Qobuz Premium, set mp3, entered id and pw in plugin config


    Please go to Settings/Advanced/Logging (Préférences/Avancé/Journal?),
    set plugin.qobuz to debug and try again. Then uplod the server.log file
    to this thread or

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    --

    Michael

  4. #4
    Junior Member
    Join Date
    Feb 2017
    Posts
    13
    Quote Originally Posted by mherger View Post
    > Player don't read files. Qobuz plugin in debug mode says :

    What do you mean by "don't read files"? Do they not play? Can't you
    browse them?

    > "Plugins::Qobuz::API::_get (642) here qobuz
    > server/api.json/0.2/track/getFileUrl?app_id=&format_id=5&request_sig=a60ab9e e04bf295562d87403780dda87&request_ts=1486375984&tr ack_id=17110879&user_auth_token=
    >
    > Nothing after token ?


    The token is removed from the log file as it is considered sensitive
    data. There's no error message? Neither in the log file nor on the player?

    > Qobuz Premium, set mp3, entered id and pw in plugin config


    Please go to Settings/Advanced/Logging (Préférences/Avancé/Journal?),
    set plugin.qobuz to debug and try again. Then uplod the server.log file
    to this thread or

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    --

    Michael
    I can browse them, all is ok. The player begins to play (correction : only the cursor begins to move, but no sound) and stop after 1 or 2 seconds.
    Message in the server log following the first message

    Plugins::Qobuz::API::__ANON__ (678) Error: 400 Bad Request

    Nothing else in debug mode...

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    LMS : Qobuz plugin stops on connect

    > I can browse them, all is ok. The player begins to play and stop after 1
    > or 2 seconds.
    > Message in the server log following the first message
    >
    > Plugins::Qobuz::API::__ANON__ (678) Error: 400 Bad Request
    >
    > Nothing else in debug mode...


    If you set the debug mode, then you'll get _tons_ of debug output.
    Please provide the full server.log file.

    --

    Michael

  6. #6
    Junior Member
    Join Date
    Feb 2017
    Posts
    13
    Quote Originally Posted by mherger View Post
    > I can browse them, all is ok. The player begins to play and stop after 1
    > or 2 seconds.
    > Message in the server log following the first message
    >
    > Plugins::Qobuz::API::__ANON__ (678) Error: 400 Bad Request
    >
    > Nothing else in debug mode...


    If you set the debug mode, then you'll get _tons_ of debug output.
    Please provide the full server.log file.

    --

    Michael
    OK, Not in mode debug. I send you the server log on dropbox.

    Thanks for your patience

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    LMS : Qobuz plugin stops on connect

    I'm not seeing anything wrong in your log file. Alas, it's not complete.
    Could you please

    - restart LMS
    - _before_ your use Qobuz, enable debugging for plugin.qobuz, again
    - upload the _full_ server.log file

    Are you sure you correctly entered your username and password in the
    settings of the plugin?

    --

    Michael

  8. #8
    Junior Member
    Join Date
    Feb 2017
    Posts
    13
    Quote Originally Posted by mherger View Post
    I'm not seeing anything wrong in your log file. Alas, it's not complete.
    Could you please

    - restart LMS
    - _before_ your use Qobuz, enable debugging for plugin.qobuz, again
    - upload the _full_ server.log file

    Are you sure you correctly entered your username and password in the
    settings of the plugin?

    --

    Michael
    Hello

    New server log (server1.log) on your dropbox.
    Stopped the server, server.log empty, started server, gone to qobuz plugin, set debug, very carefully entered id an pw, same result :
    begins to load the file and stop after 2 or 3 seconds.
    Is it possible to have a problem with the player (Plugin Squeezelite in Moode audio, but it works fine with local libraries and too with Qobuz using BubbleUpnp on android stuff)?

    Thanks

  9. #9
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    LMS : Qobuz plugin stops on connect

    > Stopped the server, server.log empty, started server, gone to qobuz
    > plugin, set debug, very carefully entered id an pw, same result :
    > begins to load the file and stop after 2 or 3 seconds.


    There's not a single Qobuz related message in there... Are you sure you
    chose the right debug setting? It looks as if you chose server.plugin
    instead.

    One other thing you could try: shut down LMS and remove qobuz.db from
    the cache folder.

    > Is it possible to have a problem with the player (Plugin Squeezelite in
    > Moode audio, but it works fine with local libraries and too with Qobuz
    > using BubbleUpnp on android stuff)?


    I have no idea what "Squeezelite in Moode audio" is.

    --

    Michael

  10. #10
    Junior Member
    Join Date
    Feb 2017
    Posts
    13
    Quote Originally Posted by mherger View Post
    > Stopped the server, server.log empty, started server, gone to qobuz
    > plugin, set debug, very carefully entered id an pw, same result :
    > begins to load the file and stop after 2 or 3 seconds.


    There's not a single Qobuz related message in there... Are you sure you
    chose the right debug setting? It looks as if you chose server.plugin
    instead.

    One other thing you could try: shut down LMS and remove qobuz.db from
    the cache folder.

    > Is it possible to have a problem with the player (Plugin Squeezelite in
    > Moode audio, but it works fine with local libraries and too with Qobuz
    > using BubbleUpnp on android stuff)?


    I have no idea what "Squeezelite in Moode audio" is.

    --

    Michael
    Hello
    Qobuz debug was on (in fact server debug was on too ...). Erased qobuz cache, but nothing better. I sent you the last log (only qobuz debug), but I see nothing different.

    N.B. : Moode Audio (http://moodeaudio.org) is an audio player on Raspberry Pi and Squeezelite is a LMS client . I use the Pi with a Steinberg UR22 DAC.

    Many thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •