Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Member ltsv38's Avatar
    Join Date
    Jul 2008
    Location
    Grenoble - France
    Posts
    88

    Stops in broadcast

    Hello

    For a few weeks now when I start listening to a radio or a podcast, I have a complete cut in the broadcast after one or two minutes. If I restart the playback manually, everything starts ... to stop again. After a 3rd attempt everything goes well: the playback is continuous and correct.
    I use the LMS 7.9.0 under Ubuntu with the latest build (beta) on different SB Radio (mostly with a wired connection): the latest updates of the LMS have not fixed this issue.

    When looking at the LMS log file I see lines with "Logitech Media Server died. Restarting." without any clear reason
    Can be found today in the following log file extract at 08:39 and 13:37 for example. The servers also died at 03:04: just after the automatic rescan of the library (every night a 03:00)

    Code:
    2016-12-09 03:04:41 Logitech Media Server died. Restarting.
    [16-12-09 03:04:47.2010] main::init (384) Starting Logitech Media Server (v7.9.0, 1481125532, Wed Dec  7 17:16:54 UTC 2016) perl 5.022002 - x86_64-linux-gnu-thread-multi
    [16-12-09 03:04:49.9260] Slim::Utils::Misc::msg (1244) Warning: [03:04:49.9252] $[ used in numeric lt (<) (did you mean $] ?) at /usr/share/squeezeboxserver/CPAN/PAR.pm line 576.
    [16-12-09 03:04:51.4118] Slim::Music::VirtualLibraries::registerLibrary (209) Can't create the library view at this point, as the scanner is running: Pistes HD uniquement
    [16-12-09 03:04:51.4134] Slim::Music::VirtualLibraries::registerLibrary (209) Can't create the library view at this point, as the scanner is running: Pistes Lossless uniquement
    [16-12-09 03:04:51.4149] Slim::Music::VirtualLibraries::registerLibrary (209) Can't create the library view at this point, as the scanner is running: Pistes Lossy uniquement
    2016-12-09 08:39:56 Logitech Media Server died. Restarting.
    [16-12-09 08:40:00.4639] main::init (384) Starting Logitech Media Server (v7.9.0, 1481125532, Wed Dec  7 17:16:54 UTC 2016) perl 5.022002 - x86_64-linux-gnu-thread-multi
    [16-12-09 08:40:06.9814] Slim::Utils::Misc::msg (1244) Warning: [08:40:06.9807] $[ used in numeric lt (<) (did you mean $] ?) at /usr/share/squeezeboxserver/CPAN/PAR.pm line 576.
    2016-12-09 13:37:38 Logitech Media Server died. Restarting.
    [16-12-09 13:37:42.8789] main::init (384) Starting Logitech Media Server (v7.9.0, 1481125532, Wed Dec  7 17:16:54 UTC 2016) perl 5.022002 - x86_64-linux-gnu-thread-multi
    [16-12-09 13:37:45.1225] Slim::Utils::Misc::msg (1244) Warning: [13:37:45.1217] $[ used in numeric lt (<) (did you mean $] ?) at /usr/share/squeezeboxserver/CPAN/PAR.pm line 576.
    It's look like the problem arrived after migrating my server to the last Ubuntu version: 16.10 "Yakkety Yak"
    It's using Perl 5 version 22 (v5.22.2)

    Thanks in advance for you help
    Last edited by ltsv38; 2016-12-09 at 12:24.
    Pierre (Grenoble - France)
    2 Squeezebox Touch (main HIFI system & headphone) + 1 Squeezebox Duet (kitchen HIFI system) + 3 Squeezebox Radio
    Ubuntu server with LMS 7.9

  2. #2
    Member ltsv38's Avatar
    Join Date
    Jul 2008
    Location
    Grenoble - France
    Posts
    88

    Stops in broadcast

    Hello

    I tried to launch LMS from a terminal (instead as a service) with again a crash when trying to listen at a radio

    Code:
    # /usr/sbin/squeezeboxserver
    [16-12-11 10:48:47.0627] main::init (384) Starting Logitech Media Server (v7.9.0, 1481125532, Wed Dec  7 17:16:54 UTC 2016) perl 5.022002 - x86_64-linux-gnu-thread-multi
    [16-12-11 10:48:47.0749] main::changeEffectiveUserAndGroup (1001) Warning: Logitech Media Server must not be run as root!  Trying user squeezeboxserver instead.
    [16-12-11 10:48:49.1567] Slim::Utils::Misc::msg (1244) Warning: [10:48:49.1563] $[ used in numeric lt (<) (did you mean $] ?) at /usr/share/squeezeboxserver/CPAN/PAR.pm line 576.
    [16-12-11 10:48:51.7901] Slim::Web::Cometd::handler (422) errorNeedsClient: 00:04:20:28:13:8e, status, -, 10, menu:menu, useContextMenu:1, subscribe:600
    Floating point exception (core dumped)
    Pierre (Grenoble - France)
    2 Squeezebox Touch (main HIFI system & headphone) + 1 Squeezebox Duet (kitchen HIFI system) + 3 Squeezebox Radio
    Ubuntu server with LMS 7.9

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •