I have a duet system that has been in storage for several years. I set it up about two weeks ago and the receiver is working fine but the controller wouldn't boot. I know the receiver is working because I can use a mobile app on my phone to play music through the receiver without any issues. However, the controller still doesn't seem to be working.

If I open the battery compartment and re-seat the battery I see a white LED go on and off. I found some information about doing a reset of the controller by holding down + while pressing the home button. When I do that the lights behind buttons on the front of the controller light up but the device never boots. I even ordered and installed a new Logitech OEM battery but still no luck.

I thought that maybe the controller was booting but the display was just was broken. However, even after I try the reset procedure above, none of the buttons do anything when I look at the player via the web interface on the PC running Logitech Media Server.

Any suggestions for troubleshooting further?