Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Oct 2011

    Cannot connect to Receiver

    Hi All,

    I have a Duet + Receiver and Squeezebox Radio.

    My Radio and Duet controller are working fine, however I cannot get my receiver working anymore. Its stuck on the flashing red light.
    I have tried factory resetting the duet and holding down the receiver button for ages, but nothing seems to be working.

    Is my receiver dead?

    I had a similar issue a few years ago and the receiver needed replacing.


  2. #2
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Utah, USA
    If you hold the button on the receiver for 20 seconds does it start a fast red flash and then drop back to a slower red flash after you release the button? If so, it has been factory reset and must be set up using your Duet controller. Do a factory reset on the controller and during setup of the controller you do your network key. at some point the controller will list players that it sees and should give you your receiver by the last few hex digits of your receiver's MAC address. You then select that receiver and the controller will pass the network security info to the receiver and it should reconnect to your network. You should see your receiver light go yellow - green - blue and then soft white when it connects to your LMS instance. For a definition of the light colors see
    Main system - Rock Solid with LMS 7.9.1 Nightly on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.1 Nightly on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave

  3. #3
    Junior Member
    Join Date
    Oct 2011
    Thanks for the info!
    I have been resetting it as you described but it wasn't working.
    However, I got it working now by also doing the following:
    1. Turned off my squeezebox radio.
    2. Deleted the receiver from the mysqueezebox website.

    Once I did that your instructions worked first time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts