Home of the Squeezebox™ & Transporter® network music players.
Page 115 of 127 FirstFirst ... 1565105113114115116117125 ... LastLast
Results 1,141 to 1,150 of 1265
  1. #1141
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,961
    Quote Originally Posted by vhenninot View Post
    Hello,

    I could not have YouTube playback working, always the same error :
    Code:
     [21-01-13 00:46:06.8854] Plugins::YouTube::WebM::__ANON__ (677) samplerate: 48000, bitrate: 
    [21-01-13 00:46:06.8877] Slim::Player::Song::open (409) Error: Couldn't create command line for ops playback for [youtube://www.youtube.com/v/QzEwx4BoYI0]
    No problem with my google account, I can authenticate, browse my playlist and perform search within YouTube...
    I update my raspberry, checked SSL packages...

    Could you help me search what could be wrong ?

    Thanks for this great plugin and your help,
    Vincent
    You need to provide a bit more logging info by setting "(player.source) - Player Source Audio & Conversion Logging" to info at least and tell us what is your player. Verify that ogg transcoding is not disabled and what is your LMS version
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  2. #1142
    Junior Member
    Join Date
    Apr 2011
    Location
    France
    Posts
    13
    Hello Philippe,

    Thanks for your answer ! Many thanks for your help !
    I tried playback on both ipeng, squeezebox radio & boom.

    Code:
    Logitech Media Server Version : 7.9.2 - 1524136933 @ Thu Apr 19 13:39:43 CEST 2018
    Nom d'hôte : raspberrypi
    Adresse IP du serveur : 192.168.1.14
    Port HTTP du serveur : 9000
    Système d'exploitation : Debian - FR - utf8
    Architecture de la plate-forme : armv7l-linux
    Version de Perl : 5.24.1 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan : 0.95
    Version de la base de données : DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Code:
     [21-01-13 09:05:31.5139] Slim::Player::StreamingController::playerActive (1993) 01:96:71:09:37:88 player already active: 01:96:71:09:37:88
    [21-01-13 09:05:31.5233] Slim::Player::Song::new (108) index 0 -> youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:31.5257] Slim::Player::StreamingController::resetSongqueue (1776) Song queue is now 0
    [21-01-13 09:05:31.5276] Slim::Player::StreamingController::playerActive (1993) 01:96:71:09:37:88 player already active: 01:96:71:09:37:88
    [21-01-13 09:05:31.5287] Slim::Player::Squeezebox::reconnect (80) 01:96:71:09:37:88 restaring play on pseudo-reconnect at 0
    [21-01-13 09:05:31.5297] Slim::Player::StreamingController::playerReconnect (2072) 01:96:71:09:37:88
    [21-01-13 09:05:31.5321] Slim::Player::StreamingController::_Stop (603) Song queue is now 0
    [21-01-13 09:05:31.5333] Slim::Player::StreamingController::_setPlayingState (2357) new playing state STOPPED
    [21-01-13 09:05:31.5344] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state IDLE
    [21-01-13 09:05:31.5355] Slim::Player::Squeezebox::reconnect (88) 01:96:71:09:37:88 forcing stop on pseudo-reconnect
    [21-01-13 09:05:48.8218] Slim::Player::StreamingController::stop (2097) 00:04:20:2c:fd:8e
    [21-01-13 09:05:48.8236] Slim::Player::StreamingController::resetSongqueue (1776) Song queue is now 
    [21-01-13 09:05:48.8277] Slim::Player::StreamingController::play (2100) 00:04:20:2c:fd:8e
    [21-01-13 09:05:48.8305] Slim::Player::StreamingController::_setPlayingState (2357) new playing state STOPPED
    [21-01-13 09:05:48.8316] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state IDLE
    [21-01-13 09:05:48.8339] Slim::Player::Song::new (108) index 0 -> youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:48.8406] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state TRACKWAIT
    [21-01-13 09:05:48.8441] Slim::Player::StreamingController::_playersMessage (789) Obtention des informations sur le flux...: youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:48.8497] Slim::Player::Song::getNextSong (229) youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:49.5873] Slim::Player::StreamingController::_nextTrackReady (737) 00:04:20:2c:fd:8e: nextTrack will be index 0
    [21-01-13 09:05:49.5887] Slim::Player::StreamingController::_Stream (1203) Song queue is now 0
    [21-01-13 09:05:49.5897] Slim::Player::StreamingController::_Stream (1206) 00:04:20:2c:fd:8e: preparing to stream song index 0
    [21-01-13 09:05:49.5907] Slim::Player::Song::open (363) youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:49.5933] Slim::Player::Song::open (387) seek=false time=0 canSeek=1
    [21-01-13 09:05:49.5952] Slim::Player::TranscodingHelper::getConvertCommand2 (443) Error: Didn't find any command matches for type: ops
    [21-01-13 09:05:49.5958] Slim::Player::Song::open (409) Error: Couldn't create command line for ops playback for [youtube://www.youtube.com/v/2vjPBrBU-TM]
    [21-01-13 09:05:49.5964] Slim::Player::StreamingController::_playersMessage (789) Problème: impossible de lire le type de fichier pour:: youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:49.5985] Slim::Player::StreamingController::_willRetry (1391) no retry data
    [21-01-13 09:05:49.5990] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state IDLE
    [21-01-13 09:05:49.5998] Slim::Player::StreamingController::nextsong (882) The next song is number 0, was 0
    [21-01-13 09:05:49.6006] Slim::Player::Song::new (108) index 0 -> youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:49.6016] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state TRACKWAIT
    [21-01-13 09:05:49.6038] Slim::Player::StreamingController::_playersMessage (789) Obtention des informations sur le flux...: youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:49.6090] Slim::Player::Song::getNextSong (229) youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:50.3145] Slim::Player::StreamingController::_nextTrackReady (737) 00:04:20:2c:fd:8e: nextTrack will be index 0
    [21-01-13 09:05:50.3155] Slim::Player::StreamingController::_Stream (1203) Song queue is now 0
    [21-01-13 09:05:50.3160] Slim::Player::StreamingController::_Stream (1206) 00:04:20:2c:fd:8e: preparing to stream song index 0
    [21-01-13 09:05:50.3165] Slim::Player::Song::open (363) youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:50.3179] Slim::Player::Song::open (387) seek=false time=0 canSeek=1
    [21-01-13 09:05:50.3204] Slim::Player::TranscodingHelper::getConvertCommand2 (443) Error: Didn't find any command matches for type: ops
    [21-01-13 09:05:50.3211] Slim::Player::Song::open (409) Error: Couldn't create command line for ops playback for [youtube://www.youtube.com/v/2vjPBrBU-TM]
    [21-01-13 09:05:50.3217] Slim::Player::StreamingController::_playersMessage (789) Problème: impossible de lire le type de fichier pour:: youtube://www.youtube.com/v/2vjPBrBU-TM
    [21-01-13 09:05:50.3238] Slim::Player::StreamingController::_willRetry (1391) no retry data
    [21-01-13 09:05:50.3244] Slim::Player::StreamingController::_setStreamingState (2366) new streaming state IDLE
    Name:  99E4DC67-034F-4B8A-97EF-DDC9AA7462E2.jpeg
Views: 429
Size:  40.4 KB

    Best regards,
    Vincent

  3. #1143
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,961
    Quote Originally Posted by vhenninot View Post
    Hello Philippe,

    Thanks for your answer ! Many thanks for your help !
    I tried playback on both ipeng, squeezebox radio & boom.

    Code:
    Logitech Media Server Version : 7.9.2 - 1524136933 @ Thu Apr 19 13:39:43 CEST 2018
    Nom d'hôte : raspberrypi
    Adresse IP du serveur : 192.168.1.14
    Port HTTP du serveur : 9000
    Système d'exploitation : Debian - FR - utf8
    Architecture de la plate-forme : armv7l-linux
    Version de Perl : 5.24.1 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan : 0.95
    Version de la base de données : DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Best regards,
    Vincent
    There has been so many changes in LMS with 8.1.1 for opus and audioscan that I think you really should start form that version. I expect it'll become official in a not so distant future, so this is really the version to go, where we have all invested efforts. Now, from there; if it still does not work then we can investigate
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  4. #1144
    Junior Member
    Join Date
    Apr 2011
    Location
    France
    Posts
    13

    Thanks !

    Dear Philippe,

    I’m really sorry I didn’t check that first !
    I remembered to have automatic update checking, but i think it doesn’t work since months !!

    Everything is working fine now regarding YouTube plugin.

    Best regards,
    Vincent

  5. #1145
    Member networx's Avatar
    Join Date
    Dec 2018
    Location
    Germany
    Posts
    31

    Buffer problems

    Facing heavy buffer probs today with all songs i try. They play for about 10s than rebuffering for 5s, playing for 10s and so on.

    Anyone has the same prob?

    PLugin is 0.127.0
    LMS 8.2.0 1611417898 @ QNAP

    additional infos: maybe a problem with AAC streams? Radio stations with AAC stream showing the the same probs. MP3 works.
    Last edited by networx; 2021-01-24 at 04:15. Reason: add infos

  6. #1146
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,255
    Hey Philippe, hope you are keeping warm and safe

    I'm an infrequent user of the YouTube plugin but have expererinced a problem today

    It is a couple of months since I last used the Plugin

    Playback on a Squeezebox Radio using "Playlist Search" results in everything appearing to be correct, but with no sound.

    Info log included

    Logitech Media Server Version: 8.1.2 - 1613972332 @ Mon Feb 22 08:43:10 CET 2021

    Hostname: LMS

    Server IP Address: 192.168.1.127

    Server HTTP Port Number: 9000

    Operating system: piCore - EN - utf8

    Platform Architecture: aarch64-linux

    Perl Version: 5.32.0 - aarch64-linux-thread-multi

    Audio::Scan: 1.02

    IO::Socket::SSL: 2.068
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    Total Players Recognized: 4
    Low prio on this as I don't see others complaining

    Many thanks

    ronnie
    Attached Files Attached Files
    Last edited by Man in a van; 2021-02-24 at 02:11.

  7. #1147
    Junior Member
    Join Date
    Dec 2010
    Posts
    9
    Quote Originally Posted by Man in a van View Post
    Hey Philippe, hope you are keeping warm and safe

    I'm an infrequent user of the YouTube plugin but have expererinced a problem today

    It is a couple of months since I last used the Plugin

    Playback on a Squeezebox Radio using "Playlist Search" results in everything appearing to be correct, but with no sound.

    Info log included



    Low prio on this as I don't see others complaining

    Many thanks

    ronnie
    I have the same issue and looking at your log I have the same error entry:
    [21-02-24 12:42:41.2782] Slim::Networking::IO::Select::__ANON__ (130) Error: Select task failed calling Slim::Networking::Async::HTTP::_http_read_body: Unsupported JS expression 'Mx["do"](a,17)' at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/YouTube/JSInterp.pm line 353.
    ; fh=Slim::Networking::Async::Socket::HTTPS=GLOB(0xb d35420)

  8. #1148
    Senior Member
    Join Date
    Nov 2012
    Location
    UK, Nottinghamshire
    Posts
    382

    Force "Play from beginning"

    Hi Philippe ,

    Just wondering if it would be possible to add option to force always playing from beginning if file was previously started.
    I have mapped subscribed channel to SB Radio Preset buttons and if podcast episode was previously started YT plugin skips it . I assume because Youtube asks if I want to play from previous position or beginning. As YT plugin is not able to answer, it just skips/tries another file. That's my guess anyway.
    Don't know if there is a way to overcome that behaviors, but perhaps an option to "always force from beginning" would work for some people? What do you think?
    Many thanks!
    3x Squeezebox Touch, 4x Squeezebox Radio, Squeezelite (RPi 3B with HiFiBerry DAC+Pro on OSMC), Material Skin Apk, Squeeze Commander, Logitech Media Server Version: 8.2.0 with Material Skin (Docker in DS218+)

  9. #1149
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,961
    Quote Originally Posted by Jaca View Post
    Hi Philippe ,

    Just wondering if it would be possible to add option to force always playing from beginning if file was previously started.
    I have mapped subscribed channel to SB Radio Preset buttons and if podcast episode was previously started YT plugin skips it . I assume because Youtube asks if I want to play from previous position or beginning. As YT plugin is not able to answer, it just skips/tries another file. That's my guess anyway.
    Don't know if there is a way to overcome that behaviors, but perhaps an option to "always force from beginning" would work for some people? What do you think?
    Many thanks!
    I just realized that you might have your cake and eat it. It seems that there is a way to have the "play" icon to play from beginning *and* a link to go one level down to have choice. I'll verify it works with controllers as well.
    Last edited by philippe_44; 2021-03-13 at 15:11.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  10. #1150
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,961
    Quote Originally Posted by philippe_44 View Post
    I just realized that you might have your cake and eat it. It seems that there is a way to have the "play" icon to play from beginning *and* a link to go one level down to have choice. I'll verify it works with controllers as well.
    argh ... LMS default skin works as well as Material and offer a "play" and a sub-menu but iPeng fails
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •