Home of the Squeezebox™ & Transporter® network music players.
Page 33 of 33 FirstFirst ... 23313233
Results 321 to 330 of 330
  1. #321
    Junior Member
    Join Date
    Sep 2018
    Posts
    3
    Your recent changes seem to be working, so thanks a lot for your swift response.

  2. #322
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,615
    Quote Originally Posted by MrH View Post
    Your recent changes seem to be working, so thanks a lot for your swift response.
    Thanks phillipe_44, working for me now also.
    Study/Server - LMS 7.9.2 - Pi3B+/pCP 4.0.0/pi screen/HiFiBerry DAC+/jivelite, 25K library and playlists on WDMyCloud, LMS cache on a USB stick (formatted ntfs).
    Lounge - Pi2/pCP 4.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP 4.0.0 > HiFiBerry AMP+/retro radio
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 4.0.0 > Edifier R980T
    In car - RPi3B/pCP in AP mode > HiFiBerry DAC+ > car's audio (files on a 2TB USB drive)
    Spares - 1xTouch, 1xSB3, 1xRadio, 1xBoom

  3. #323
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,755
    Quote Originally Posted by kidstypike View Post
    Thanks phillipe_44, working for me now also.
    I must be missing something. Is there an update to the plugin? I can't see one.

    Sent from my SM-G900F using Tapatalk

  4. #324
    Junior Member
    Join Date
    Sep 2018
    Posts
    3
    Yes works but with short interupt round about every 8-10 seconds for 1 - 2 seconds. That goes the whole track long.
    And to start it needs longer than before and now 2 or 3 push to the play button.

    Every Track the same issue...

    Thx Phillipe great work.
    Last edited by MichaelFFM; Today at 10:42.

  5. #325
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    2,615
    Quote Originally Posted by slartibartfast View Post
    I must be missing something. Is there an update to the plugin? I can't see one.

    Sent from my SM-G900F using Tapatalk
    Saw post from MrH, went to LMS/settings/plugins and the restart LMS dialogue popped up, I assume it was a youtube update as it now works fine, and is . . .

    Name:  Youtube 7.jpg
Views: 44
Size:  2.8 KB
    Study/Server - LMS 7.9.2 - Pi3B+/pCP 4.0.0/pi screen/HiFiBerry DAC+/jivelite, 25K library and playlists on WDMyCloud, LMS cache on a USB stick (formatted ntfs).
    Lounge - Pi2/pCP 4.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP 4.0.0 > HiFiBerry AMP+/retro radio
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 4.0.0 > Edifier R980T
    In car - RPi3B/pCP in AP mode > HiFiBerry DAC+ > car's audio (files on a 2TB USB drive)
    Spares - 1xTouch, 1xSB3, 1xRadio, 1xBoom

  6. #326
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    1,755
    Quote Originally Posted by kidstypike View Post
    Saw post from MrH, went to LMS/settings/plugins and the restart LMS dialogue popped up, I assume it was a youtube update as it now works fine, and is . . .

    Name:  Youtube 7.jpg
Views: 44
Size:  2.8 KB
    Got it now. For some reason I couldn't see it in my phone browser.

    Sent from my SM-G900F using Tapatalk

  7. #327
    Junior Member
    Join Date
    Sep 2018
    Posts
    3
    Quote Originally Posted by MichaelFFM View Post
    Yes works but with short interupt round about every 8-10 seconds for 1 - 2 seconds. That goes the whole track long.
    And to start it needs longer than before and now 2 or 3 push to the play button.

    Every Track the same issue...

    Thx Phillipe great work this plugin.


    Here some log when the interupt comes maybe it helps.

    ebM::getEBML (489) size:63 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7667] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6787, flags: 128)
    [18-09-19 17:31:48.7670] Plugins::YouTube::WebM::getEBML (489) size:60 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7673] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6790, flags: 128)
    [18-09-19 17:31:48.7677] Plugins::YouTube::WebM::getEBML (489) size:62 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7679] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6793, flags: 128)
    [18-09-19 17:31:48.7683] Plugins::YouTube::WebM::getEBML (489) size:60 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7686] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6796, flags: 128)
    [18-09-19 17:31:48.7689] Plugins::YouTube::WebM::getEBML (489) size:54 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7692] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6799, flags: 128)
    [18-09-19 17:31:48.7696] Plugins::YouTube::WebM::getEBML (489) size:53 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7698] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6802, flags: 128)
    [18-09-19 17:31:48.7702] Plugins::YouTube::WebM::getEBML (489) size:47 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7705] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6804, flags: 128)
    [18-09-19 17:31:48.7708] Plugins::YouTube::WebM::getEBML (489) size:66 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7711] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6807, flags: 128)
    [18-09-19 17:31:48.7714] Plugins::YouTube::WebM::getEBML (489) size:67 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7717] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6810, flags: 128)
    [18-09-19 17:31:48.7721] Plugins::YouTube::WebM::getEBML (489) size:64 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7723] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6813, flags: 128)
    [18-09-19 17:31:48.7727] Plugins::YouTube::WebM::getEBML (489) size:63 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7730] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6816, flags: 128)
    [18-09-19 17:31:48.7733] Plugins::YouTube::WebM::getEBML (489) size:63 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7736] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6819, flags: 128)
    [18-09-19 17:31:48.7740] Plugins::YouTube::WebM::getEBML (489) size:61 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7743] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6822, flags: 128)
    [18-09-19 17:31:48.7746] Plugins::YouTube::WebM::getEBML (489) size:53 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7749] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6825, flags: 128)
    [18-09-19 17:31:48.7752] Plugins::YouTube::WebM::getEBML (489) size:55 (tagsize: 1 + 1)
    [18-09-19 17:31:48.7755] Plugins::YouTube::WebM::extractVorbis (435) found track: 1 (ts: 6828, flags: 128)
    [18-09-19 17:31:52.5156] Plugins::YouTube::ProtocolHandler::getMetadataFor (448) getmetadata: youtube://www.youtube.com/v/whzog4W0cnY
    [18-09-19 17:31:52.5163] Plugins::YouTube::ProtocolHandler::getMetadataFor (471) cache hit: whzog4W0cnY
    [18-09-19 17:31:52.5174] Plugins::YouTube::ProtocolHandler::getMetadataFor (448) getmetadata: youtube://www.youtube.com/v/whzog4W0cnY
    [18-09-19 17:31:52.5182] Plugins::YouTube::ProtocolHandler::getMetadataFor (471) cache hit: whzog4W0cnY

    18-09-19 20:35:14.1196] Plugins::YouTube::ProtocolHandler::__ANON__ (434) could not find start offset
    Last edited by MichaelFFM; Today at 12:45.

  8. #328
    Senior Member
    Join Date
    Jun 2009
    Posts
    204

    live feed

    i'm another +1 for a working live feed. I know it's a big task but just through I would add my two cents. There will be more and more content here for music from youtube.
    LMS 7.9.1 on QNAP 219P+
    3 wired Touch End Points
    Jolida Tube DAC III
    Marantz 2270 to Boston Acoustics Slimlines
    Marantz 7010 to B&W CM10 S2

  9. #329
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    4,091
    Quote Originally Posted by MrH View Post
    Do you mean that YT has done a lot of changes recently?

    Is it possible to use (or reuse code from) youtube-dl in
    your plugin, to simplify development?
    Yes, YT did lots of changes.

    I leverage already youtube-dl expertise to follow the changes, but youtube-dl is Python and LMS is Perl
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  10. #330
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    4,091
    Quote Originally Posted by MichaelFFM View Post
    Yes works but with short interupt round about every 8-10 seconds for 1 - 2 seconds. That goes the whole track long.
    And to start it needs longer than before and now 2 or 3 push to the play button.

    Every Track the same issue...

    Thx Phillipe great work.
    Well, I had to open the format to DASH webm (audio only) but my decoder does not really support DASH ... so letĺs see what others experience with audio file (YT is now separating audio only from video and makes it audio only files). I donĺt have the time currently to investigate proper DASH handling of a webm audio file, so this is a good as it can be for sometime
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •