Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Feb 2016
    Posts
    8

    piCorePlayer and DSD

    Hi,

    I installed piCorePlayer on RPI2 and a HifiBerry Digi+ Card. Then I installed LMS 7.9 on piCorePlayer.

    Everything is working fine except dff/dsf replay.

    My DAC is non DSD capable nor DoP, but I saw dsf can be converted on the fly and decoded by alsa but I can't get it to run.

    I tried several squeezelite settings like "-e dsd" , installed dsdplayer plugin (but there are no dsdplay bin and libsox for arm).

    Can't find the sources of this plugin by the way, but for what I understood it seems of no use this days...

    Does Anyone got it to run and can share ?

    Thanks !

    On Advanced Settings / Files Type
    DFF/DSF I can only choose Native/Disabled
    FLAC is greyed

  2. #2

    Lms 7.9

    Can someone tell me how to install LMS on Picoreplayer?

  3. #3

  4. #4
    Junior Member
    Join Date
    Feb 2016
    Posts
    8
    I found the solution, simply add "-c pcm,flac,mp3,dsd -r 44100,48000,88200,96000,176400,192000" to squeezelite settings and it's playing fine !

    no need of "-e dsd" or dsdplayer plugin
    Last edited by fedcod; 2016-03-14 at 08:09.

  5. #5
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,174
    Quote Originally Posted by fedcod View Post
    Or wait a few more days, and it will be included as an option on pCP.

  6. #6
    Junior Member
    Join Date
    Jun 2016
    Posts
    20

    Not working for me

    Hi,

    I have LMS 7.9 installed on a QNAP nas TS-853A-8G and using PiCoreplayer on my RPI3 with DAC+Pro-I2S output directly into my AK4495SEQ dac.
    This works like a charm but can't get DSF/DFF files to play. My dac is not dop/dsd compliant and have to resample to 192kHz.

    From a laptop with Server 2012R2 + LMS7.9 this worked with option -e dsd and installed dsdplugin, but with QNAP this isn't working.

    I just tried your settings, files are playing but no sound.

    I use PCP 2.05

    Any clue?

    Any help much appreciated!!

    Regards,
    Alex
    The Netherlands
    Last edited by abartels; 2016-06-11 at 06:02.

  7. #7
    Senior Member JackOfAll's Avatar
    Join Date
    Dec 2005
    Location
    London, UK
    Posts
    2,749
    Quote Originally Posted by abartels View Post
    RPI3 with DAC+Pro-I2S output directly into my AK4495SEQ dac.
    Unless the AK can decode DoP, (which I don't think it can), you'll have to stick with DSD->PCM decode via squeezelite/LMS.

  8. #8
    Junior Member
    Join Date
    Jun 2016
    Posts
    20
    Quote Originally Posted by JackOfAll View Post
    Unless the AK can decode DoP, (which I don't think it can), you'll have to stick with DSD->PCM decode via squeezelite/LMS.
    Yes, that is what I am trying to accomplish but not successful until now.

    Anybody a clue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •