Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2012
    Posts
    13

    PicorePlayer and LMS - how to get a MONO downmix?

    Dear all,

    I am currently running a private project to build my own Squeezebox using Picoreplayer and LMS on a Raspberry Pi2 incl. a PiFi and/or USB DAC.

    The challenge I have: I need a MONO downmix to run one box alone and the option to switch to Stereo if I connect a second box. The LMS options are not providing a MONO downmix but I can only select the right or the left channel or stereo. Is there an option in the PiCoreplayer to get a proper mono output?

    Thanks for your help and advice.
    Nick

  2. #2
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,480
    https://www.raspberrypi.org/forums/v...p?f=29&t=33431

    Or use SoX via custom-convert.conf.
    Or use a "stereo-to-mono" cable/adapter.

  3. #3
    Junior Member
    Join Date
    Sep 2012
    Posts
    13
    Hello Apesbrain,

    thanks for the first feedback. My hardware guru (responsible for the audio part is not recommending the cable option). The custom-convert.conf option is done on the LMS side, correct? As I would like to run airplay as well on the PiCoreplayer, ideally the conversion to Mono is done on the player side.

    I am struggling with the Alsa config (tried that already yesterday when finding the same post you just have shared). Is someone here having the same problem and is using only a Mono-setup?

    Cheers
    Nick

  4. #4
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,798
    hi Nick L.,

    There is a *beta* tool for doing mono.

    Click on [Beta] mode.
    Click on [Extras].
    Click on [Asound].

    WARNING: It is really beta software, it will not work with all pCP add-ons, you may have to reload pCP if things go bad, but it is a lot easier than starting from scratch with ALSA.

    regards
    Greg

  5. #5
    Junior Member
    Join Date
    Sep 2012
    Posts
    13
    Hello Greg,

    thanks for pointing me to the right direction. The beta option is working fine if you don't use the equalizer. As I need the equalizer to adjust the frequency response of my "Sonos remake", I had to finetune the asound.conf.
    The down-mix is working well now! All I have to do now is to un-comment the five lines at the end of the asound.conf.

    It would be great now to switch between a mono and a stereo-setup without editing the asound.conf via SSH. Is there a way to do that in a more clever way? The other option is to just have two SD cards (one for mono and one for stereo).
    Thanks for your ideas and comments.

    Nick

    asound.conf:
    Code:
    # default - Generated by piCorePlayer
    pcm.!default {
    type plug
    slave.pcm "hw:0,0"
    }
    
    #---ALSA EQ Below--------
    ctl.equal {
    type equal;
    controls "/home/tc/.alsaequal.bin"
    library "/usr/local/lib/ladspa/caps.so"
    }
    
    pcm.plugequal {
    type equal;
    slave.pcm "plughw:1,0"
    controls "/home/tc/.alsaequal.bin"
    library "/usr/local/lib/ladspa/caps.so"
    }
    
    pcm.equal {
    type plug;
    slave.pcm plugequal;
    
    # Mono-Downmix added by Nick - remove comments of the following six lines to enable Mono
    #ttable {
    #0.1 1
    #0.0 1
    #1.0 1
    #1.1 1
    #}
    
    }
    Last edited by Nick L.; 2016-05-05 at 14:27. Reason: Error fixing

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •