Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1

    Which is the "correct" or most compatible mp3 tag format for iPeng (and others)?

    To save some space (and because I can't hear the difference as long as the source is the same) I have started storing my music as MP3 320 CBR instead of Flac.
    I "nutcase" for chronology and always want the music of various composers or artists to be in chronological order.
    With Flac file that has never been a problem, but with MP3 I now sometimes see that certain albums are listed at the end without any "Year" data at all.

    Although it is not always the case it seems as if it only happens when I've written data in the ID3v2.3(ID3v2.3) tag format in MP3Tag.

    MP3 with data written as ID3v2.3(ID3v1 ID3v2.3) tags seems to be fine?

    Does this mean that ID3v2.3(ID3v1 ID3v2.3) is a more compatible/correct tag format than the other?

    EDIT: Alternatively - could there be other reasons for the year tag sometimes not to be read in ipeng (it is always the same not being read?

    Any thoughts anyone?

    Stein Arne
    Last edited by SyrinxGC; 2016-02-20 at 05:21. Reason: Extra question

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Posts
    690
    I guess ID3v2.3 should be fine unless you have really old players.

    You're saying that sometimes you see no YEAR tag. Is this in iPeng only? Did you check (e.g. using Mp3tag) that those files actually have the YEAR tag filled?

    You say you want chronological order. Do you mean when you browse an artist and look at his/her albums? IIRC this is typically a setting on the player. Opposed to the chronological order when browsing 'New Music'. This is ordered by the file's last-modified date.

    EDIT: even if you don't hear a difference there's a big advantage in storing your music as FLAC (or other lossless format): if you once need your music in a different format, converting it from mp3 would make things worse while converting from lossless gives you the best possible output.
    Last edited by reinholdk; 2016-02-20 at 08:19. Reason: additional remark

  3. #3
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,701
    Quote Originally Posted by SyrinxGC View Post
    To save some space (and because I can't hear the difference as long as the source is the same) I have started storing my music as MP3 320 CBR instead of Flac.
    I "nutcase" for chronology and always want the music of various composers or artists to be in chronological order.
    With Flac file that has never been a problem, but with MP3 I now sometimes see that certain albums are listed at the end without any "Year" data at all.

    Although it is not always the case it seems as if it only happens when I've written data in the ID3v2.3(ID3v2.3) tag format in MP3Tag.

    MP3 with data written as ID3v2.3(ID3v1 ID3v2.3) tags seems to be fine?

    Does this mean that ID3v2.3(ID3v1 ID3v2.3) is a more compatible/correct tag format than the other?

    EDIT: Alternatively - could there be other reasons for the year tag sometimes not to be read in ipeng (it is always the same not being read?

    Any thoughts anyone?
    Stein Arne


    likely some other reason for the year tag issue. Perhaps you've mapped year and date incorrectly in mp3tag? all my mp3 files are ID3v2.3. Actually it is best to have only one tag type unless you have some old players that can only handle ID3v1 tags. Otherwise ID3v2.3 tags are the most compatible with everything. Easy enough to remove all the ID3v1 tags in batch with mp3tag.
    Home: VBA 4TB (2.5)>LMS 7.9.2>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4)>LMS 7.9.1>Touch>Benchmark DAC I, Boom, Radio w/Battery (ethernet, Radio WIFI)
    Office: Win10(64)>LMS 7.9.2>Squeezelite
    The Wild (no internet): PiCorePlayer 4.0 on rPi 3B+, hifiberry Dac+Pro, 4TB USB (LMS & Squeezelite)
    Controllers: iPhone6 & iPadAir2 (iPeng), CONTROLLER, or SqueezePlay 7.8 on Win10(64) laptop
    Files: ripping: dbpa > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  4. #4
    Quote Originally Posted by reinholdk View Post
    You're saying that sometimes you see no YEAR tag. Is this in iPeng only? Did you check (e.g. using Mp3tag) that those files actually have the YEAR tag filled?
    Thanks.
    The YEAR tag is in MP3Tag - that's the only tag editor I'm using.

    Quote Originally Posted by reinholdk View Post
    You say you want chronological order. Do you mean when you browse an artist and look at his/her albums? IIRC this is typically a setting on the player. Opposed to the chronological order when browsing 'New Music'. This is ordered by the file's last-modified date.
    I'm talking about the album release year - or for classical music, usually the year the music was composed. With Bach I've used the BWV numbers as years. Works well from 1 digit to 4 :-)

    One important thing: While I was waiting for an answer here I changed all the works lacking YEAR tag to ID3v2.3(ID3v1 ID3v2.3). All problems solved it seems.
    So for iPeng ID3v2.3(ID3v1 ID3v2.3) seems to be the best format - unless I've missed something.

    Quote Originally Posted by reinholdk View Post
    EDIT: even if you don't hear a difference there's a big advantage in storing your music as FLAC (or other lossless format): if you once need your music in a different format, converting it from mp3 would make things worse while converting from lossless gives you the best possible output.
    Could not agree more. I have an extra backup disc, not in daily use, with everything in lossless format - although I don't expect the MP3 format and players compatible with it to disappear any time soon.

  5. #5
    Quote Originally Posted by garym View Post
    likely some other reason for the year tag issue. Perhaps you've mapped year and date incorrectly in mp3tag? all my mp3 files are ID3v2.3. Actually it is best to have only one tag type unless you have some old players that can only handle ID3v1 tags. Otherwise ID3v2.3 tags are the most compatible with everything. Easy enough to remove all the ID3v1 tags in batch with mp3tag.
    I've checked and double checked the albums with problems. That is not the case. I have also removed all extended tags incl. "orig.date" which has caused me trouble with some classical works.
    I've also performed "Tag cut" and "Tag paste" to remove possible problem data.

    Adding ID3v1 has as far as I can see solved all my iPeng problems.

  6. #6
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Location
    Vństerňs Sweden
    Posts
    16,528
    This is actually two formats so you are storing the tags tvice in the file ID3v2.3(ID3v1 ID3v2.3). both as id3v1 and id3v2.3 stick to one set of tags it works best .

    I dont know how LMS prioritise this and it can get even wierder if the content of the two tag sets does not match
    --------------------------------------------------------------------
    Main hifi: Rasbery PI digi+ MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Loggia: Raspi hifiberry dac + Adams
    Bathroom : Radio (with battery)
    iPad with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server Intel NUC Esxi VM Linux mint 18 LMS 7.9.2

    http://people.xiph.org/~xiphmont/demo/neil-young.html

  7. #7
    Senior Member
    Join Date
    May 2008
    Location
    United States
    Posts
    11,701
    Quote Originally Posted by SyrinxGC View Post
    I've checked and double checked the albums with problems. That is not the case. I have also removed all extended tags incl. "orig.date" which has caused me trouble with some classical works.
    I've also performed "Tag cut" and "Tag paste" to remove possible problem data.

    Adding ID3v1 has as far as I can see solved all my iPeng problems.
    I'm glad that works, but seems odd (and not the case on my end). As an experiment, can you

    1. Set mp3tag TOOLS > OPTIONS > Tags > mpeg with ticks in Read ID3v1 and ID3v2 for read, then write only tick ID3v2.3, with ID3v2.3 UTF16 ticked., the REMOVE, tick all but ID3v2

    2. Open a file that has only ID3v2.3 in mp3tag and causes the year problem (but it has a year tag). Select, then hit the red X to the right of the save (disk) icon in upper left menu. This will remove all tags and only keep ID3v2.3.

    Does this work? I'm wondering if doing any saving within mp3tag solves the problem (whether ID3v1|Id3v2.3 or just ID3v2.3)
    Home: VBA 4TB (2.5)>LMS 7.9.2>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4)>LMS 7.9.1>Touch>Benchmark DAC I, Boom, Radio w/Battery (ethernet, Radio WIFI)
    Office: Win10(64)>LMS 7.9.2>Squeezelite
    The Wild (no internet): PiCorePlayer 4.0 on rPi 3B+, hifiberry Dac+Pro, 4TB USB (LMS & Squeezelite)
    Controllers: iPhone6 & iPadAir2 (iPeng), CONTROLLER, or SqueezePlay 7.8 on Win10(64) laptop
    Files: ripping: dbpa > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  8. #8
    Quote Originally Posted by Mnyb View Post
    This is actually two formats so you are storing the tags tvice in the file ID3v2.3(ID3v1 ID3v2.3). both as id3v1 and id3v2.3 stick to one set of tags it works best .

    I dont know how LMS prioritise this and it can get even wierder if the content of the two tag sets does not match
    You may be right. Anyway the data comes from MP3Tag and the only data fields I use - and ALWAYS use (I delete everything else) are Title, Artist, Album, Year, Track, Genre and Composer.
    It has first of all been a problem for classical music where I sort first by Genre, then Artist (which usually is composers last name) and finally Year (which in some cases may be the Works number).
    LMS Web UI ignore the year when I sort the same way. Instead it sort albums/works alphabetically. A solution might be to add year as first part of album name.
    For me the missing year has only been a problem with ipeng.

    By the way - if you use default Foobar settings, ID3v2.3(ID3v1 ID3v2.3) is what you get (or I get!).

  9. #9
    Quote Originally Posted by garym View Post
    I'm glad that works, but seems odd (and not the case on my end). As an experiment, can you

    1. Set mp3tag TOOLS > OPTIONS > Tags > mpeg with ticks in Read ID3v1 and ID3v2 for read, then write only tick ID3v2.3, with ID3v2.3 UTF16 ticked., the REMOVE, tick all but ID3v2

    2. Open a file that has only ID3v2.3 in mp3tag and causes the year problem (but it has a year tag). Select, then hit the red X to the right of the save (disk) icon in upper left menu. This will remove all tags and only keep ID3v2.3.

    Does this work? I'm wondering if doing any saving within mp3tag solves the problem (whether ID3v1|Id3v2.3 or just ID3v2.3)
    Sorry, but it may be too late for that since I have no longer any missing years after including ID3v1 tags in addition to v2. I guess this is an ipeng problem, not an LMS problem.
    If the problem should turn up again I will revive this thread.

    Thanks for your engagement folks!

    Stein Arne

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •