Home of the Squeezebox™ & Transporter® network music players.
Page 202 of 203 FirstFirst ... 102152192200201202203 LastLast
Results 2,011 to 2,020 of 2021
  1. #2011
    Junior Member
    Join Date
    Jan 2021
    Posts
    20

    Skip button pauses playback

    Hi, everyone.

    I have an odd issue: when I press the skip button in LMS, while a song plays, the next song appears in LMS Interface, but playback is paused. When I push the button again, the next song is appears and playback starts again. This only happens on my Airplay device, so I think it is related to the plugin.

    I am using latest stable docker version of LMS on my rpi 4 64 bit. The player is a denon avr s750h.

    Did anyone experience a similar behavior or has anyone an idea, what could be the issue?

  2. #2012
    Junior Member
    Join Date
    Nov 2020
    Location
    Ireland
    Posts
    26
    I was literally about to report the same issue. In my case on a Marantz Melody system but I have 2 other airplay devices - a Sonos speaker and a cheap audiocast puck - which don't have this problem. I've only had problems since - I think - a marantz f/w update. As Marantz and Denon are essentially the same company I suspect it's related to their Airplay update. I frequently have problems too with initiating playback, across all file types. It will appear to play for a second then stop/pause. I have some raopbridge debug logs but cannot upload them just now as I'm out and about. For what it's worth, I've experimented with buffer values, encryption, tried both the static and dynamic bridge binaries and reset my Marantz, to no avail.
    Last edited by manx; 2022-05-07 at 04:00.

  3. #2013
    Junior Member
    Join Date
    Jan 2021
    Posts
    20
    Okay, then maybe this issue is caused by a FW upgrade. My system used to work for over a year without this issue but I did not recognize any update on my AVR. Maybe it was installed silently.

    I also played around with all available settings and recognized one other thing: when I enable "turn off on disconnect", the player turns off, every time the issue appears. So I think, song sipping causes a disconnect from server. Song skipping with my Denon remote seems to work without any issues.

    I will also record and send my logs, when I have time.

  4. #2014
    Junior Member
    Join Date
    Nov 2020
    Location
    Ireland
    Posts
    26
    Here's an airplay bridge debug log taken for a few minutes. Playback of local files is started, tracks skipped, skipped again to resume playback. Playback of local files and a radio stream failed to start in the first place on a couple of occasions and were 'resumed' from the player screen (material skin apk). Bridge was then stopped.
    Attached Files Attached Files

  5. #2015
    Junior Member
    Join Date
    Nov 2021
    Posts
    9

    Can anyone please help with this?

    Quote Originally Posted by flyfishing View Post
    First, thanks for previous assistance in getting this setup. I am now able to open LMS on the computer and play songs on my Yamaha setup.

    Here is my current stumbling block. I have close to 1000 .mp3 songs in a folder on a Windows Server called "lms test" with no sub folders. How can I play all those titles either in order or shuffle mode? And if the session is interrupted for some reason is there a way in either mode to pick up again without starting over? Maybe I just haven't let it run long enough but my impression is that it will play the titles shown on the current page and then either start over or quit.

    Lastly is there a way to play songs that are in subfolders? I'm thinking of the shuffle mode on such as the Sony Carousel milti disk player that would play songs either in progression or "shuffle" from the CDs in the tray.

    Thanks for any assistance.
    Can anyone help with this please. Even to tell me it cannot be done.

  6. #2016
    Junior Member
    Join Date
    Nov 2020
    Location
    Ireland
    Posts
    26
    Quote Originally Posted by flyfishing View Post
    Can anyone help with this please. Even to tell me it cannot be done.
    Yes that is perfectly doable but doesn't require the Airplay plugin as such. You need to add those folders on your windows share to the 'Media Folders' of LMS (the top level folder/s should be enough) and rescan your library. If you install the 'Additional Browse Modes' plugin you will be able to browse to individual folders. Shuffle is controlled from the now playing screen of your controller. You could tag all files in a folder as a single album (if they're not being changed on a frequent basis) and use the 'Bookmarks' plugin to remember your position between sessions.

  7. #2017
    Quote Originally Posted by dolodobendan View Post
    I have to revise this again: Volume control stopped working for my Sonos ONE SL pair, too. Maybe Sonos changed something.
    Hi,

    sorry if this has been discussed somewhere in the mean time, these comments were the only references to my issue I was able to find. In my use case I would like to be able to control the volume from the physical buttons of the device i.e. in my case IKEA Symfonisk speaker. Is there any setting available to allow this or this is still the case for (most) Sonos players?

    Thanks for the excellent plugin!

  8. #2018
    I have also noticed that now when I added one new Symfonisk as a stereo pair (pairing via Sonos) to the old and then a new separate Symfonisk speaker, the latest individual Symfonisk is not being seen by the Airplay bridge. From Sonos I can see it support Airplay but it does not appear in LMS other than for a few minutes at a time. The pattern can be seen here:
    Name:  Clipboard01.jpg
Views: 168
Size:  164.2 KB

    I did not have Airplay Bridge logging enabled but I will enable it and update here once it next connects and disconnects.
    When looking at LMS log, there are some unexpected lines:
    Code:
    [22-06-27 01:19:26.3993] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (319) request=client disconnect client=Slim::Player::SqueezePlay=ARRAY(0x66d2180) aa:aa:1b:60:85:e6
    [22-06-27 01:19:26.4949] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (319) request=client reconnect client=Slim::Player::SqueezePlay=ARRAY(0x66d2180) aa:aa:1b:60:85:e6
    [22-06-27 01:19:43.3507] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3497] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 108.
    [22-06-27 01:19:43.3527] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3520] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 116.
    [22-06-27 01:19:43.3544] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3537] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 122.
    [22-06-27 01:19:43.3560] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3554] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 128.
    [22-06-27 01:19:43.3604] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3595] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 137.
    [22-06-27 01:19:43.3645] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3636] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 150.
    [22-06-27 01:19:43.3661] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3655] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 156.
    [22-06-27 01:19:43.3701] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3692] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 167.
    [22-06-27 01:19:43.3718] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3711] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 173.
    [22-06-27 01:19:43.3761] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3753] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 184.
    [22-06-27 01:19:43.3778] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3771] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 190.
    [22-06-27 01:19:48.2987] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.2982] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 212.
    [22-06-27 01:19:48.3007] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3003] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 222.
    [22-06-27 01:19:48.3017] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3013] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 230.
    [22-06-27 01:19:48.3038] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3034] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 238.
    [22-06-27 01:19:48.3046] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3043] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 244.
    [22-06-27 01:26:02.1483] Plugins::ShairTunes2W::Plugin::stop_mDNS (300) Killing all processes /config/cache/InstalledPlugins/Plugins/ShairTunes2W/Bin/shairport_helper-armv6hf
    [22-06-27 01:26:02.1814] Slim::Utils::Misc::msg (1341) Warning: [01:26:02.1704] Can't exec "killall": No such file or directory at /config/cache/InstalledPlugins/Plugins/ShairTunes2W/Plugin.pm line 307.
    But now for example after restarting the server, these have not come for 30 minutes and running...
    Last edited by Nautilus; 2022-06-26 at 16:01.

  9. #2019
    Quote Originally Posted by Nautilus View Post
    I have also noticed that now when I added one new Symfonisk as a stereo pair (pairing via Sonos) to the old and then a new separate Symfonisk speaker, the latest individual Symfonisk is not being seen by the Airplay bridge. From Sonos I can see it support Airplay but it does not appear in LMS other than for a few minutes at a time. The pattern can be seen here:
    Name:  Clipboard01.jpg
Views: 168
Size:  164.2 KB

    I did not have Airplay Bridge logging enabled but I will enable it and update here once it next connects and disconnects.
    When looking at LMS log, there are some unexpected lines:
    Code:
    [22-06-27 01:19:26.3993] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (319) request=client disconnect client=Slim::Player::SqueezePlay=ARRAY(0x66d2180) aa:aa:1b:60:85:e6
    [22-06-27 01:19:26.4949] Plugins::ShairTunes2W::Plugin::playerSubscriptionChange (319) request=client reconnect client=Slim::Player::SqueezePlay=ARRAY(0x66d2180) aa:aa:1b:60:85:e6
    [22-06-27 01:19:43.3507] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3497] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 108.
    [22-06-27 01:19:43.3527] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3520] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 116.
    [22-06-27 01:19:43.3544] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3537] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 122.
    [22-06-27 01:19:43.3560] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3554] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 128.
    [22-06-27 01:19:43.3604] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3595] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 137.
    [22-06-27 01:19:43.3645] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3636] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 150.
    [22-06-27 01:19:43.3661] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3655] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 156.
    [22-06-27 01:19:43.3701] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3692] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 167.
    [22-06-27 01:19:43.3718] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3711] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 173.
    [22-06-27 01:19:43.3761] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3753] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 184.
    [22-06-27 01:19:43.3778] Slim::Utils::Misc::msg (1341) Warning: [01:19:43.3771] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/RaopBridge/HTML/EN/plugins/RaopBridge/settings/basic.html line 190.
    [22-06-27 01:19:48.2987] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.2982] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 212.
    [22-06-27 01:19:48.3007] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3003] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 222.
    [22-06-27 01:19:48.3017] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3013] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 230.
    [22-06-27 01:19:48.3038] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3034] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 238.
    [22-06-27 01:19:48.3046] Slim::Utils::Misc::msg (1341) Warning: [01:19:48.3043] Use of uninitialized value in concatenation (.) or string at /config/cache/InstalledPlugins/Plugins/CastBridge/HTML/EN/plugins/CastBridge/settings/basic.html line 244.
    [22-06-27 01:26:02.1483] Plugins::ShairTunes2W::Plugin::stop_mDNS (300) Killing all processes /config/cache/InstalledPlugins/Plugins/ShairTunes2W/Bin/shairport_helper-armv6hf
    [22-06-27 01:26:02.1814] Slim::Utils::Misc::msg (1341) Warning: [01:26:02.1704] Can't exec "killall": No such file or directory at /config/cache/InstalledPlugins/Plugins/ShairTunes2W/Plugin.pm line 307.
    But now for example after restarting the server, these have not come for 30 minutes and running...
    Here's the Airplay Bridge log from a time it connects for two minutes:
    Code:
    [16:08:28.040616] AddRaopDevice:883 [0x3d8c18]: adding renderer (Sonos-542A1B58F3AA)
    [16:08:28.041530] raopcl_create:735 [0xb6613f78]: using PCM coding
    [16:08:28.044834] output_raop_thread_init:126 [0x381338]: init output raop
    [16:08:28.044975] output_init_common:290 allocating 1764000
    [16:08:28.046085] slimproto:835 squeezelite [0x381338] <=> player [0x3d8c18]
    [16:08:28.046203] slimproto:836 [0x381338] connecting to 192.168.1.11:3483
    [16:08:28.047077] slimproto:866 [0x381338] connected
    [16:08:28.047171] sendHELO:118 [0x381338] cap: CanHTTPS=1,Model=squeezelite,ModelName=RaopBridge,AccuratePlayPoints=0,HasDigitalOut=1,MaxSampleRate=96000,aac,ogg,ops,ogf,flc,alc,wav,aif,pcm,mp3
    [16:08:28.065608] PlayerThread:562 [0x3d8c18]: processing off
    [16:10:30.296528] mDNSsearchCallback:630 [0x3d8c18]: removing renderer (Sonos-542A1B58F3AA)
    [16:10:30.296732] slimproto_close:907 [0x381338] slimproto stop for Sonos-542A1B58F3AA
    [16:10:30.588750] DelRaopDevice:978 [0x3d8c18]: Raop device stopped

  10. #2020
    It seems IGMP setting has something to do with this. The player becomes usually connected if my iPhone is on the same access point, then disconnects soon after. I enabled IGMP snooping on my router and it helped for a while (player was connected for a few days straight) but it then resumed the same behavior. Toggling the IGMP setting did not help anymore after this. Unfortunately my TP Link Deco access points do not have IGMP setting, only the router (TP Link Archer) has the IGMP snooping option available (but not IGMP server for example). Any tips how to improve the situation?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •