Home of the Squeezebox™ & Transporter® network music players.
Page 19 of 19 FirstFirst ... 9171819
Results 181 to 187 of 187
  1. #181
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,215
    ~/.lircrc is the default path squeezelite uses if no filename has been specified with the -i option.

    This has been fixed in picoreplayer 5.0 as we now include the path and filename with the -i option.

    For 4.1 I'd suggest putting your file at /usr/local/etc/lirc/lircrc as you suggested.

    Then add usr/local/etc/lirc/lircrc to the end of /opt/.filetool.lst and save your configuration.

    Then your file will be restored whenever you reboot pcp.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  2. #182
    Quote Originally Posted by hartzell View Post

    I've been getting a headless pi & IQaudio DAC+ working with the little silver Apple remote (A1294). I'm almost there (after a bit of digging and poking).

    I'm using piCorePlayer v4.1.0:

    [...]

    My last problem is that squeezelight fails to load the .lircrc file when running as root.

    I just noticed the piCorePlayer 5.0.0 release; my configuration with the A1294 works by installing the specific lircd.conf and lircrc files without the problems I described yesterday.

    Thanks for the great system!

  3. #183
    Sorry to be posting but am at a loss.

    Flashed picoreplayer with the latest image available, all setup OK on a pi3b+

    I want to connect an old monitor up and use jivelite and also control the system using a remote. This is proving problematic.

    I'm using a 3 pin IR receiver - /dev/lirc0 and it runs off gpio pin 17. This appears to work fine until I install jivelite whereupon lircd will no longer start automatically.

    I tried reflashing from scratch, installing jivelite, installing lirc but the same thing happens each time.

    Have also tried the -i option but either lircd does not start or aI am inputting it incorreclty.

    If I then remove jivelite, lirc, I am stuck in a loop where lirc says it's installed but not started. If I try to uninstall it again it seems to go through the motions but after a reboot it is still there but not running. A reflash is the only way (for me) to recover.


    I am obviously not a linux expert and have read through hours worth of threads which I have followed but for some reason my setup is not working. I don't think it is unique and have a harmony 650 so can program that with most remotes available which should make things easier.

    Harmony is programmed with Logitech squeezebox buttons and if I reflash the pi sd card and enable lirc all works out of the box, it's once I try and add jivelite things get messy.

    Any help gratefully received.

  4. #184
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,383
    Quote Originally Posted by PossumJenkins View Post
    Sorry to be posting but am at a loss.

    Flashed picoreplayer with the latest image available, all setup OK on a pi3b+

    I want to connect an old monitor up and use jivelite and also control the system using a remote. This is proving problematic.

    I'm using a 3 pin IR receiver - /dev/lirc0 and it runs off gpio pin 17. This appears to work fine until I install jivelite whereupon lircd will no longer start automatically.

    I tried reflashing from scratch, installing jivelite, installing lirc but the same thing happens each time.

    Have also tried the -i option but either lircd does not start or aI am inputting it incorreclty.

    If I then remove jivelite, lirc, I am stuck in a loop where lirc says it's installed but not started. If I try to uninstall it again it seems to go through the motions but after a reboot it is still there but not running. A reflash is the only way (for me) to recover.


    I am obviously not a linux expert and have read through hours worth of threads which I have followed but for some reason my setup is not working. I don't think it is unique and have a harmony 650 so can program that with most remotes available which should make things easier.

    Harmony is programmed with Logitech squeezebox buttons and if I reflash the pi sd card and enable lirc all works out of the box, it's once I try and add jivelite things get messy.

    Any help gratefully received.
    I think that lirc is for squeezelite only, If you want to use IR remotes with Jivelite you need to load IR-Tools

    Jeff
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 8.0 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  5. #185
    Quote Originally Posted by Jeff07971 View Post
    I think that lirc is for squeezelite only, If you want to use IR remotes with Jivelite you need to load IR-Tools

    Jeff

    Yup thanks for the advice, after accepting my own stupidity I have now got it sorted using the jivelite config file instead

    cheers

  6. #186

    remote support with DigiOne

    I've been experimenting successfully using PCP and Jivelite on a Pi 3B+ with the Pi 7" screen and the squeezebox IR remote connected to the GPIO via pin 25. All working beautifully out of the box. Thanks to the brilliant coders for making this work for Linux novices!

    Now I've bought an Allo DigiOne which will feed a Linn Numerik and other stuff which is where my current Squeezebox goes. Problem is the DigiOne doesn't pass the GPIO through so now I've lost the remote connection. Is there a simple solution to this? Something via USB?

    Thanks

  7. #187
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,830
    Quote Originally Posted by pfd View Post
    I've been experimenting successfully using PCP and Jivelite on a Pi 3B+ with the Pi 7" screen and the squeezebox IR remote connected to the GPIO via pin 25. All working beautifully out of the box. Thanks to the brilliant coders for making this work for Linux novices!

    Now I've bought an Allo DigiOne which will feed a Linn Numerik and other stuff which is where my current Squeezebox goes. Problem is the DigiOne doesn't pass the GPIO through so now I've lost the remote connection. Is there a simple solution to this? Something via USB?

    Thanks
    Depending on how much space you have around your Pi ... you might be able to add in a small GPIO splitter board to give you access to the pins.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •