Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,165

    Applet instal on LMS 7.9 issue

    Hi

    We are trying to implement an Applet for Jivelite running on piCorePlayer and we have success with LMS versions below 7.9.

    Is there anything different for installing applets on LMS 7.9 compared to previous versions?

    We add: http://picoreplayer.sourceforge.net/repo.xml to the "3. party Additional Repositories" in LMS click Save or OK.

    Next we go to Jivelite and via "Advanced menu" choose "Install Applet" and here you can select to install the piCorePlayer applet (which will install an extra menu). However it only works for LMS versions prior to 7.9
    The applet won't show up if the LMS is version 7.9.

    Regards
    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,323

    Applet instal on LMS 7.9 issue

    > We are trying to implement an Applet for Jivelite running on
    > piCorePlayer and we have success with LMS versions below 7.9.


    Is the LMS version the only difference? Eg. are you running all LMS
    you've tested on the exactly same platform etc.?

    > We add: http://picoreplayer.sourceforge.net/repo.xml to the "3. party
    > Additional Repositories" in LMS click Save or OK.


    Sourceforge sometimes is a problem because it's using re-directs and
    https. LMS does not support https on some platforms.

    > Next we go to Jivelite and via "Advanced menu" choose "Install Applet"
    > and here you can select to install the piCorePlayer applet (which will
    > install an extra menu). However it only works for LMS versions prior to
    > 7.9
    > The applet won't show up if the LMS is version 7.9.


    Does the applet not show up on the player at all? Enable debugging for
    plugin.extensions and watch the server.log file.

    --

    Michael

  3. #3
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,165
    Quote Originally Posted by mherger View Post
    > We are trying to implement an Applet for Jivelite running on
    > piCorePlayer and we have success with LMS versions below 7.9.


    Is the LMS version the only difference? Eg. are you running all LMS
    you've tested on the exactly same platform etc.?

    > We add: http://picoreplayer.sourceforge.net/repo.xml to the "3. party
    > Additional Repositories" in LMS click Save or OK.


    Sourceforge sometimes is a problem because it's using re-directs and
    https. LMS does not support https on some platforms.

    > Next we go to Jivelite and via "Advanced menu" choose "Install Applet"
    > and here you can select to install the piCorePlayer applet (which will
    > install an extra menu). However it only works for LMS versions prior to
    > 7.9
    > The applet won't show up if the LMS is version 7.9.


    Does the applet not show up on the player at all? Enable debugging for
    plugin.extensions and watch the server.log file.

    --

    Michael
    This is from 7.9

    [16-01-10 09:57:27.1087] Slim::Plugin::Extensions::Plugin::_parseXML (411) searching http://picoreplayer.sourceforge.net/repo.xml for type: plugin target: unix version: 7.9.0
    [16-01-10 09:57:27.1100] Slim::Plugin::Extensions::Plugin::_parseXML (473) no plugin entry in http://picoreplayer.sourceforge.net/repo.xml
    [16-01-10 09:57:27.1112] Slim::Plugin::Extensions::Plugin::_parseXML (496) found 0 extensions
    [16-01-10 09:57:27.1217] Slim::Plugin::Extensions::Plugin::findUpdates (309) no action required



    This is from 7.6.2

    [16-01-10 10:02:08.0833] Slim::Plugin::Extensions::Plugin::_parseXML (427) searching http://picoreplayer.sourceforge.net/repo.xml for type: plugin target: unix version: 7.6.2
    [16-01-10 10:02:08.0840] Slim::Plugin::Extensions::Plugin::_parseXML (486) no plugin entry in http://picoreplayer.sourceforge.net/repo.xml
    [16-01-10 10:02:08.0847] Slim::Plugin::Extensions::Plugin::_parseXML (509) found 0 extensions
    [16-01-10 10:02:08.0934] Slim::Plugin::Extensions::Plugin::findUpdates (328) no action required
    [16-01-10 10:03:09.0583] Slim::Plugin::Extensions::Plugin::getExtensions (343) using cached extensions xml http://www.mysqueezebox.com/public/plugins/other.xml
    [16-01-10 10:03:09.0592] Slim::Plugin::Extensions::Plugin::_parseXML (427) searching http://www.mysqueezebox.com/public/plugins/other.xml for type: applet target: jivelite version: 0.1.0
    [16-01-10 10:03:09.0602] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry RetroBrowser does not match, bad target version [0.1.0 outside 7.3, 7.3.*]
    [16-01-10 10:03:09.0609] Slim::Plugin::Extensions::Plugin::_parseXML (437) entry EnhancedDigitalOutput does not match, wrong target [jivelite != fab4]
    [16-01-10 10:03:09.0615] Slim::Plugin::Extensions::Plugin::_parseXML (437) entry DisplayOff does not match, wrong target [jivelite != fab4]
    [16-01-10 10:03:09.0627] Slim::Plugin::Extensions::Plugin::_parseXML (456) entry DemoApplet vers: 0.1 url: http://triodeapplets.googlecode.com/...pplet-v0.1.zip
    [16-01-10 10:03:09.0636] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry AlbumFlow does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0645] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry InformationScreen does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0653] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry CustomClock does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0662] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry PatchInstaller does not match, bad target version [0.1.0 outside 7.5, *]
    [16-01-10 10:03:09.0670] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry ScreenSwitcher does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0677] Slim::Plugin::Extensions::Plugin::_parseXML (437) entry SettingsRemover does not match, wrong target [jivelite != jive|fab4|baby]
    [16-01-10 10:03:09.0685] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry TextClock does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0693] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry LicenseManager does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0702] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry DiyFM does not match, bad target version [0.1.0 outside 7.3, 7.*]
    [16-01-10 10:03:09.0708] Slim::Plugin::Extensions::Plugin::_parseXML (437) entry Headphones does not match, wrong target [jivelite != jive]
    [16-01-10 10:03:09.0716] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry Weather does not match, bad target version [0.1.0 outside 7.0, 7.*]
    [16-01-10 10:03:09.0725] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry FontReplacer does not match, bad target version [0.1.0 outside 7.3, 7.*]
    [16-01-10 10:03:09.0731] Slim::Plugin::Extensions::Plugin::_parseXML (509) found 1 extensions
    [16-01-10 10:03:09.0785] Slim::Plugin::Extensions::Plugin::getExtensions (343) using cached extensions xml http://www.mysqueezebox.com/public/plugins/logitech.xml
    [16-01-10 10:03:09.0793] Slim::Plugin::Extensions::Plugin::_parseXML (427) searching http://www.mysqueezebox.com/public/plugins/logitech.xml for type: applet target: jivelite version: 0.1.0
    [16-01-10 10:03:09.0799] Slim::Plugin::Extensions::Plugin::_parseXML (486) no applet entry in http://www.mysqueezebox.com/public/plugins/logitech.xml
    [16-01-10 10:03:09.0805] Slim::Plugin::Extensions::Plugin::_parseXML (509) found 0 extensions
    [16-01-10 10:03:09.0834] Slim::Plugin::Extensions::Plugin::getExtensions (343) using cached extensions xml http://picoreplayer.sourceforge.net/repo.xml
    [16-01-10 10:03:09.0842] Slim::Plugin::Extensions::Plugin::_parseXML (427) searching http://picoreplayer.sourceforge.net/repo.xml for type: applet target: jivelite version: 0.1.0
    [16-01-10 10:03:09.0855] Slim::Plugin::Extensions::Plugin::_parseXML (456) entry piCorePlayer vers: 1.0 url: http://picoreplayer.sourceforge.net/...Player-1.0.zip
    [16-01-10 10:03:09.0864] Slim::Plugin::Extensions::Plugin::_parseXML (437) entry DemoApplet does not match, wrong target [jivelite != squeezelite]
    [16-01-10 10:03:09.0871] Slim::Plugin::Extensions::Plugin::_parseXML (509) found 1 extensions
    [16-01-10 10:03:09.0911] Slim::Plugin::Extensions::Plugin::getExtensions (343) using cached extensions xml http://www.mysqueezebox.com/public/p...repository.xml
    [16-01-10 10:03:09.0919] Slim::Plugin::Extensions::Plugin::_parseXML (427) searching http://www.mysqueezebox.com/public/p...repository.xml for type: applet target: jivelite version: 0.1.0
    [16-01-10 10:03:09.0926] Slim::Plugin::Extensions::Plugin::_parseXML (437) entry BBCRadio does not match, wrong target [jivelite != baby|fab4|squeezeplay]
    [16-01-10 10:03:09.0936] Slim::Plugin::Extensions::Plugin::_parseXML (443) entry DaylightClock does not match, bad target version [0.1.0 outside 7.4, *]
    [16-01-10 10:03:09.0943] Slim::Plugin::Extensions::Plugin::_parseXML (509) found 0 extensions

    Does this give a clue on what is going on?
    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  4. #4
    Senior Member
    Join Date
    Sep 2005
    Posts
    2,848
    Hi

    @ steen:
    The whole min & max are meant for the Version of lms.

    @Michael:
    is there any chance to add an "new" type of player "Jivelite" - into /usr/share/perl5/Slim/Player ?
    I somewhere read about some user wants a screensaver for Jivelite and unless Jivelite is known as a "has Display" that wont work (AFAIK).

    May that addon is the starting point for Steens plugin aswell?

    cheers

  5. #5
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,226
    LMS 7.8.1 looks for the applet, finds it and presents in the list of the Advanced installer in jivelite.

    Code:
    [16-01-10 12:00:48.9955] Slim::Plugin::Extensions::Plugin::getExtensions (343) using cached extensions xml http://picore
    player.sourceforge.net/repo.xml
    [16-01-10 12:00:48.9957] Slim::Plugin::Extensions::Plugin::_parseXML (427) searching http://picoreplayer.sourceforge.net
    /repo.xml for type: applet target: jivelite version: 0.1.0
    [16-01-10 12:00:48.9959] Slim::Plugin::Extensions::Plugin::_parseXML (456) entry piCorePlayer vers: 1.0 url: http://pico
    replayer.sourceforge.net/repo/piCorePlayer-1.0.zip
    [16-01-10 12:00:48.9961] Slim::Plugin::Extensions::Plugin::_parseXML (512) found 1 extensions
    whereas LMS 7.9 doesn't appear to even look for an applet in the picore repo.xml as I can find no corresponding entry in the 7.9 log.

    The attached zip file has full logs from both systems which are running i386 Debian 7.9.

    The picoreplayer repository is in the sourceforge web space which does not force a redirect to https. It serves plain http.
    Attached Files Attached Files
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,323

    Applet instal on LMS 7.9 issue

    >> Is the LMS version the only difference? Eg. are you running all LMS
    >> you've tested on the exactly same platform etc.?


    Ok, there indeed was an issue I introduced a long time ago... Should be
    fixed in the next build (or in git already). Thanks for bringing this up!

    --

    Michael

  7. #7
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,226
    Quote Originally Posted by mherger View Post
    >> Is the LMS version the only difference? Eg. are you running all LMS
    >> you've tested on the exactly same platform etc.?


    Ok, there indeed was an issue I introduced a long time ago... Should be
    fixed in the next build (or in git already). Thanks for bringing this up!

    --

    Michael
    Confirmed working now.

    Thank you.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •