Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 30
  1. #1
    Senior Member morris_minor's Avatar
    Join Date
    Nov 2007
    Location
    Surrey, UK
    Posts
    357

    Setting up piCorePlayer on WiFi

    I need to move one of my piCorePlayers to a location without ethernet access and so purchased a TP-Link TL-WN822N - which was shown as working adaptor with pCP v1.18b.

    However I haven't yet found a way to get it on the network wirelessly.

    With pCP on ethernet I've accessed the WiFi setup page, found my access point, entered the password, saved it. The next page comes up and it acquires a new IP lease - but the ethernet setting (and IP) still remains, with the newly acquired WiFi IP not working.

    What am I missing?

    How can I set up WiFi without pCP already being on the network via ethernet?

    Any help much appreciated, thanks . .
    Bob
    -+-+-+-
    Last.FM

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,757
    Once you've entered your SSID and password and saved, reboot your Pi, as it's rebooting remove the ethernet cable.

    Find your new (wireless) IP address using an app such as "Fing" on a phone or tablet, or in your router settings ui.
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  3. #3
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,879
    Quote Originally Posted by morris_minor View Post
    I need to move one of my piCorePlayers to a location without ethernet access and so purchased a TP-Link TL-WN822N - which was shown as working adaptor with pCP v1.18b.

    However I haven't yet found a way to get it on the network wirelessly.

    With pCP on ethernet I've accessed the WiFi setup page, found my access point, entered the password, saved it. The next page comes up and it acquires a new IP lease - but the ethernet setting (and IP) still remains, with the newly acquired WiFi IP not working.

    What am I missing?

    How can I set up WiFi without pCP already being on the network via ethernet?

    Any help much appreciated, thanks . .
    Bob
    hi morris_minor,

    If the wifi adaptor is supported by piCorePlayer, it should be as simple as filling in the wifi information and rebooting.

    If you turn [Beta] mode on, you will get a [Diagnostics] button on the wifi page giving you lots of wifi related information.

    Steen has done some nice documentation here: https://sites.google.com/site/picore.../home/how-to-1

    A couple a points:

    - You can have Ethernet and wifi working at the same time. You will get 2 IP addresses set via DHCP.
    - If you have a monitor attached, during booting, the last few lines will contain your IP address(es)
    - Main reasons wifi doesn't work
    + wrong username/password
    + hidden SSID
    + wifi adaptor not supported

    regards
    Greg

  4. #4
    Senior Member morris_minor's Avatar
    Join Date
    Nov 2007
    Location
    Surrey, UK
    Posts
    357
    Thanks guys! All good now.

    I upgraded to v1.21a and whipped the ethernet cable out while rebooting . . .

    I've also reported TP-Link TL-WN822N as working with this version of pCP
    -+-+-+-
    Last.FM

  5. #5
    Junior Member
    Join Date
    Jul 2016
    Posts
    29

    WiFi and piCorePlayer on RP3?

    I'm setting up a Raspberry Pi3 and HifiBerry Digi+ on piCorePlayer and have read about problems with weak WiFi and Bluetooth causing problems. The solution seems to be to disable internal WiFi and Bluetooth and use an Edimax or other suitable WiFi dongle in their place. I'm amenable to this but am interested in the group experience with this workaround. If this works is there a way to disable internal WiFi and BT in the GUI or do I have to attach a monitor and keyboard to make the change?
    Any chance piCorePlayer will make this an option in future revisions?
    Love the piCorePlayer and have been amazed with its sound on the RP2. Thanks for the help. Mark

  6. #6
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,879
    Hi Mark,

    I am glad you are liking piCorePlayer

    I think Paul has added a disable RPi3 wifi option to the [Wifi settings] page on pCP2.06.

    I don't think we have looked at disabling Bluetooth at the moment.

    regards
    Greg

  7. #7
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,521
    Quote Originally Posted by jclctr View Post
    I'm setting up a Raspberry Pi3 and HifiBerry Digi+ on piCorePlayer and have read about problems with weak WiFi and Bluetooth causing problems. The solution seems to be to disable internal WiFi and Bluetooth and use an Edimax or other suitable WiFi dongle in their place. I'm amenable to this but am interested in the group experience with this workaround. If this works is there a way to disable internal WiFi and BT in the GUI or do I have to attach a monitor and keyboard to make the change?
    Any chance piCorePlayer will make this an option in future revisions?
    Love the piCorePlayer and have been amazed with its sound on the RP2. Thanks for the help. Mark
    Mark, these problems are a bit like Mark Twain's death .

    Just set up the pi using the onboard wireless, works fine for me .

    atb

    Ronnie

  8. #8
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,757
    Quote Originally Posted by Greg Erskine View Post

    I don't think we have looked at disabling Bluetooth at the moment.

    regards
    Greg
    Specifically what the OP was refering to, RPi3/Digi+ combination.

    I had a problem with playback using this combination, but I swapped my Digi+ to a DAC+ on my RPi3, and used my Digi+ on a RPi2, both players working fine now

    I don't know if this problem has been fixed yet: https://support.hifiberry.com/hc/en-...able-bluetooth
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.1.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  9. #9
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,254
    You can disable it via ssh. By adding dtoverlay=pi3-disable-bt. To the boot config. That will be default in the next release.....and the drivers are patched too.

  10. #10
    Senior Member JackOfAll's Avatar
    Join Date
    Dec 2005
    Location
    London, UK
    Posts
    2,749
    Quote Originally Posted by Man in a van View Post
    Just set up the pi using the onboard wireless, works fine for me .
    Well, if you are happy with it Ronnie, then that's all that matters!

    For those wanting to disable Pi3 WIFI and BT, you need to "blacklist brcmfmac" driver (via /etc/modprobe.d conf file) for wifi and stick "dtoverlay=pi3-disable-bt" in /boot/config.txt for BT.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •