Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Junior Member
    Join Date
    May 2020
    Posts
    3

    Please help - lost 3 stations

    Hi,

    New here. Longtime Logitech radio user.

    If someone could point the way to adding the URL for mysqueezebox.com in the "Favorites" section for:

    WBZ-AM (1030) Boston (iHeart station)
    WOR-AM (710) NYC (iHeart station)
    and WROL-AM (980) Lowell, MA

    I'd be deeply grateful.

    Not the most tech-savy person, as you could surmise.

    Thanks in advance for someone's help.

    Peter
    Last edited by pdankens; 2020-05-08 at 17:51.

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,321
    WBZ-AM http://stream.revma.ihrhls.com/zc7729 (AAC stream - not sure if it will work on your device)
    WOR-AM http://stream.revma.ihrhls.com/zc5874 (as above)
    WROL-AM http://playerservices.streamtheworld.../WROLAMAAC.pls

    I guess that you are not running LMS locally. It could be a good time to set it up if you have something you could run it on (or buy a Raspberry Pi and run it on that).
    Two big reasons ...
    Many stations are moving to stream formats that the Squeezebox devices cannot play natively ... but LMS can transcode them.

    bpa has written a plugin for iHeartRadio
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3
    Junior Member
    Join Date
    May 2020
    Posts
    3
    Quote Originally Posted by Paul Webster View Post
    WBZ-AM http://stream.revma.ihrhls.com/zc7729 (AAC stream - not sure if it will work on your device)
    WOR-AM http://stream.revma.ihrhls.com/zc5874 (as above)
    WROL-AM http://playerservices.streamtheworld.../WROLAMAAC.pls

    I guess that you are not running LMS locally. It could be a good time to set it up if you have something you could run it on (or buy a Raspberry Pi and run it on that).
    Two big reasons ...
    Many stations are moving to stream formats that the Squeezebox devices cannot play natively ... but LMS can transcode them.

    bpa has written a plugin for iHeartRadio
    Paul, THANK YOU SO MUCH!

    Can I bother you one final time more?

    Gave you the wrong call letters for one! Looking for WCAP - 980AM in Lowell, MA.

    Thanks again and enjoy the weekend!

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,321
    I assume that WCAP 980AM have changed either their provider or how it is configured.

    The stream is something like
    https://5d1efda4a2995.streamlock.net.../playlist.m3u8
    That set of seemingly random letters and numbers might mean that it changes frequently and the domain name implies some form of protection.
    In any case - when it does play it is using a mechanism that I do not think the SB hardware can handle natively.

    I tried it via LMS to a SB Radio - with bps's PlayHLS plugin installed and it did not like it
    Plugins::PlayHLS::ScanHLS::gotSegmentHTTP (282) Pid 256 (100) unsupported stream type 27 (1b)

    Someone else might be able to find an alternative URL - or ask the broadcaster.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,542
    Quote Originally Posted by Paul Webster View Post
    I assume that WCAP 980AM have changed either their provider or how it is configured.

    The stream is something like
    https://5d1efda4a2995.streamlock.net.../playlist.m3u8
    That set of seemingly random letters and numbers might mean that it changes frequently and the domain name implies some form of protection.
    In any case - when it does play it is using a mechanism that I do not think the SB hardware can handle natively.

    I tried it via LMS to a SB Radio - with bps's PlayHLS plugin installed and it did not like it
    Plugins::PlayHLS::ScanHLS::gotSegmentHTTP (282) Pid 256 (100) unsupported stream type 27 (1b)

    Someone else might be able to find an alternative URL - or ask the broadcaster.
    The stream type 27 - means there is a video stream as well as an audio one.
    The stream plays OK for me with PlayHLS 2.3 but it means the stream has a bitrate of about 425kbps yet relatively low quality audio. The video is just a static station logo. I don't understand this crazy use of bandwidth.

    I added support to discard video in 2.3 but only had a few test stations so I'm sure there are cases where it doesn't work. What is the setup that fails - OS, LMS version and player type.

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,321
    pCP 6
    Logitech Media Server Version: 8.0.0 - 1587398922 @ Mon Apr 20 18:25:01 CEST 2020
    PlayHLS 2.3
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,542
    Quote Originally Posted by Paul Webster View Post
    pCP 6
    Logitech Media Server Version: 8.0.0 - 1587398922 @ Mon Apr 20 18:25:01 CEST 2020
    PlayHLS 2.3
    Thanks.

    Strange issue - native AAC players (e.g. Squeezelite, Touch) will play but it takes about 45-60 secs before audio starts. I'm guessing you gave up way before that.
    Playing starts after about 15 secs for transcoded streams.

    Not sure I think the issue is partly due to so much video vs audio contents and possibly initial buffering in player/LMS. I'll look into it.

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,542
    Just to close off the WCAP issue and a bit academic to OP as they use mysqueezebox.com.

    The HLS playlist indicated a bandwidth of 449747 bps
    Code:
    #EXT-X-STREAM-INF:BANDWIDTH=449747,CODECS="avc1.100.31,mp4a.40.2",RESOLUTION=852x480
    This meant LMS put buffer threshold at max as it expected a very fast high volume audio stream. The audio contents of the HLS stream is only about 48kbps so the initial start time was very slow as LMS expected a lot of data to fillplayer buffer in a short time - a 449kbps stream and not a 48kbps one.

    I'll do a rev of PlayHLS with a tweak to do a guess of likely audio bit rate just from the audio stream characteristics.

    There is a separate issue where LMS does a timeout of 5-10 secs during initial scan of the stream. Not sure of the root cause.

  9. #9
    Junior Member
    Join Date
    May 2020
    Posts
    3
    Thanks to all of you for your time, your expertise and your help.

    Have a great day during these trying times.

  10. #10
    Junior Member
    Join Date
    Sep 2018
    Posts
    4

    One more request

    I lost WBZam also and the newly posted stream works perfectly. One more request- WSAR 1400am or 95.9FM. Thanks Paul!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •