Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Senior Member
    Join Date
    May 2008
    Posts
    382

    Squeezelite-x silence in playback from mid-track onwards

    I'm running Squeezelite-x on Windows 10. LMS server v8.1.1 on Linux. I have Squeezelite-x playing a Random song mix. Every few songs I find that the audio disappears mid-track. The track continues playing but the remainder of the track is silent. If I skip to the next track it starts playing back normally.
    Has anyone else noticed this behaviour?

  2. #2
    Senior Member
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Posts
    162
    Quote Originally Posted by itm View Post
    I'm running Squeezelite-x on Windows 10. LMS server v8.1.1 on Linux. I have Squeezelite-x playing a Random song mix. Every few songs I find that the audio disappears mid-track. The track continues playing but the remainder of the track is silent. If I skip to the next track it starts playing back normally.
    Has anyone else noticed this behaviour?
    I am running squeezelite-x v2.7.16 on win10 - I use it to control other players, but turned on the player functionality to test your scenario. My LMS v8.1.1 is on Ubuntu 20.04.2. All working fine so far on random song mix a few songs in - will let it play and report back if I see what you are seeing.

    Might check your LMS logs for anything interesting. Also F12 in slx has some logging too, and you can add logging to squeezelite within slx with advanced options (-f <logfile> Write debug to logfile)

    TomS
    SB3(1), Boom(2), Radio(3), piCorePlayer (1)

  3. #3
    Senior Member
    Join Date
    May 2008
    Posts
    382
    Quote Originally Posted by TomS View Post
    I am running squeezelite-x v2.7.16 on win10 - I use it to control other players, but turned on the player functionality to test your scenario. My LMS v8.1.1 is on Ubuntu 20.04.2. All working fine so far on random song mix a few songs in - will let it play and report back if I see what you are seeing.

    Might check your LMS logs for anything interesting. Also F12 in slx has some logging too, and you can add logging to squeezelite within slx with advanced options (-f <logfile> Write debug to logfile)

    TomS
    Thanks. There's nothing in the server log at that time, and nothing unusual in the F12 log from Squeezebox-Lite-X.

  4. #4
    Senior Member
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Posts
    162
    Quote Originally Posted by TomS View Post
    I am running squeezelite-x v2.7.16 on win10 - I use it to control other players, but turned on the player functionality to test your scenario. My LMS v8.1.1 is on Ubuntu 20.04.2. All working fine so far on random song mix a few songs in - will let it play and report back if I see what you are seeing.

    Might check your LMS logs for anything interesting. Also F12 in slx has some logging too, and you can add logging to squeezelite within slx with advanced options (-f <logfile> Write debug to logfile)

    TomS
    Okay, I have seen 2x now a pause for 10ish seconds at about 5 min into an M4A (AAC, i.e. compressed) file. It picks up where it left off though.

    On my LMS, I have AAC streamed directly to the player, or so I think from the file types menu (Native).

    Name:  2021-02-23_14-20-02.jpg
Views: 44
Size:  41.3 KB

    With this setting I see a pause at 5 min.

    If I changed that "native" to "disabled" I assume LMS does some transcoding and I *do not* see the pause at 5 min.

    Most of my library is flac so I was lucky to catch it with this m4a. I will try a few more m4a (AAC) files to confirm.

    TomS

    [EDIT] the same file played on squeezelite on a rPi 3 (piCorePlayer) served from same LMS does not show pause/silence at 5 min.
    Last edited by TomS; 2021-02-23 at 12:39. Reason: more info, another sqlt tplayer
    SB3(1), Boom(2), Radio(3), piCorePlayer (1)

  5. #5
    Senior Member
    Join Date
    May 2008
    Posts
    382
    Thanks for that. My files are mp3, which is also set to "Native" in the File Types menu. I'll try setting it to "Disabled" to see if it improves things.

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,090
    Quote Originally Posted by itm View Post
    Thanks for that. My files are mp3, which is also set to "Native" in the File Types menu. I'll try setting it to "Disabled" to see if it improves things.
    The issue sounds similar to the one in this thread.
    https://forums.slimdevices.com/showt...very-5-minutes

    Perhaps you should try ralphy's experimental version of squeezelite.

  7. #7
    Senior Member
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Posts
    162

    sqlx log of sorts

    just to be more complete in case it is helpful, adding -f <logfilename> to squeezelite parameters produced an empty log file, but these lines below are from the sqlx (f12) log window. Again, this is with Native for AAC.

    Music started at 14:55:01, and at 15:00:01 it stopped for approx 30 sec, resuming at 15:00:34. My rPi 4 with piCorePlayer (incl squeezelite) does not pause.

    Tom

    Code:
    INFO   14:54:21.378  SND (CLI): serverstatus 0 0
    INFO   14:54:21.423  RCV (CLI): serverstatus 0 0 lastscan:1614009368 version:8.1.1 uuid:xxxxx mac:14:xx:xx:xx:xx:xx ip:192.168.5.163 httpport:9000 info·total·albums:2052 info·total·artists:7416 info·total·genres:73 info·total·songs:25300 info·total·duration:6020916.27600008 player·count:10 sn·player·count:1 other·player·count:0
    INFO   14:54:21.423  Remember last connected known host: Ip=192.168.5.163, Mac=xx:xx:xx:xx:xx
    INFO   14:54:21.462  SND (CLI): yy:yy:yy:yy:yy:yy [title ?;artist ?;album ?]
    INFO   14:54:21.472  RCV (CLI): yy:yy:yy:yy:yy:yy title Right·Hand·Man
    INFO   14:54:21.510  RCV (CLI): yy:yy:yy:yy:yy:yy artist Christopher·Jackson,·Lin-Manuel·Miranda,·Leslie·Odom,·Jr.·&·Original·Broadway·Cast·of·Hamilton
    INFO   14:54:21.510  RCV (CLI): yy:yy:yy:yy:yy:yy album Hamilton·(Original·Broadway·Cast·Recording)·(Disc·1·of·2)
    INFO   14:55:01.586  RCV (CLI): yy:yy:yy:yy:yy:yy playlist jump 0   
    INFO   14:55:01.586  RCV (CLI): yy:yy:yy:yy:yy:yy playlist open file:///music/itunes/Compilations/Hamilton%20(Original%20Broadway%20Cast%20Recordi/1-08%20Right%20Hand%20Man.m4a
    INFO   14:55:01.586  RCV (CLI): yy:yy:yy:yy:yy:yy playlist open file:///music/itunes/Compilations/Hamilton%20(Original%20Broadway%20Cast%20Recordi/1-08%20Right%20Hand%20Man.m4a
    INFO   14:55:01.764  RCV (CLI): yy:yy:yy:yy:yy:yy playlist newsong Right·Hand·Man 0
    INFO   14:55:01.827  QueryNowPlaying Complete [59ms]
    INFO   15:00:34.129  RCV (CLI): yy:yy:yy:yy:yy:yy playlist open file:///music/itunes/Compilations/Hamilton%20(Original%20Broadway%20Cast%20Recordi/1-08%20Right%20Hand%20Man.m4a
    INFO   15:00:34.172  RCV (CLI): yy:yy:yy:yy:yy:yy playlist open file:///music/itunes/Compilations/Hamilton%20(Original%20Broadway%20Cast%20Recordi/1-08%20Right%20Hand%20Man.m4a
    INFO   15:00:34.309  RCV (CLI): yy:yy:yy:yy:yy:yy playlist newsong Right·Hand·Man 0
    INFO   15:00:34.363  QueryNowPlaying Complete [51ms]
    INFO   15:00:56.005  RCV (CLI): yy:yy:yy:yy:yy:yy playlist stop
    EDIT: tried another m4a (aac) file and saw the same 30 seconds of silence at 5:25 into it. Log looks similar to above.
    Last edited by TomS; 2021-02-23 at 14:41. Reason: tried another song, same issue
    SB3(1), Boom(2), Radio(3), piCorePlayer (1)

  8. #8
    Senior Member
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Posts
    162
    the transcoding is a red herring - thanks to bpa for the link to the previous thread on this - for me upping the buffer size in the squeezelite parameters in sqlx fixed it for my 6 minute songs. I added the option "-b 16384" to increase it. If you had a super long track, I don't know how it would behave.

    (btw running squeezelite 1.9.8-1344 (x64) inside of sqlx, which I think is later than his experimental versions).

    TomS
    SB3(1), Boom(2), Radio(3), piCorePlayer (1)

  9. #9
    Senior Member
    Join Date
    May 2008
    Posts
    382
    Quote Originally Posted by TomS View Post
    the transcoding is a red herring - thanks to bpa for the link to the previous thread on this - for me upping the buffer size in the squeezelite parameters in sqlx fixed it for my 6 minute songs. I added the option "-b 16384" to increase it. If you had a super long track, I don't know how it would behave.

    (btw running squeezelite 1.9.8-1344 (x64) inside of sqlx, which I think is later than his experimental versions).

    TomS
    Thanks for the tip. I've been trying to add the "-b 16384" parameter by running Squeezelite-X from the command line in Windows 10, but I get an "Access is denied" error whenever I try to run it - even if I open the command window as Administrator.
    May I ask how you are executing the command?

  10. #10
    Senior Member
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Posts
    162
    Quote Originally Posted by itm View Post
    Thanks for the tip. I've been trying to add the "-b 16384" parameter by running Squeezelite-X from the command line in Windows 10, but I get an "Access is denied" error whenever I try to run it - even if I open the command window as Administrator.
    May I ask how you are executing the command?
    Add that option in the squeezelite player options inside of sqlx. The little "..." button next to player name in the settings page, shown in the pic below.

    TomS.

    Name:  options.jpg
Views: 16
Size:  85.1 KB
    SB3(1), Boom(2), Radio(3), piCorePlayer (1)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •