Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Joseph Dell'Orfano
    Guest

    m4a and slimserver

    Hi all. I am running slimserver on linux, fedora core 1. I
    cannot stream m4a files despite the published fix. I modified the
    convert.conf file to include...

    mov wav squeezebox *
    [faad] -w -f 2 $FILE$

    After restarting slimserver and confirming that the appropriate filetype
    was checked in the server settings, slimserver will not play this file.
    I found references on this list pointing to faad, so I compiled an
    earlier version (in fact, I compiled several versions) without success.
    I have confirmed that faad works properly and that xmms continues to
    play .m4a files with the faad plugins.

    I have a fix, however. If I comment out the above lines and add this...

    mov mp3 * *
    [faad] -w $FILE$ | lame -h - -

    then it works. I do not understand why the original config wouldn't
    work, as this turns the file into a .wav and slimserver is supposed to
    stream wav files. In fact, I have no problem streaming other .wav files.
    My solution obviously converts the .wav output of faad into a .mpg
    (along with a loss of sound quality I'm sure).

    Anybody have this problem? Thanks.

    -Joe Dell'Orfano

  2. #2
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    m4a and slimserver

    Slimserver streams according to the bitrate limiting setting in
    PlayerSettings->Audio. By default, a Squeezebox hooked up by wireless will be
    set to limit at 320kbps MP3. This gives the typical user the best experience
    out of box (no dropouts). If your wireless network is free from interference
    enough to handle full PCM output, you can always set your player settings to
    'no limit' and the conversions will use WAV as the output (thus yoru first line
    in convert.conf will work). Default setting for wired squeezeboxen is no
    limit.

    Generally, when modifying your own lines for convert.conf, its a good idea to
    include both mp3 AND wav conversion lines to cover all cases. Also, to avoid
    this line being removed when you upgrade slimserver versions, you can also use
    slimserver-convert.conf for your custom lines.

    -kdf

    Quoting Joseph Dell'Orfano <fullgo (AT) dellorfano (DOT) net>:

    > Hi all. I am running slimserver on linux, fedora core 1. I
    > cannot stream m4a files despite the published fix. I modified the
    > convert.conf file to include...
    >
    > mov wav squeezebox *
    > [faad] -w -f 2 $FILE$
    >
    > After restarting slimserver and confirming that the appropriate filetype
    > was checked in the server settings, slimserver will not play this file.
    > I found references on this list pointing to faad, so I compiled an
    > earlier version (in fact, I compiled several versions) without success.
    > I have confirmed that faad works properly and that xmms continues to
    > play .m4a files with the faad plugins.
    >
    > I have a fix, however. If I comment out the above lines and add this...
    >
    > mov mp3 * *
    > [faad] -w $FILE$ | lame -h - -
    >
    > then it works. I do not understand why the original config wouldn't
    > work, as this turns the file into a .wav and slimserver is supposed to
    > stream wav files. In fact, I have no problem streaming other .wav files.
    > My solution obviously converts the .wav output of faad into a .mpg
    > (along with a loss of sound quality I'm sure).
    >
    > Anybody have this problem? Thanks.
    >
    > -Joe Dell'Orfano
    >
    >

  3. #3
    Joseph Dell'Orfano
    Guest

    m4a and slimserver

    YES! Thank you. Now I understand it. Of course this makes sense!!

    Well, I suppose I have a valid fix for this problem with wireless
    squeezeboxes.

    -Joe


    On Mon, 2004-12-13 at 19:45, kdf wrote:
    > Slimserver streams according to the bitrate limiting setting in
    > PlayerSettings->Audio. By default, a Squeezebox hooked up by wireless will be
    > set to limit at 320kbps MP3. This gives the typical user the best experience
    > out of box (no dropouts). If your wireless network is free from interference
    > enough to handle full PCM output, you can always set your player settings to
    > 'no limit' and the conversions will use WAV as the output (thus yoru first line
    > in convert.conf will work). Default setting for wired squeezeboxen is no
    > limit.
    >
    > Generally, when modifying your own lines for convert.conf, its a good idea to
    > include both mp3 AND wav conversion lines to cover all cases. Also, to avoid
    > this line being removed when you upgrade slimserver versions, you can also use
    > slimserver-convert.conf for your custom lines.
    >
    > -kdf
    >
    > Quoting Joseph Dell'Orfano <fullgo (AT) dellorfano (DOT) net>:
    >
    > > Hi all. I am running slimserver on linux, fedora core 1. I
    > > cannot stream m4a files despite the published fix. I modified the
    > > convert.conf file to include...
    > >
    > > mov wav squeezebox *
    > > [faad] -w -f 2 $FILE$
    > >
    > > After restarting slimserver and confirming that the appropriate filetype
    > > was checked in the server settings, slimserver will not play this file.
    > > I found references on this list pointing to faad, so I compiled an
    > > earlier version (in fact, I compiled several versions) without success.
    > > I have confirmed that faad works properly and that xmms continues to
    > > play .m4a files with the faad plugins.
    > >
    > > I have a fix, however. If I comment out the above lines and add this...
    > >
    > > mov mp3 * *
    > > [faad] -w $FILE$ | lame -h - -
    > >
    > > then it works. I do not understand why the original config wouldn't
    > > work, as this turns the file into a .wav and slimserver is supposed to
    > > stream wav files. In fact, I have no problem streaming other .wav files.
    > > My solution obviously converts the .wav output of faad into a .mpg
    > > (along with a loss of sound quality I'm sure).
    > >
    > > Anybody have this problem? Thanks.
    > >
    > > -Joe Dell'Orfano
    > >
    > >

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •