Home of the Squeezebox™ & Transporter® network music players.
Page 7 of 7 FirstFirst ... 567
Results 61 to 70 of 70
  1. #61
    Senior Member
    Join Date
    Dec 2009
    Location
    Hilden, Germany
    Posts
    136
    I don't know what I changed. But in a second try it did work.

    Gesendet von meinem ONEPLUS A3003 mit Tapatalk

  2. #62
    Junior Member
    Join Date
    Mar 2017
    Posts
    2
    Not sure what I missed, but going through it again seems to have fixed it for me as well. Thanks folks!

  3. #63
    Junior Member
    Join Date
    Dec 2017
    Posts
    4

    Problem with LMS on Freenas11

    Hi!
    I have a problem with LMS on Freenas 11. When I try to run LMS, I have a message:

    Code:
    Starting lms.
    The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    ....
    Why it doesn't work? Everything (PERL version, LMS version, users, groups, access rights etc) seems to be OK, but it doesn't work...

  4. #64
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,964

    How to: Installing LMS 7.9 nightly in aFreeBSD jail on FreeNAS 9.3

    > The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    > ....
    >
    > Why it doesn't work? Everything (PERL version, LMS version, users,
    > groups, access rights etc) seems to be OK, but it doesn't work...

    Quite obviously the Perl version is not ok. It's missing above modules.
    Did you try to build the modules as outlined in this thread?

    --
    --

    Michael

  5. #65
    Junior Member
    Join Date
    Mar 2016
    Posts
    3
    Quote Originally Posted by alayer View Post
    Hi!
    I have a problem with LMS on Freenas 11. When I try to run LMS, I have a message:

    Code:
    Starting lms.
    The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    ....
    Why it doesn't work? Everything (PERL version, LMS version, users, groups, access rights etc) seems to be OK, but it doesn't work...
    Hi,
    If you are on Freenas 11, why not running LMS in Docker?

  6. #66
    Junior Member
    Join Date
    Dec 2017
    Posts
    4

    Still doesn't work

    Quote Originally Posted by mherger View Post
    > The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    > ....
    >
    > Why it doesn't work? Everything (PERL version, LMS version, users,
    > groups, access rights etc) seems to be OK, but it doesn't work...

    Quite obviously the Perl version is not ok. It's missing above modules.
    Did you try to build the modules as outlined in this thread?

    --
    --

    Michael
    1. I built lms in lms_build jail, using RichieB script (https://github.com/RichieB2B/lms-freenas ).
    After 30 minutes - success!
    Code:
    Building complete! The result is in /tmp/LMS/logitechmediaserver-7.9.0-FreeBSD.tar
    root@build_lms:/usr/home/al # ll /tmp/LMS/
    total 49006
    -rw-r--r--   1 root   wheel     11518 Dec  8 23:44 buildme.sh.log
    drwx------  12 10184  10017        39 Mar  8  2017 logitechmediaserver-7.9.0-FreeBSD/
    -rw-r--r--   1 root   wheel  42740224 Dec  8 23:44 logitechmediaserver-7.9.0-FreeBSD.tar
    -rw-r--r--   1 root   wheel  24084509 Mar  8  2017 logitechmediaserver-7.9.0-FreeBSD.tgz
    drwxr-xr-x  10 root   wheel        11 Dec  8 23:44 slimserver-vendor/
    2. Then I made a second jail, lms, and installed my fresh logitechmediaserver-7.9.0-FreeBSD.tar as described in this thread ( e.g. in coreadale post). Unfortunately, when I want to start LMS, i had a message:

    Code:
    root@lms:/tmp/lms # /etc/rc.d/lms start
    Starting lms.
    The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    
    
    *******
    
    NOTE:
    
    If you're running some unsupported Linux/Unix platform, please use the buildme.sh
    script located here:
    
    https://github.com/Logitech/slimserver-vendor/tree/public/7.9/CPAN
    
    If 7.9 is outdated by the time you read this, Replace "7.9" with the major version
    You should never need to do this if you're on Windows or Mac OSX. If the installers
    don't work for you, ask for help and/or report a bug.
    
    *******
    
    
    Exiting..
    root@lms:/tmp/lms #
    I don't know much about FreeBSD or freenas 11, so I don't know what I do wrong. Tomorrow I will start with Docker, as Cadavor suggest.

    Best regards,
    Andrzej
    Last edited by alayer; 2017-12-09 at 00:22.

  7. #67
    Senior Member
    Join Date
    Feb 2013
    Posts
    370
    Quote Originally Posted by alayer View Post
    1. I built lms in lms_build jail, using RichieB script (https://github.com/RichieB2B/lms-freenas ).
    After 30 minutes - success!
    Code:
    Building complete! The result is in /tmp/LMS/logitechmediaserver-7.9.0-FreeBSD.tar
    root@build_lms:/usr/home/al # ll /tmp/LMS/
    total 49006
    -rw-r--r--   1 root   wheel     11518 Dec  8 23:44 buildme.sh.log
    drwx------  12 10184  10017        39 Mar  8  2017 logitechmediaserver-7.9.0-FreeBSD/
    -rw-r--r--   1 root   wheel  42740224 Dec  8 23:44 logitechmediaserver-7.9.0-FreeBSD.tar
    -rw-r--r--   1 root   wheel  24084509 Mar  8  2017 logitechmediaserver-7.9.0-FreeBSD.tgz
    drwxr-xr-x  10 root   wheel        11 Dec  8 23:44 slimserver-vendor/
    2. Then I made a second jail, lms, and installed my fresh logitechmediaserver-7.9.0-FreeBSD.tar as described in this thread ( e.g. in coreadale post). Unfortunately, when I want to start LMS, i had a message:

    Code:
    root@lms:/tmp/lms # /etc/rc.d/lms start
    Starting lms.
    The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    
    
    *******
    
    NOTE:
    
    If you're running some unsupported Linux/Unix platform, please use the buildme.sh
    script located here:
    
    https://github.com/Logitech/slimserver-vendor/tree/public/7.9/CPAN
    
    If 7.9 is outdated by the time you read this, Replace "7.9" with the major version
    You should never need to do this if you're on Windows or Mac OSX. If the installers
    don't work for you, ask for help and/or report a bug.
    
    *******
    
    
    Exiting..
    root@lms:/tmp/lms #
    I don't know much about FreeBSD or freenas 11, so I don't know what I do wrong. Tomorrow I will start with Docker, as Cadavor suggest.

    Best regards,
    Andrzej

    Did you check that it's not the same simple error as posted in #51? Building LMS using this method in FreeNAS 11 does work, I did it about two months ago. To use Docker in FreeNAS, you'd have to create a linux virtual machine first to run docker. This seems rather pointless when you can just install LMS in the virtual machine. In any case, LMS running in a virtual machine inside FreeNAS does not have direct access to your zfs pool data, you have to setup network shares to mount within the virtual machine. Performance is better when using jails.

  8. #68
    Junior Member
    Join Date
    Dec 2017
    Posts
    4
    @Krisbee I think you're right - there must be a stupid, simple error I made somewhere, but I can't find it. In #51 there is only:


    Code:
    EDIT: Tried it again. Now it works! Thanks alot!
    but why "it works" now??? In my case there are no problems with .tar extensions, I run every command separately for error checking, and because I want to learn more about FreeBSD and Freenas. I like to see how it works and with every try I think I know more, for example how to compile FreeBSD ports :-)

  9. #69
    Senior Member
    Join Date
    Feb 2013
    Posts
    370
    Quote Originally Posted by alayer View Post
    @Krisbee I think you're right - there must be a stupid, simple error I made somewhere, but I can't find it. In #51 there is only:


    Code:
    EDIT: Tried it again. Now it works! Thanks alot!
    but why "it works" now??? In my case there are no problems with .tar extensions, I run every command separately for error checking, and because I want to learn more about FreeBSD and Freenas. I like to see how it works and with every try I think I know more, for example how to compile FreeBSD ports :-)
    One thing you might check is if the build jail and jail used to run LMS both used the same version of perl. And I'd also check the contents of the "buildme.sh.log".

  10. #70
    Junior Member
    Join Date
    Dec 2017
    Posts
    4

    Finally - IT WORKS!!!

    After 4 busy evenings LMS is running
    The problem is with PERL versions.
    Perl, FreeNAS11:
    Code:
    [root@freenas11 ~]# perl --version                                              
                                                                                    
    This is perl 5, version 20, subversion 3 (v5.20.3) built for amd64-freebsd-threa
    d-multi
    Perl in jails:
    Code:
    $ perl --version
    
    This is perl 5, version 24, subversion 1 (v5.24.1) built for amd64-freebsd-thread-multi
    Perl in jails after pkg update/upgrade commands:
    Code:
    root@lms_build:/usr/home/al # perl --version
    
    This is perl 5, version 24, subversion 3 (v5.24.3) built for amd64-freebsd-thread-multi
    Third version

    You can't build LMS (./buildme.sh) using PERL 5.24.3, 5.22.4, 5.26.1. Compilation works ONLY with Perl 5.24.1.
    So simply don't execute
    Code:
    pkg update
    pkg upgrade
    in lms_built and lms jails - and it works.

    I downloaded logitechmediaserver-7.9.1-1512734075-FreeBSD.tgz from h t t p : / / downloads-origin.slimdevices.com / nightly/?ver=7.9 , instructions like Coreadale wrote in #50 with some modifications (Perl versions, no pkg update/upgrade, no wget - I downloaded latest LMS version manually, after building LMS more directories to remove (rm -rf 5.26) and in LMS jail:
    Code:
    pkg install p5-IO-Socket-SSL
    So - it was very interestig for me to learn how to build LMS, thanks to all of you for all posts in this thread, really very helpfull. Now it's time for music

    Andrzej
    Last edited by alayer; 2017-12-15 at 08:31.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •