Home of the Squeezebox™ & Transporter® network music players.
Page 304 of 314 FirstFirst ... 204254294302303304305306 ... LastLast
Results 3,031 to 3,040 of 3139
  1. #3031
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Quote Originally Posted by Cebolla View Post
    From your picture looks like it's the original 2008 Caruso - not surprising the old girl has problems with UPnP streaming!
    Attachment 33129
    Don't be too disappointed if the only solution is to hang another one of your RPi Squeezelite based players out of the back.
    Upnp-Streaming is a crab at all and yes that might be an option, yet i do need the two analog inputs of the Caruso for TV and my Thorens turntable. The old diva itself drives a sub and two active speakers. All in all a very clean solution with a minimum of devices.
    I discovered a stable workaround. The problem of loosing contact can be fixed by bypassing the network connecting my old diva directly to the router. It works with power lan or with a separate cable. Looking forward to using an old telephone-cable for 100 Mbit in order to get rid off the power lan. Choices ...

    Regards

    Thomas

  2. #3032
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,639
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3033
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Quote Originally Posted by Paul Webster View Post
    Interesting. However the development of my device started more than 13 years ago. Probably they did it on their own for the 1st edition.

    There is still an App in the apple-store for their elder devices and this app as well as the UPnP-App "mconnect" finds my caruso behind every switch and does work, but
    the T&A App is very old-school compared to Squeezepad and/or Ipeng ... and
    I won┤t miss the performance and integration to handle all my clients within one solution/app ... and
    in addition to that via shairtunes and the bridge i can stream itunes or youtube content from my iphone/ipad to the old diva.


    Regards
    Thomas
    Last edited by oneleveller; 2021-01-28 at 07:44.

  4. #3034
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Quote Originally Posted by oneleveller View Post
    Interesting. However the development of my device started more than 13 years ago. Probably they did it on their own for the 1st edition.

    There is still an App in the apple-store for their elder devices and this app as well as the UPnP-App "mconnect" finds my caruso behind every switch and does work, but
    the T&A App is very old-school compared to Squeezepad and/or Ipeng ... and
    I won┤t miss the performance and integration to handle all my clients within one solution/app ... and
    in addition to that via shairtunes and the bridge i can stream itunes or youtube content from my iphone/ipad to the old diva.


    Regards
    Thomas
    T&A APP (needs an UPnP Server running e.g. Twonky)

    Name:  TA App.png
Views: 158
Size:  114.0 KB


    Squeezepad with LMS and UPnP-bridge

    Name:  Squeezepad.jpg
Views: 158
Size:  36.0 KB

    Regards Thomas
    Last edited by oneleveller; 2021-01-28 at 07:49.

  5. #3035
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,726
    Quote Originally Posted by rdmaidment View Post
    I have tried this but it didn't make any difference but thanks for thinking of it.
    Too bad... the only option now is to "lobby" Roon so that they support the CLI interface emulation on port 9090
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  6. #3036
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,726
    Quote Originally Posted by mftech View Post
    Here's the log for the LUMIN T2, jhope this helps, if not, provide me instructions
    So I have your PM now. The Lumin does not like probably the HTTP chunked mode (I remember talking with another forum member about that and probably concluding that was yet another broken HTTP stack, non compliant to the standard). So you can try

    • Set HTTP mode to "no length"
    • If this does not work, try to always send WAV/PCM/AIF files by
      - either selecting transcoding to "pcm" and then in "UPnP player audio capabilities", select "show advanced" and make sure that "PCM format" is "wav" (you can try "raw" if it does not work)
      - or limit the codecs to "wav, pcm, aif"
    • If this still does not work, go back to defaults and set HTTP mode to "fixed length"
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  7. #3037
    Senior Member mftech's Avatar
    Join Date
    Sep 2005
    Location
    Carignan
    Posts
    177
    Quote Originally Posted by philippe_44 View Post
    So I have your PM now. The Lumin does not like probably the HTTP chunked mode (I remember talking with another forum member about that and probably concluding that was yet another broken HTTP stack, non compliant to the standard). So you can try

    • Set HTTP mode to "no length"
    • If this does not work, try to always send WAV/PCM/AIF files by
      - either selecting transcoding to "pcm" and then in "UPnP player audio capabilities", select "show advanced" and make sure that "PCM format" is "wav" (you can try "raw" if it does not work)
      - or limit the codecs to "wav, pcm, aif"
    • If this still does not work, go back to defaults and set HTTP mode to "fixed length"
    Merci Philippe...I`ll try your suggestions tonight.
    Tŕte Ó FLAC

    2 X SB Classic
    2 X SB2
    1 X SB Boom
    1 X SB Touch
    1 X Transporter
    2 X Duet + Remote
    3 X Rpi+Picoreplayer
    2 X Chromecast
    1 X Chromecast Audio
    1 X Atoll ST100

    All devives connected via CeolBOX server aka The Musical Box
    Using OrangeSqueeze and Material Skin Plug-in to remote all my connected devices.

  8. #3038
    Quote Originally Posted by philippe_44 View Post
    Sonos does not support raw PCM format (only wav), so in the "24 bits PCM" parameter "packed type 1" is irrelevant.
    Thanks Philippe. As usual I was getting confused about how all this stuff works. I wrongly assumed it was sending raw PCM because I'm seeing codec=p in the logs... but I'd forgotten about the extra config setting which tells it to use WAV as the PCM format. Sorry!

  9. #3039
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,639
    Very old Philips Fidelio ... works but slow to get going.

    Can you suggest a setting that might make it start more quickly?
    Right now everything is as default.

    Code:
    [16:28:40.106955] sq_callback:375 [0x423d28]: set current URI (s:0) http://192.168.2.152:60461/bridge-2.mp3
    [16:28:40.107765] AVTSetURI:91 [0x423d28]: uPNP setURI http://192.168.2.152:60461/bridge-2.mp3 (cookie 0x12)
    [16:28:40.113016] process_start:1202 [0x3a2fe0]: codec:*, ch:0, s:0, r:0
    [16:28:40.130911] sendSTAT:169 [0x3a2fe0]: STAT:[STMc] msplayed 0
    [16:28:40.348429] AVTSetPlayMode:167 [0x423d28]: uPNP set play mode (cookie 0x13)
    [16:28:40.348843] AVTPlay:151 [0x423d28]: uPNP play (cookie 0x13)
    [16:28:40.349108] CtrlSetVolume:245 [0x423d28]: uPNP volume 49 (cookie 0x13)
    
    *** 50 seconds with no extra log info .... then ... music starts shortly after the entries below
    
    [16:29:30.199633] output_http_thread:140 [0x3a2fe0]: got HTTP connection 11
    [16:29:30.200155] output_http_thread:169 [0x3a2fe0]: drain is 2621440 (waited 50079)
    [16:29:30.214050] handle_http:467 [0x3a2fe0]: received GET /bridge-2.mp3 HTTP/1.1
    [16:29:30.214248] handle_http:470 [0x3a2fe0]: HTTP headers
    Host: 192.168.2.152:60461
    Icy-MetaData: 1
    Connection: close
    transferMode.dlna.org: Streaming
    User-Agent: WinampMPEG/2.8
    Accept: */*
    
    [16:29:30.217028] handle_http:552 [0x3a2fe0]: responding:
    HTTP/1.1 200 OK
    Server: squeezebox-bridge
    Connection: close
    icy-metaint: 16384
    Content-Type: audio/mpeg
    transferMode.dlna.org: Streaming
    Transfer-Encoding: chunked
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  10. #3040
    Junior Member
    Join Date
    Mar 2020
    Posts
    7

    Turning my Receiver on/off with LMS

    I have the following Config:
    Raspi 4B + Touchscreen running LMS 8.1.1 with Picoreplayer 7.0 and Jivelite. My Pioneer Receiver is connected via UpnP Bridge as a music renderer. When playing music it says "DMR". I only use wifi to play music from Spotty, Tunein and Synology NAS. So no Network cable to the Raspi.
    When I turn the picoreplayer on via the touchscreen power button and select some music to play, it automatically turns on the Pioneer receiver. So far so good.
    What does NOT work is the power off. I can use the Power button on the touchscreen again and the screen turns off but the pioneer receiver is still on......
    My Question: is there something I can do to also turn the Receiver off?
    If I understand it right than the Receiver is the DMR (Digital Media Renderer) and Logitech Media Server is the DMS (Digital Media Server) in this DLNA setup. Is the UpnP Bridge plugin the DMC (Digital Media Controller)?
    Somehow the power off command from the player does not imply the DMR power off......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •