Home of the Squeezebox™ & Transporter® network music players.
Page 288 of 291 FirstFirst ... 188238278286287288289290 ... LastLast
Results 2,871 to 2,880 of 2905
  1. #2871
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,144
    Quote Originally Posted by jasc View Post
    Philippe, thank you for the great work. Do you have a Paypal donation link?
    Thanks

    No I don't
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  2. #2872
    Junior Member
    Join Date
    Aug 2020
    Posts
    2

    Disable volume control

    Thanks for all the work!
    I just started to use the UPnPBridge and have have it working mostly, but have some trouble to fully disable the volume control.

    I have set (and also tried some variations without success)
    <max_volume>100</max_volume>
    <volume_on_play>-1</volume_on_play>
    <volume_feedback>1</volume_feedback>

    This disable the effect of volume up/down in Squeezer as desired, but if I press pause the volume is set to "3"
    [19:47:35.533414] process_strm:238 [0x6d1440] strm command p
    [19:47:35.533519] process_strm:268 [0x6d1440] pause (interval:0)
    [19:47:35.533567] CtrlSetVolume:245 [0x756bc0]: uPNP volume 3 (cookie 0x79)
    [19:47:35.533814] AVTBasic:201 [0x756bc0]: uPNP Pause (cookie 0x7a)
    [19:47:35.533983] sendSTAT:169 [0x6d1440]: STAT:[STMp] msplayed 13000
    [19:47:35.721958] _SyncNotifState:679 H190D38840: uPNP pause

    Is there a way to completely disable the uPNP volume commands?

  3. #2873
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,144

    Announce: UPnPBridge = integrate UPnP/DLNA players with LMS (squeeze2upnp)

    Quote Originally Posted by tombom View Post
    Thanks for all the work!
    I just started to use the UPnPBridge and have have it working mostly, but have some trouble to fully disable the volume control.

    I have set (and also tried some variations without success)
    100
    -1
    1

    This disable the effect of volume up/down in Squeezer as desired, but if I press pause the volume is set to "3"
    [19:47:35.533414] process_strm:238 [0x6d1440] strm command p
    [19:47:35.533519] process_strm:268 [0x6d1440] pause (interval:0)
    [19:47:35.533567] CtrlSetVolume:245 [0x756bc0]: uPNP volume 3 (cookie 0x79)
    [19:47:35.533814] AVTBasic:201 [0x756bc0]: uPNP Pause (cookie 0x7a)
    [19:47:35.533983] sendSTAT:169 [0x6d1440]: STAT:[STMp] msplayed 13000
    [19:47:35.721958] _SyncNotifState:679 H190D38840: uPNP pause

    Is there a way to completely disable the uPNP volume commands?
    I think you can set LMS to not send volume by saying it’s a fixed output. It’s somewhere in players’ settings, audio I think
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  4. #2874
    Junior Member
    Join Date
    Aug 2020
    Posts
    2
    Quote Originally Posted by philippe_44 View Post
    I think you can set LMS to not send volume by saying it’s a fixed output. It’s somewhere in players’ settings, audio I think
    Thanks! That worked.

  5. #2875
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,126

    Complicated connection problem with Bubbleupnp/upnpPlay apps

    Setup:

    2 routers (Asus, Belkin)
    2 android devices running identical upnp app

    Asus router - both devices (Blackviw A20, Fiio M6) appear as players in config (and work with LMS)

    Belkin router - one android device (A20) is listed and plays, second (Fiio) never appears in config

    The Belkin has limited interface settings, but the so-called Security Log shows (192.168.1.21 is the Fiio):


    Aug 23 04:40:37 sending OFFER of 192.168.1.21
    Aug 23 04:40:37 received REQUEST
    Aug 23 04:40:37 sending ACK to 192.168.1.21
    Aug 23 05:00:44 received DISCOVER
    Aug 23 05:00:44 sending OFFER of 192.168.1.10
    Aug 23 05:00:44 received REQUEST
    Aug 23 05:00:44 sending ACK to 192.168.1.10
    Aug 23 05:30:08 received DISCOVER
    Aug 23 05:30:08 sending OFFER of 192.168.1.10
    Aug 23 05:30:08 received REQUEST
    Aug 23 05:30:08 sending ACK to 192.168.1.10

    Seems the Belkin doesn't get the Fiio DISCOVER, but the Asus does (I presume)

    Baffled (again) why the Fiio works with Asus but not the Belkin ....

    Edit update:

    Rebooted everything and now bubbleupnp Fiio M6 appears as player, and works.
    Last edited by castalla; 2020-08-23 at 06:08.
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

  6. #2876
    Hello, just tried to migrate LMS 8 from Linux to Windows (I know... strange idea ! ).
    Everything seems OK (may be a little longer to reboot LMS on Windows ubuntu : less than 9s, windows : about 15s)
    Except I'm not able to make UPnPBridge work on Windows. I make my tests with a foobar player (but I have same results with other upnp players). It works perfectly on linux but not on windows...
    I see the player, the player try to stream but it never start.
    I don't have firewall problems or disk space problems. Can I copy an UPnPBridge log here or do you prefer a github issue ?

  7. #2877
    Junior Member
    Join Date
    Sep 2020
    Posts
    3

    Same "http parsing error" with Windows10 + Roon + Phantom Speakers...?

    Quote Originally Posted by ragwo View Post
    Hi.
    I have a reoccuring http parsing error using the UPnPBridge plugin with Roon. I'm running latest Roon build on Win10 pro, UPnPBridge 1.25.1. The UPnP speakers are Devialet Phantom. After anything from 30 seconds to 8 minutes the music stops due to the parsing error. I've changed the <stream_length> to -1,-2 and 0 without any effect. Streaming local files or Tidal/Qobuz doesn't matter. Roon is enabled in the config.xml, the sample rate is set to 192k. Her's what's happening:

    Host: 192.168.86.38:49153
    Connection: close
    icy-metadata: 1
    Range: bytes=53641092-
    transferMode.dlna.org: Streaming
    User-Agent: Rygel/0.32.1 DLNADOC/1.50 UPnP/1.0

    [13:40:10.612] handle_http:563 [00514360]: responding:
    HTTP/1.1 206 Partial Content
    Server: squeezebox-bridge
    Connection: close
    Content-Type: audio/flac
    transferMode.dlna.org: Streaming
    Content-Range: bytes 53641092-53641092/*


    [13:40:25.034] MasterHandler:977 [004C3AF8]: Auto-renewal failed, re-subscribing
    [13:40:25.050] MasterHandler:1001 [004C3AF8]: subscribe success
    [13:40:25.066] XMLGetFirstDocumentItem:176 (BUG) ixmlNode_getFirstChild(tmpNode) returned NULL
    [13:40:25.620] handle_http:463 [00514360]: http parsing error (null)
    [13:40:25.620] output_http_thread:193 [00514360]: HTTP close 1468 (bytes 53641092) (n:1 res:0)
    [13:40:26.005] _SyncNotifState:629 [004C5C90]: uPNP stop
    [13:40:26.005] sendSTAT:166 [00514360]: STAT:[STMo] msplayed 81000
    [13:40:26.005] process_strm:235 [00514360] strm command u
    [13:40:26.005] process_strm:284 [00514360] unpause at: 0 now: 1023749671

    I also have an auto renewal failure, but it doesn't affect the playback. Every 20 seconds this occurs:
    [13:13:10.025] MasterHandler:977 [004C5C90]: Auto-renewal failed, re-subscribing
    [13:13:10.025] MasterHandler:1001 [004C5C90]: subscribe success
    [13:13:10.041] XMLGetFirstDocumentItem:176 (BUG) ixmlNode_getFirstChild(tmpNode) returned NULL

    Are those bugs related?
    Is there a fix for the http parsing error?
    I'm really greatful for all replies and suggestions.
    Hi there,

    I just started playing with the UPnPxxx ...it seems I have the same problem, with 16/44 files it always becomes un-responsive at ~3:20s ...did you solve this problem? I'm running the v1.48...?

  8. #2878
    Junior Member
    Join Date
    Sep 2020
    Posts
    3

    Always disconnects exactly at ~3:17s but only with 16/44k tracks...??

    Hoping someone can help me understand what's is happening...I have a Roon setup with a Win10 machine(all hardwired with a local/dedicated switch), the only changes I did to the Config.xml was the sample rate to 192k and "1" for Roon...If I play higher rate tracks it all seems to be fine, but with 16/44k tracks (local rips or streaming Tidal) this issue always happens...not sure if its some kind of "keep-alive" or "buffer" issue, since from my testing, the problem only happens when one track is playing for the 3:17s. If I play smaller tracks, or for example, skip halfway of the track...I can play music for longer than the 3:17s....so it's a continuous play of one track that brings the problem. One variable that drives me crazy is why this seems to only happen with 16/44k tracks, not with high sample rate tracks...?? Maybe I still didn't play for long enough time to see it happen as well, but doesn't seem to happen....

    Any help would be much appreciated!

  9. #2879
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,144
    Quote Originally Posted by rookie2020 View Post
    Hoping someone can help me understand what's is happening...I have a Roon setup with a Win10 machine(all hardwired with a local/dedicated switch), the only changes I did to the Config.xml was the sample rate to 192k and "1" for Roon...If I play higher rate tracks it all seems to be fine, but with 16/44k tracks (local rips or streaming Tidal) this issue always happens...not sure if its some kind of "keep-alive" or "buffer" issue, since from my testing, the problem only happens when one track is playing for the 3:17s. If I play smaller tracks, or for example, skip halfway of the track...I can play music for longer than the 3:17s....so it's a continuous play of one track that brings the problem. One variable that drives me crazy is why this seems to only happen with 16/44k tracks, not with high sample rate tracks...?? Maybe I still didn't play for long enough time to see it happen as well, but doesn't seem to happen....

    Any help would be much appreciated!
    This is the first time you try Roon with the UPnPBridge, right? It has some specific expectations in term of knowing the file size, which IMHO are incorrect, but that's the way it is. I can't remember what I did to fix that, but I think that includes using transcoding to pcm. Look at the Roon forum, I've help a few folks here
    LMS 7.9 on Pi 3B+ & Odroid-C2 - SqueezeAMP!, 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, Riva 1 & 3

  10. #2880
    Junior Member
    Join Date
    Sep 2020
    Posts
    3
    Quote Originally Posted by philippe_44 View Post
    This is the first time you try Roon with the UPnPBridge, right? It has some specific expectations in term of knowing the file size, which IMHO are incorrect, but that's the way it is. I can't remember what I did to fix that, but I think that includes using transcoding to pcm. Look at the Roon forum, I've help a few folks here
    Indeed it's... :-) ...I will keep reading to see if I can find...thank you for the pointers... amazing work btw, thank you very, very, much for creating this Bridge!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •