Home of the Squeezebox™ & Transporter® network music players.
Page 258 of 314 FirstFirst ... 158208248256257258259260268308 ... LastLast
Results 2,571 to 2,580 of 3139
  1. #2571
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,726
    Quote Originally Posted by hontored View Post
    Hi,

    there has been a lot of updates since v 0.2.9.5.

    What is the state of the plugin regarding communicating with HQplayer ?

    I have an audiolinux installation and I would like to make LMS stream to HQplayer.

    Best,
    Sébastien
    I’ve not done anything particular AFAIR for HQplayer. I think they had a non standard way to présente mimetypes capabilities. I’ve added some general options to manually handle player’s capabilities, maybe it can help, I don’t know
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  2. #2572
    Junior Member
    Join Date
    Sep 2019
    Posts
    6

    LMS to HQPlayer4 embedded through UPnPBridge 1.20.2 IT WORKS!!!

    Hi Philippe.

    By chance I managed to make it work.

    Here is my configuration :
    AudioLinux
    LMS 7.9.2 - ARCH-AUR-GIT.20190923.91bab34
    HQplayer Embebbeded 4.11.1

    So here is how it happened :

    1) tried to install the latest UPnPBridge plugin 1.20.2 from LMS web interface
    2) service ran HQplayer recognized by plugin
    3) set the plugin
    4) try to play a song. No luck no sound
    5) try to install plugin 0.2.9.5 : copy everything in .../opt/logitechmediaserver-git/cache/InstalledPlugins/Plugins/UPnPBridge/ to tmp directory
    unzip plugin 0.2.9.5 to .../opt/logitechmediaserver-git/cache/InstalledPlugins/Plugins/UPnPBridge/
    set plugin according to https://www.nexthardware.com/forum/p...d-con-lms.html
    and save
    6) Not possible to play a song: UPnPBridge won't start
    7) remove plugin 0.2.9.5 from .../opt/logitechmediaserver-git/cache/InstalledPlugins/Plugins/UPnPBridge/ and put back 1.20.2 from tmp directory
    8) try to play a song. IT WORKS!

    So what I realized is that when swapping versions of plugin the settings file is not touched in the process. It is touched by LMS once it starts.

    So the setting file upnpbridge.xml in .../opt/logitechmediaserver-git/prefs/ is from v 0.2.9.5 when I restart LMS with plugin 1.20.2

    I suspect the http menu to be responsible for the problem. It is empty in v 1.20.2 whereas you have to choose "fixed large size" in v 0.2.9.5
    I compared the menu from restarted v 1.20.2 just after 0.2.9.5 without tinkering and v 1.20.2 after saving prefs.
    It seems this item should be set to:
    <stream_length>1000000000</stream_length>^M
    In prefs file save from 1.20.2 it is set to:
    <stream_length>-3</stream_length>^M

    What do you think Philippe ?
    Sébastien

    ----------------------------------------------------------------------------

    For info here is my v 0.2.9.5 file
    <squeeze2upnp>
    <upnp_scan_timeout>15</upnp_scan_timeout>
    <upnp_scan_interval>30</upnp_scan_interval>
    <common>
    <volume_feedback>1</volume_feedback>
    <server>?</server>
    <codecs>aac,ogg,ops,flc,alc,aif,pcm,mp3</codecs>
    <remove_timeout>120</remove_timeout>
    <byte_seek>1</byte_seek>
    <raw_audio_format>raw,wav,aif</raw_audio_format>
    <send_icy>1</send_icy>
    <seek_after_pause>1</seek_after_pause>
    <match_endianness>1</match_endianness>
    <buffer_limit>-1</buffer_limit>
    <streambuf_size>524288</streambuf_size>
    <stream_pacing_size>1048576</stream_pacing_size>
    <stream_length>1000000000</stream_length>
    <mode>thru</mode>
    <enabled>1</enabled>
    <output_size>4194304</output_size>
    <max_volume>100</max_volume>
    <auto_play>0</auto_play>
    <send_metadata>1</send_metadata>
    <resample_options></resample_options>
    <send_coverart>0</send_coverart>
    <forced_mimetypes>HASH(0x564409787118)</forced_mimetypes>
    <upnp_remove_count>1</upnp_remove_count>
    <volume_on_play>0</volume_on_play>
    <flac_header>1</flac_header>
    <accept_nexturi>1</accept_nexturi>
    <L24_format>0</L24_format>
    <roon_mode>0</roon_mode>
    <sample_rate>192000</sample_rate>
    </common>
    <log_limit>-1</log_limit>
    <upnp_log>info</upnp_log>
    <upnp_socket>?</upnp_socket>
    <slimproto_log>info</slimproto_log>
    <device>
    <enabled>1</enabled>
    <mac>bb:bb:63:6b:e5:64</mac>
    <udn>uuid:b391f3f4-e2c1-4fb5-961b-5aa011b86d57</udn>
    <friendly_name>HQPlayer:SignalystHQPlayer4</friendly_name>
    <name>HQPlayer:SignalystHQPlayer4</name>
    </device>
    <output_log>info</output_log>
    <slimmain_log>warn</slimmain_log>
    <util_log>warn</util_log>
    <decode_log>warn</decode_log>
    <stream_log>warn</stream_log>
    <main_log>info</main_log>
    </squeeze2upnp>

    Here is my v1.20.2 file after swapping versions without saving
    <?xml version="1.0"?>^M
    <squeeze2upnp>^M
    <upnp_scan_timeout>15</upnp_scan_timeout>^M
    <upnp_scan_interval>30</upnp_scan_interval>^M
    <common>^M
    <volume_feedback>1</volume_feedback>^M
    <server>?</server>^M
    <codecs>aac,ogg,ops,flc,alc,aif,pcm,mp3</codecs>^M
    <remove_timeout>120</remove_timeout>^M
    <byte_seek>1</byte_seek>^M
    <raw_audio_format>raw,wav,aif</raw_audio_format>^M
    <send_icy>1</send_icy>^M
    <seek_after_pause>1</seek_after_pause>^M
    <match_endianness>1</match_endianness>^M
    <buffer_limit>-1</buffer_limit>^M
    <streambuf_size>524288</streambuf_size>^M
    <stream_pacing_size>1048576</stream_pacing_size>^M
    <stream_length>1000000000</stream_length>^M
    <mode>thru</mode>^M
    <enabled>1</enabled>^M
    <output_size>4194304</output_size>^M
    <max_volume>100</max_volume>^M
    <auto_play>0</auto_play>^M
    <send_metadata>1</send_metadata>^M
    <resample_options></resample_options>^M
    <send_coverart>0</send_coverart>^M
    <forced_mimetypes>HASH(0x564409787118)</forced_mimetypes>^M
    <upnp_remove_count>1</upnp_remove_count>^M
    <volume_on_play>0</volume_on_play>^M
    <flac_header>1</flac_header>^M
    <accept_nexturi>0</accept_nexturi>^M
    <L24_format>0</L24_format>^M
    <roon_mode>0</roon_mode>^M
    <sample_rate>192000</sample_rate>^M
    </common>^M
    <log_limit>-1</log_limit>^M
    <upnp_log>info</upnp_log>^M
    <upnp_socket>?</upnp_socket>^M
    <slimproto_log>info</slimproto_log>^M
    <output_log>info</output_log>^M
    <slimmain_log>warn</slimmain_log>^M
    <util_log>warn</util_log>^M
    <decode_log>warn</decode_log>^M
    <stream_log>warn</stream_log>^M
    <main_log>info</main_log>^M
    <device>^M
    <enabled>1</enabled>^M
    <mac>bb:bb:63:6b:e5:64</mac>^M
    <udn>uuid:b391f3f4-e2c1-4fb5-961b-5aa011b86d57</udn>^M
    <friendly_name>HQPlayer:SignalystHQPlayer4</friendly_name>^M
    <name>HQPlayer:SignalystHQPlayer4</name>^M
    </device>^M
    </squeeze2upnp>^M

    Here is a v1.20.2 after saving:
    <?xml version="1.0"?>^M
    <squeeze2upnp>^M
    <upnp_scan_timeout>15</upnp_scan_timeout>^M
    <output_log>info</output_log>^M
    <upnp_scan_interval>30</upnp_scan_interval>^M
    <decode_log>warn</decode_log>^M
    <util_log>warn</util_log>^M
    <main_log>info</main_log>^M
    <common>^M
    <seek_after_pause>0</seek_after_pause>^M
    <match_endianness>1</match_endianness>^M
    <forced_mimetypes>HASH(0x564409787118)</forced_mimetypes>^M
    <send_icy>1</send_icy>^M
    <resample_options></resample_options>^M
    <volume_on_play>0</volume_on_play>^M
    <L24_format>0</L24_format>^M
    <buffer_limit>-1</buffer_limit>^M
    <volume_feedback>1</volume_feedback>^M
    <flac_header>1</flac_header>^M
    <output_size>4194304</output_size>^M
    <accept_nexturi>1</accept_nexturi>^M
    <send_metadata>1</send_metadata>^M
    <roon_mode>0</roon_mode>^M
    <send_coverart>0</send_coverart>^M
    <streambuf_size>524288</streambuf_size>^M
    <stream_pacing_size>1048576</stream_pacing_size>^M
    <max_volume>100</max_volume>^M
    <upnp_remove_count>1</upnp_remove_count>^M
    <byte_seek>1</byte_seek>^M
    <mode>thru</mode>^M
    <raw_audio_format>raw,wav,aif</raw_audio_format>^M
    <remove_timeout>120</remove_timeout>^M
    <sample_rate>192000</sample_rate>^M
    <enabled>1</enabled>^M
    <server>?</server>^M
    <auto_play>0</auto_play>^M
    <codecs>aac,ogg,ops,flc,alc,aif,pcm,mp3</codecs>^M
    <stream_length>-3</stream_length>^M
    </common>^M
    <log_limit>-1</log_limit>^M
    <slimmain_log>warn</slimmain_log>^M
    <slimproto_log>info</slimproto_log>^M
    <upnp_socket>?</upnp_socket>^M
    <upnp_log>info</upnp_log>^M
    <stream_log>warn</stream_log>^M
    <device>^M
    <mac>bb:bb:63:6b:e5:64</mac>^M
    <friendly_name>HQPlayer:SignalystHQPlayer4</friendly_name>^M
    <name>HQPlayer:SignalystHQPlayer4</name>^M
    <enabled>1</enabled>^M
    <udn>uuid:b391f3f4-e2c1-4fb5-961b-5aa011b86d57</udn>^M
    </device>^M
    </squeeze2upnp>^M

  3. #2573
    Junior Member
    Join Date
    Sep 2019
    Posts
    6
    I think I found where the problem comes from.

    when comparing 0.2.9.5 preference file with 1.20.2 I found this:
    the http menu is blank leading to
    <stream_length>-3</stream_length>^M

    So you simply need to replace by:
    <stream_length>1000000000</stream_length>^M

    which corresponds to the option:
    fixed large size in the "http" menu.

    I came to this conclusion after switching manually installations (file moving) between 0.2.9.5 and 1.20.2 and realising setting 0.2.9.5 and switching to 1.20.2 gives sound...

    What do you think Philippe ?
    Sébastien
    Last edited by hontored; 2019-09-23 at 12:39.

  4. #2574
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,726
    Quote Originally Posted by hontored View Post
    I think I found where the problem comes from.

    when comparing 0.2.9.5 preference file with 1.20.2 I found this:
    the http menu is blank leading to
    <stream_length>-3</stream_length>^M

    So you simply need to replace by:
    <stream_length>1000000000</stream_length>^M

    which corresponds to the option:
    fixed large size in the "http" menu.

    I came to this conclusion after switching manually installations (file moving) between 0.2.9.5 and 1.20.2 and realising setting 0.2.9.5 and switching to 1.20.2 gives sound...

    What do you think Philippe ?
    Sébastien

    1000000000 is the worse option for length, but better tha nothing. Did you try -1?
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  5. #2575
    Junior Member
    Join Date
    Sep 2019
    Posts
    6
    No I didn't try -1.

    The thing is the http menu rolls down but there is no text for me with version 1.20.2 of the plugin.
    It seems the default is -3 because that's how it is every time I save my settings with 1.20.2

    I will try to replace 1000000000 with -1.

    Not now because it is already 23:49 in my zone.

  6. #2576
    Junior Member
    Join Date
    Sep 2019
    Posts
    6
    Hi Philippe.

    I tried to put -1 in:
    <stream_length>-1</stream_length>^M

    It doesn't work properly. It will play a song but not a list of songs.

    If I launch an album I can listen to the first song without any problem. Play, pause, play jump to somewhere in the song is ok.
    When the song is finished and the next one should start I have no sound:
    I need to manually pause and play or if I jump to the middle of the song it is ok.

    I tried to activate/deactivate gapless but it doesn't change anything.

    Can you elaborate on what are the available values for "stream_length" and what they mean ?

    Sébastien

  7. #2577
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,726
    Quote Originally Posted by hontored View Post
    Hi Philippe.

    I tried to put -1 in:
    <stream_length>-1</stream_length>^M

    It doesn't work properly. It will play a song but not a list of songs.

    If I launch an album I can listen to the first song without any problem. Play, pause, play jump to somewhere in the song is ok.
    When the song is finished and the next one should start I have no sound:
    I need to manually pause and play or if I jump to the middle of the song it is ok.

    I tried to activate/deactivate gapless but it doesn't change anything.

    Can you elaborate on what are the available values for "stream_length" and what they mean ?

    Sébastien
    You have a detailed explanation in the user guide
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  8. #2578
    Junior Member
    Join Date
    Sep 2019
    Posts
    6
    Ok read the doc in the repository.

    So 1000000000 is needed for some reason to detect changing from one song to the next.

    You advised not using the fixed length. Is it in case you want to play a file bigger than 10^9 bits?

    I can't see what could be a problem appart from this.

    I should add that I am having lms send flac to hqplayer through UPnPBridge in passthrough for other users interested: HQplayer embbeded 4.11.1 now handles flac.

    Anyway, I am satisfied with the way it works now.

    I should add thank you Philippe for developping the plugin
    Last edited by hontored; 2019-09-24 at 09:41.

  9. #2579
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    6,726
    Quote Originally Posted by hontored View Post
    So 1000000000 is needed for some reason to detect changing from one song to the next.

    You advised not using the fixed length. Is it in case you want to play a file bigger than 10^9 bits?

    I can't see what could be a problem appart from this.
    Limitation is duration of a track which is about 15 mins for 192/24. Other problem is that some players don’t like, when being told that expected file is X, that connection is closed after Y

    Hence using fixed length is a last resort ugly workaround
    LMS 8.1.x on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  10. #2580
    Junior Member
    Join Date
    Jun 2019
    Posts
    21

    RPi4 4GB, sound quality, no dedicated audio card

    Hello,

    I am using UPnPBridge (thank you!) with the following Pi setup, and have a question about sound quality:

    • RPi 4 4GB running Max2Play
    • No dedicated audio card, just the RPi4 in a case
    • Squeezelite is paired with the Pi's onboard audio BCM2835, i.e.
    • sysdefault - bcm2835 ALSA, bcm2835 ALSA, Default Audio Device, CARD=ALSA
    • ALSA Parameters: 80:::
    • Command Line Options: -C 5


    UPnPBridge is in turn paired with Squeezelite, and the network player is a Linn Majik DSM (which is itself a very good DAC)

    My old setup had an RPi3 and an IQaudIO Pi-DAC+, Squeezelite was paired with it, and UPnPBridge with the Linn Majik DSM.

    My questions:

    1. Am I losing sound quality by not having the IQaudIO Pi-DAC+ in the chain? I have only FLAC and MP3, LMS is set up to not transcode either format. This is why I assumed that the Pi is mereley "transporting" the unprocessed audio signals to the Linn DSM, and that a dedicated audio card makes no difference in audio quality when using UPnPBridge and an external DAC. But I am unsure.

    2. Is there anything in the Squeezelite settings (Selected Device, ALSA parameters, Command Line Options) that could be changed to ensure the best possible sound quality (i.e. untouched) output to the Linn DSM?


    Many thanks,
    JCU
    Last edited by jasc; 2019-10-04 at 00:45.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •