Home of the Squeezebox™ & Transporter® network music players.
Page 209 of 264 FirstFirst ... 109159199207208209210211219259 ... LastLast
Results 2,081 to 2,090 of 2636
  1. #2081
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,985
    Quote Originally Posted by philippe_44 View Post
    You can also add "ogg" as it's natively supported by the bridge.

    There was one error in flac that impacted flow badly and I did not see it because I'm manually editing my config file ... One thing for flow is that the setting of "no higher" is irrelevant as flow must use the same coding for all the tracks, so the idea of "downsample *only* above" does not work here. The sample size and rate must be set to fixed values as soon as flow is active. By default, it's 44.1/16. If you set 48000 but still tick "no higher", 48000 will be the fixed value.
    I think that once you decide you need to transcode (for flow, replay gain or whatever), the upnp player abilities are almost entirely irrelevant, and you should just set a sensible codec and fixed rate for your player.

    flac and flow now works - thanks. I've now picked flac 96000, 0 compression, 24 bit for my Marantz and that seems fine.

    I have never, ever, used replay gain and so on, so haven't tested that.

    What limitation do you have in mind?
    "if the player only accept wav or aiff, the duration of the whole “session” will be limited to 4GB" - RTFM

    Please don't apologize, as said before I really appreciate you take the time for these tests and I know this is very frustrating because I left a lot of errors and you don't know if this is a problem with the version or if this is a wrong setting. I have the chance to be able to discriminate these from source code and with a debugger, which makes that much less "infuriating" (although there are some other painful moments).

    And in addition, these concepts are complicated and I have not found a good way so far to communicate them.

    To some extend, the pcm mode, with raw, wav and all that is adding an extraordinary level of permutations & combinations that do not exist with flac & mp3. My opinion is that the best configuration is either the thru (through ) mode with it's uncertainties or a flac/mp3. Using pcm is probably looking for troubes and headaches (and it's very visible in the flow diagrams I've added)
    I'll have to print off the flow charts and pour myself a glass of something strong before trying to comprehend the full scope of all this.
    LMS 7.9.2 on PC, Xubuntu 18.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touchs & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 18.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  2. #2082
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,985
    Quote Originally Posted by philippe_44 View Post
    I've added the following flow diagrams - not sure it helps

    1/ general comment son player registration & track playback from LMS point of view

    Attachment 25532


    2/ how the bridge selects a format to send to the UPnP player

    Attachment 25531


    3/ how the audio stream is processed

    Attachment 25534
    By the way, I tried downloading the images but they have a strange chequered background. I don't know why.
    LMS 7.9.2 on PC, Xubuntu 18.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touchs & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 18.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  3. #2083

    Transcoding set to 'None' but happening.

    flac to Jongo still not working but that is not the reason for this post.

    The config file reproduced below has mode set to thru yet the LMS player GUI is showing that transcoding is being applied. Eg
    Code:
    File Format: FLAC
    Duration: 5:11
    Bitrate: 535kbps VBR (Converted to 705kbps FLAC)
    Sample Rate: 44.1 kHz
    Sample Size: 16Bits
    File Length: 20,890,440
    This was not happening previously. From v1.2 I think.

    Code:
    <squeeze2upnp>
    <common>
    <auto_play>0</auto_play>
    <output_size>4194304</output_size>
    <volume_on_play>1</volume_on_play>
    <min_gapless>10</min_gapless>
    <streambuf_size>524288</streambuf_size>
    <mode>thru</mode>
    <send_icy>1</send_icy>
    <stream_length>-3</stream_length>
    <forced_mimetypes/>
    <codecs>flc,aif,pcm,mp3</codecs>
    <sample_rate>48000</sample_rate>
    <enabled>1</enabled>
    <roon_mode>0</roon_mode>
    <L24_format>1</L24_format>
    <send_metadata>1</send_metadata>
    <raw_audio_format>raw,wav,aif</raw_audio_format>
    <server>?</server>
    <accept_nexturi>1</accept_nexturi>
    <seek_after_pause>0</seek_after_pause>
    <flac_header>1</flac_header>
    <max_volume>100</max_volume>
    <send_coverart>1</send_coverart>
    <resample_options/>
    <volume_feedback>1</volume_feedback>
    </common>
    <util_log>warn</util_log>
    <main_log>info</main_log>
    <slimproto_log>info</slimproto_log>
    <decode_log>warn</decode_log>
    <log_limit>-1</log_limit>
    <stream_log>warn</stream_log>
    <output_log>info</output_log>
    <upnp_log>info</upnp_log>
    <upnp_socket>192.168.1.11</upnp_socket>
    <slimmain_log>warn</slimmain_log>
    <device>
    <udn>uuid:93b2abac-cb6a-4857-b891-0019f584535c</udn>
    <mode>thru</mode>
    <forced_mimetypes>audio/flac</forced_mimetypes>
    <send_icy>0</send_icy>
    <flac_header>1</flac_header>
    <codecs>flc</codecs>
    <max_volume>100</max_volume>
    <sample_rate>48000</sample_rate>
    <send_coverart>0</send_coverart>
    <enabled>1</enabled>
    <friendly_name>Jongo Lounge</friendly_name>
    <send_metadata>1</send_metadata>
    <mac>bb:bb:f5:84:53:5c</mac>
    <name>Jongo Lounge</name>
    </device>
    </squeeze2upnp>

  4. #2084
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    5,109
    Quote Originally Posted by drgeoff View Post
    flac to Jongo still not working but that is not the reason for this post.

    The config file reproduced below has mode set to thru yet the LMS player GUI is showing that transcoding is being applied. Eg
    Code:
    File Format: FLAC
    Duration: 5:11
    Bitrate: 535kbps VBR (Converted to 705kbps FLAC)
    Sample Rate: 44.1 kHz
    Sample Size: 16Bits
    File Length: 20,890,440
    This was not happening previously. From v1.2 I think.

    Code:
    <squeeze2upnp>
    <common>
    <auto_play>0</auto_play>
    <output_size>4194304</output_size>
    <volume_on_play>1</volume_on_play>
    <min_gapless>10</min_gapless>
    <streambuf_size>524288</streambuf_size>
    <mode>thru</mode>
    <send_icy>1</send_icy>
    <stream_length>-3</stream_length>
    <forced_mimetypes/>
    <codecs>flc,aif,pcm,mp3</codecs>
    <sample_rate>48000</sample_rate>
    <enabled>1</enabled>
    <roon_mode>0</roon_mode>
    <L24_format>1</L24_format>
    <send_metadata>1</send_metadata>
    <raw_audio_format>raw,wav,aif</raw_audio_format>
    <server>?</server>
    <accept_nexturi>1</accept_nexturi>
    <seek_after_pause>0</seek_after_pause>
    <flac_header>1</flac_header>
    <max_volume>100</max_volume>
    <send_coverart>1</send_coverart>
    <resample_options/>
    <volume_feedback>1</volume_feedback>
    </common>
    <util_log>warn</util_log>
    <main_log>info</main_log>
    <slimproto_log>info</slimproto_log>
    <decode_log>warn</decode_log>
    <log_limit>-1</log_limit>
    <stream_log>warn</stream_log>
    <output_log>info</output_log>
    <upnp_log>info</upnp_log>
    <upnp_socket>192.168.1.11</upnp_socket>
    <slimmain_log>warn</slimmain_log>
    <device>
    <udn>uuid:93b2abac-cb6a-4857-b891-0019f584535c</udn>
    <mode>thru</mode>
    <forced_mimetypes>audio/flac</forced_mimetypes>
    <send_icy>0</send_icy>
    <flac_header>1</flac_header>
    <codecs>flc</codecs>
    <max_volume>100</max_volume>
    <sample_rate>48000</sample_rate>
    <send_coverart>0</send_coverart>
    <enabled>1</enabled>
    <friendly_name>Jongo Lounge</friendly_name>
    <send_metadata>1</send_metadata>
    <mac>bb:bb:f5:84:53:5c</mac>
    <name>Jongo Lounge</name>
    </device>
    </squeeze2upnp>
    If you see that in the GUI, then it is not transcoding in the bridge. LMS does not know what’s happening inside. So this is transcoding done by LMS itself.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  5. #2085
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Quote Originally Posted by drgeoff View Post
    flac to Jongo still not working but that is not the reason for this post.

    The config file reproduced below has mode set to thru yet the LMS player GUI is showing that transcoding is being applied. Eg
    Code:
    File Format: FLAC
    Duration: 5:11
    Bitrate: 535kbps VBR (Converted to 705kbps FLAC)
    Sample Rate: 44.1 kHz
    Sample Size: 16Bits
    File Length: 20,890,440
    This was not happening previously. From v1.2 I think.
    EDIT: Ignore my ramblings below - my assumptions were completely wrong, everything works as expected and my results were due to Sonos now being able to play 24/48 flac files natively!

    I've noticed a similar (maybe?) thing happening too. I upgraded to 1.2.0 a few days back, having been on v0.3.x for quite a long time. Prior to updating, I had to use a custom-convert.conf file to downsample 24/96+ flac files down to 16/48 for my Sonos system. However, I updated to 1.2 on Saturday after buying an additonal Sonos component and deleted my custom-convert.conf file (purely out of interest) and noticed my 24/96 and 24/192 flacs are still being downsampled somewhere along the line with the bridge set to "thru". Bear in mind I've done no in-depth analysis, but I assume that LMS is still doing the downsampling without me needing the custom-convert.conf file any more. I'm still running the same version of LMS (19th April build) that I was on with the earlier version of the bridge.

    At some point I might activate all the logging to see what's going on behind the scenes, but for the moment I'm just happy that everything's working without me having to tinker with anything. I recall struggling to understand why I needed the custom-convert.conf file in the first place a few years back so I'm not exactly clued up on how all this stuff works now without it!

    An an exercise, I might downgrade back to v0.3 to see if my hi-res files will still play without the custom-convert.conf file. If I can figure out how to get the older version!
    Last edited by FatPete; 2018-08-28 at 16:03. Reason: Disclaimer that I was wrong!

  6. #2086
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    5,109
    Quote Originally Posted by FatPete View Post
    I've noticed a similar (maybe?) thing happening too. I upgraded to 1.2.0 a few days back, having been on v0.3.x for quite a long time. Prior to updating, I had to use a custom-convert.conf file to downsample 24/96+ flac files down to 16/48 for my Sonos system. However, I updated to 1.2 on Saturday after buying an additonal Sonos component and deleted my custom-convert.conf file (purely out of interest) and noticed my 24/96 and 24/192 flacs are still being downsampled somewhere along the line with the bridge set to "thru". Bear in mind I've done no in-depth analysis, but I assume that LMS is still doing the downsampling without me needing the custom-convert.conf file any more. I'm still running the same version of LMS (19th April build) that I was on with the earlier version of the bridge.

    At some point I might activate all the logging to see what's going on behind the scenes, but for the moment I'm just happy that everything's working without me having to tinker with anything. I recall struggling to understand why I needed the custom-convert.conf file in the first place a few years back so I'm not exactly clued up on how all this stuff works now without it!

    An an exercise, I might downgrade back to v0.3 to see if my hi-res files will still play without the custom-convert.conf file. If I can figure out how to get the older version!
    Oh, I think I know what happened:. I did go back and forth between naming the flac mode ‘flac’ or ‘flc’ to have consistency across my different plugins. I finally decided for flc but I left one place in the code where it was looking for flac. As a result, it could end up in a sort of ‘no state’ which is not good. All you have to do is, in the web UI, change the transcode parameter to anything else than current value then change it back to what you want. In the next release, I’ll make sure that there is a default consistent value, no matter what is set in the config file.
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  7. #2087
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    2,985
    Quote Originally Posted by philippe_44 View Post
    I've added the following flow diagrams - not sure it helps

    1/ general comment son player registration & track playback from LMS point of view

    Attachment 25532


    2/ how the bridge selects a format to send to the UPnP player

    Attachment 25531


    3/ how the audio stream is processed

    Attachment 25534
    I had a quick look. I think I understand the why and what of a fair bit of it.

    I do have one question. On the very first chart, Registration, if not 'thru', why do you still follow the config file codecs and bits? If you are going to transcode, surely all that matters is what the UPnP bridge itself, and transcoder (do you use sox?) are capable of processing as input. It doesn't matter at all what the player can do, nor what's in the config file. This way LMS will only transcode if the source is something the bridge itself cannot handle, much reducing the chance of both LMS and the bridge transcoding (potentially increasing cpu loads quite severely, and according to some reducing the sound quality by over processing).

    It then seems to me that what matters then (again only for the case when not 'thru') is whether the player can handle the specified transcoded results for flc, mp3, pcm/raw or pcm/wav, sample rate and bits. This surely depends on what the player has told you it can do, plus any Additional Mime Types. From the charts I'm not sure whether you do this for flc and mp3. I guess that in several cases players can do more than they announce, but whether one would want to override that is questionable. An additional complexity is added by the 'source' options for transcoded bits and sample rate. Given that the user has decided to ask the bridge to transcode where necessary, I would treat 'source' a request to be honoured where possible, but would downsample and/or reduce the bit rate if the player said it can't do it (which is what LMS does for you anyway as things stand).

    Does that make any sense?
    LMS 7.9.2 on PC, Xubuntu 18.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touchs & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 18.04 laptop firefox/upplay or Android 'phone with Squeeze-Commander/BubbleUPnP controls LMS/Minimserver.

  8. #2088
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Quote Originally Posted by philippe_44 View Post
    Oh, I think I know what happened:. I did go back and forth between naming the flac mode ‘flac’ or ‘flc’ to have consistency across my different plugins. I finally decided for flc but I left one place in the code where it was looking for flac. As a result, it could end up in a sort of ‘no state’ which is not good. All you have to do is, in the web UI, change the transcode parameter to anything else than current value then change it back to what you want. In the next release, I’ll make sure that there is a default consistent value, no matter what is set in the config file.
    EDIT: Ignore my ramblings below - my assumptions were completely wrong, everything works as expected and my results were due to Sonos now being able to play 24/48 flac files natively!

    Thanks Philippe. I've just tried this now (ensuring plugin wasn't running and Applying changes at each step) but somehow LMS is still correctly downsampling 24/192 flac so that my Sonos can play it. I haven't restored my custom-convert.conf file yet.

    Here's what I see when playing a 24/192 file:

    Code:
    [10:06:25.864161] sq_callback:297 [0x74b440]:
            artist:DeVotchKa
            album:This Night Falls Forever
            title:Straight Shot
            genre:Alternative
            duration:322.800
            size:0
            cover:http://192.168.1.10:9000/music/7f044116/cover.jpg
            offset:0
    [10:06:25.864344] sq_callback:324 [0x74b440]: current URI set http://192.168.1.10:49153/bridge-1.flac
    [10:06:25.864480] AVTSetURI:91 [0x74b440]: uPNP setURI http://192.168.1.10:49153/bridge-1.flac (cookie 0x1)
    [10:06:25.864849] process_start:1140 [0x6c8080]: codec:c, ch:0, s:0, r:0
    [10:06:25.865052] sendSTAT:160 [0x6c8080]: STAT:[STMc] msplayed 0
    [10:06:26.032405] AVTSetPlayMode:167 [0x74b440]: uPNP set play mode (cookie 0x2)
    [10:06:26.032718] AVTPlay:151 [0x74b440]: uPNP play (cookie 0x3)
    [10:06:26.032951] CtrlSetMute:282 [0x74b440]: uPNP mute 0 (cookie 0x3)
    [10:06:26.033526] CtrlSetVolume:253 [0x74b440]: uPNP volume 11 (cookie 0x4)
    [10:06:26.043990] output_http_thread:135 [0x6c8080]: got HTTP connection 19
    [10:06:26.047709] output_http_thread:181 [0x6c8080]: drain is 131072 (waited 183)
    [10:06:26.049027] handle_http:478 [0x6c8080]: received GET /bridge-1.flac HTTP/1.1
    [10:06:26.049367] handle_http:481 [0x6c8080]: HTTP headers
    CONNECTION: close
    Host: 192.168.1.10:49153
    ACCEPT: */*
    USER-AGENT: Linux UPnP/1.0 Sonos/44.2-54281 (ZPS11)
    
    [10:06:26.059277] handle_http:565 [0x6c8080]: responding:
    HTTP/1.1 200 OK
    Server: squeezebox-bridge
    Connection: close
    Content-Type: audio/flac
    Transfer-Encoding: chunked
    For a normal 16/44 file:

    Code:
    [10:12:58.826432] sq_callback:297 [0x74b440]:
            artist:Interpol
            album:Marauder
            title:If You Really Love Nothing
            genre:Alternative
            duration:265.640
            size:0
            cover:http://192.168.1.10:9000/music/d60b741f/cover.jpg
            offset:0
    [10:12:58.826832] sq_callback:324 [0x74b440]: current URI set http://192.168.1.10:49153/bridge-2.wav
    [10:12:58.827074] AVTSetURI:91 [0x74b440]: uPNP setURI http://192.168.1.10:49153/bridge-2.wav (cookie 0x9a)
    [10:12:58.827517] process_start:1140 [0x6c8080]: codec:p, ch:2, s:16, r:44100
    [10:12:58.827809] sendSTAT:160 [0x6c8080]: STAT:[STMc] msplayed 0
    [10:12:58.930009] AVTSetPlayMode:167 [0x74b440]: uPNP set play mode (cookie 0x9b)
    [10:12:58.930250] AVTPlay:151 [0x74b440]: uPNP play (cookie 0x9c)
    [10:12:58.930342] CtrlSetVolume:253 [0x74b440]: uPNP volume 9 (cookie 0x9c)
    [10:12:58.937763] output_http_thread:135 [0x6c8080]: got HTTP connection 17
    [10:12:58.988013] _output_new_stream:419 [0x6c8080]: encoding in PCM r:44100 s:16 f:w
    [10:12:58.988132] _output_new_stream:420 [0x6c8080]: HTTP -3, estimated len 46858940
    [10:12:58.988164] output_http_thread:181 [0x6c8080]: drain is 529200 (waited 161)
    [10:12:58.988786] handle_http:478 [0x6c8080]: received GET /bridge-2.wav HTTP/1.1
    [10:12:58.988919] handle_http:481 [0x6c8080]: HTTP headers
    CONNECTION: close
    Host: 192.168.1.10:49153
    ACCEPT: */*
    USER-AGENT: Linux UPnP/1.0 Sonos/44.2-54281 (ZPS11)
    
    [10:12:58.989370] handle_http:565 [0x6c8080]: responding:
    HTTP/1.1 200 OK
    Server: squeezebox-bridge
    Connection: close
    Content-Type: audio/wav
    Transfer-Encoding: chunked
    Here's my bridge config:

    Code:
    <squeeze2upnp>
    <decode_log>warn</decode_log>
    <log_limit>-1</log_limit>
    <upnp_socket>?</upnp_socket>
    <slimproto_log>info</slimproto_log>
    <upnp_log>info</upnp_log>
    <output_log>info</output_log>
    <main_log>info</main_log>
    <util_log>warn</util_log>
    <common>
    <send_metadata>1</send_metadata>
    <sample_rate>48000</sample_rate>
    <send_coverart>1</send_coverart>
    <streambuf_size>524288</streambuf_size>
    <stream_length>-3</stream_length>
    <raw_audio_format>raw,wav,aif</raw_audio_format>
    <volume_feedback>1</volume_feedback>
    <enabled>1</enabled>
    <roon_mode>0</roon_mode>
    <accept_nexturi>1</accept_nexturi>
    <codecs>flc,aif,pcm,mp3</codecs>
    <forced_mimetypes>HASH(0x7a53d58)</forced_mimetypes>
    <output_size>4194304</output_size>
    <flac_header>1</flac_header>
    <max_volume>100</max_volume>
    <auto_play>0</auto_play>
    <server>?</server>
    <mode>thru</mode>
    <L24_format>1</L24_format>
    <resample_options/>
    <min_gapless>10</min_gapless>
    <send_icy>1</send_icy>
    <volume_on_play>1</volume_on_play>
    <seek_after_pause>0</seek_after_pause>
    </common>
    <slimmain_log>warn</slimmain_log>
    <stream_log>warn</stream_log>
    <device>
    <accept_nexturi>1</accept_nexturi>
    <codecs>aif,pcm,flc,mp3</codecs>
    <enabled>1</enabled>
    <stream_length>-3</stream_length>
    <raw_audio_format>wav,aiff</raw_audio_format>
    <sample_rate>48000</sample_rate>
    <name>TV</name>
    <send_metadata>1</send_metadata>
    <seek_after_pause>0</seek_after_pause>
    <udn>uuid:RINCON_5CAAFD32C25001400</udn>
    <mode>thru</mode>
    <L24_format>2</L24_format>
    <mac>bb:bb:36:34:70:74</mac>
    <flac_header>1</flac_header>
    <max_volume>100</max_volume>
    <friendly_name>TV</friendly_name>
    </device>
    </squeeze2upnp>
    As I mentioned, this isn't actually affecting me negatively because my 24/192 flacs are playing successfully on my Sonos. The downsampling is taking place somewhere so I can only assume LMS is doing its job when it spots that my Sonos players max out at 48000Hz, whereas previously I had to use custom-convert.conf to do this?
    Last edited by FatPete; 2018-08-28 at 16:03. Reason: Disclaimer that I was wrong!

  9. #2089
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    5,109
    Quote Originally Posted by FatPete View Post
    Thanks Philippe. I've just tried this now (ensuring plugin wasn't running and Applying changes at each step) but somehow LMS is still correctly downsampling 24/192 flac so that my Sonos can play it. I haven't restored my custom-convert.conf file yet.

    Here's what I see when playing a 24/192 file:

    Code:
    [10:06:25.864161] sq_callback:297 [0x74b440]:
            artist:DeVotchKa
            album:This Night Falls Forever
            title:Straight Shot
            genre:Alternative
            duration:322.800
            size:0
            cover:http://192.168.1.10:9000/music/7f044116/cover.jpg
            offset:0
    [10:06:25.864344] sq_callback:324 [0x74b440]: current URI set http://192.168.1.10:49153/bridge-1.flac
    [10:06:25.864480] AVTSetURI:91 [0x74b440]: uPNP setURI http://192.168.1.10:49153/bridge-1.flac (cookie 0x1)
    [10:06:25.864849] process_start:1140 [0x6c8080]: codec:c, ch:0, s:0, r:0
    [10:06:25.865052] sendSTAT:160 [0x6c8080]: STAT:[STMc] msplayed 0
    [10:06:26.032405] AVTSetPlayMode:167 [0x74b440]: uPNP set play mode (cookie 0x2)
    [10:06:26.032718] AVTPlay:151 [0x74b440]: uPNP play (cookie 0x3)
    [10:06:26.032951] CtrlSetMute:282 [0x74b440]: uPNP mute 0 (cookie 0x3)
    [10:06:26.033526] CtrlSetVolume:253 [0x74b440]: uPNP volume 11 (cookie 0x4)
    [10:06:26.043990] output_http_thread:135 [0x6c8080]: got HTTP connection 19
    [10:06:26.047709] output_http_thread:181 [0x6c8080]: drain is 131072 (waited 183)
    [10:06:26.049027] handle_http:478 [0x6c8080]: received GET /bridge-1.flac HTTP/1.1
    [10:06:26.049367] handle_http:481 [0x6c8080]: HTTP headers
    CONNECTION: close
    Host: 192.168.1.10:49153
    ACCEPT: */*
    USER-AGENT: Linux UPnP/1.0 Sonos/44.2-54281 (ZPS11)
    
    [10:06:26.059277] handle_http:565 [0x6c8080]: responding:
    HTTP/1.1 200 OK
    Server: squeezebox-bridge
    Connection: close
    Content-Type: audio/flac
    Transfer-Encoding: chunked
    For a normal 16/44 file:

    Code:
    [10:12:58.826432] sq_callback:297 [0x74b440]:
            artist:Interpol
            album:Marauder
            title:If You Really Love Nothing
            genre:Alternative
            duration:265.640
            size:0
            cover:http://192.168.1.10:9000/music/d60b741f/cover.jpg
            offset:0
    [10:12:58.826832] sq_callback:324 [0x74b440]: current URI set http://192.168.1.10:49153/bridge-2.wav
    [10:12:58.827074] AVTSetURI:91 [0x74b440]: uPNP setURI http://192.168.1.10:49153/bridge-2.wav (cookie 0x9a)
    [10:12:58.827517] process_start:1140 [0x6c8080]: codec:p, ch:2, s:16, r:44100
    [10:12:58.827809] sendSTAT:160 [0x6c8080]: STAT:[STMc] msplayed 0
    [10:12:58.930009] AVTSetPlayMode:167 [0x74b440]: uPNP set play mode (cookie 0x9b)
    [10:12:58.930250] AVTPlay:151 [0x74b440]: uPNP play (cookie 0x9c)
    [10:12:58.930342] CtrlSetVolume:253 [0x74b440]: uPNP volume 9 (cookie 0x9c)
    [10:12:58.937763] output_http_thread:135 [0x6c8080]: got HTTP connection 17
    [10:12:58.988013] _output_new_stream:419 [0x6c8080]: encoding in PCM r:44100 s:16 f:w
    [10:12:58.988132] _output_new_stream:420 [0x6c8080]: HTTP -3, estimated len 46858940
    [10:12:58.988164] output_http_thread:181 [0x6c8080]: drain is 529200 (waited 161)
    [10:12:58.988786] handle_http:478 [0x6c8080]: received GET /bridge-2.wav HTTP/1.1
    [10:12:58.988919] handle_http:481 [0x6c8080]: HTTP headers
    CONNECTION: close
    Host: 192.168.1.10:49153
    ACCEPT: */*
    USER-AGENT: Linux UPnP/1.0 Sonos/44.2-54281 (ZPS11)
    
    [10:12:58.989370] handle_http:565 [0x6c8080]: responding:
    HTTP/1.1 200 OK
    Server: squeezebox-bridge
    Connection: close
    Content-Type: audio/wav
    Transfer-Encoding: chunked
    Here's my bridge config:

    Code:
    <squeeze2upnp>
    <decode_log>warn</decode_log>
    <log_limit>-1</log_limit>
    <upnp_socket>?</upnp_socket>
    <slimproto_log>info</slimproto_log>
    <upnp_log>info</upnp_log>
    <output_log>info</output_log>
    <main_log>info</main_log>
    <util_log>warn</util_log>
    <common>
    <send_metadata>1</send_metadata>
    <sample_rate>48000</sample_rate>
    <send_coverart>1</send_coverart>
    <streambuf_size>524288</streambuf_size>
    <stream_length>-3</stream_length>
    <raw_audio_format>raw,wav,aif</raw_audio_format>
    <volume_feedback>1</volume_feedback>
    <enabled>1</enabled>
    <roon_mode>0</roon_mode>
    <accept_nexturi>1</accept_nexturi>
    <codecs>flc,aif,pcm,mp3</codecs>
    <forced_mimetypes>HASH(0x7a53d58)</forced_mimetypes>
    <output_size>4194304</output_size>
    <flac_header>1</flac_header>
    <max_volume>100</max_volume>
    <auto_play>0</auto_play>
    <server>?</server>
    <mode>thru</mode>
    <L24_format>1</L24_format>
    <resample_options/>
    <min_gapless>10</min_gapless>
    <send_icy>1</send_icy>
    <volume_on_play>1</volume_on_play>
    <seek_after_pause>0</seek_after_pause>
    </common>
    <slimmain_log>warn</slimmain_log>
    <stream_log>warn</stream_log>
    <device>
    <accept_nexturi>1</accept_nexturi>
    <codecs>aif,pcm,flc,mp3</codecs>
    <enabled>1</enabled>
    <stream_length>-3</stream_length>
    <raw_audio_format>wav,aiff</raw_audio_format>
    <sample_rate>48000</sample_rate>
    <name>TV</name>
    <send_metadata>1</send_metadata>
    <seek_after_pause>0</seek_after_pause>
    <udn>uuid:RINCON_5CAAFD32C25001400</udn>
    <mode>thru</mode>
    <L24_format>2</L24_format>
    <mac>bb:bb:36:34:70:74</mac>
    <flac_header>1</flac_header>
    <max_volume>100</max_volume>
    <friendly_name>TV</friendly_name>
    </device>
    </squeeze2upnp>
    As I mentioned, this isn't actually affecting me negatively because my 24/192 flacs are playing successfully on my Sonos. The downsampling is taking place somewhere so I can only assume LMS is doing its job when it spots that my Sonos players max out at 48000Hz, whereas previously I had to use custom-convert.conf to do this?
    This seems to be in order and the bridge operates in thru mode - the max sample rate is 48000 so you expect LMS to downsample tracks above that rate which it does. I don’t why the flc-flc rule did not apply before. Was it player specific, as per our discussion with @PasTim?
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  10. #2090
    Junior Member
    Join Date
    Apr 2015
    Posts
    21
    Quote Originally Posted by philippe_44 View Post
    This seems to be in order and the bridge operates in thru mode - the max sample rate is 48000 so you expect LMS to downsample tracks above that rate which it does. I don’t why the flc-flc rule did not apply before. Was it player specific, as per our discussion with @PasTim?
    EDIT: Ignore my ramblings below - my assumptions were completely wrong, everything works as expected and my results were due to Sonos now being able to play 24/48 flac files natively!

    Ah, if everything is working as expected then I'll keep quiet now!

    For reasons unknown, when I first started using your uPnPBridge back in April 2016, any flac file 24/96 and upwards refused to play on my Sonos - each track was immediately skipped. For whatever reason, LMS wasn't downsamping anything above 48kHz, but I searched around the forum and found something about using custom-convert.conf to force the downsampling. My original post is here (referencing my original problem in the first half of the post):

    https://forums.slimdevices.com/showt...l=1#post850551

    I only had a single Sonos Play:5 at the time, so unsure if it was player-specific.

    I think I was using LMS 7.7.x back then, so maybe something was changed between 7.7.x and 7.9.x that made LMS downsample correctly? As far as I recall, I always had uPnPBridge configured to report 48000 as the max sample rate. I'd continued to use the custom-convert.conf file in the intervening years because I assumed it was necessary for the downsampling but it all works as expected now!

    Anyway, no problems nowadays! A big thank you again for all your hard work on these plugins over the years - it's worked wonderfully for my Sonos system.
    Last edited by FatPete; 2018-08-28 at 16:04. Reason: Disclaimer that I was wrong!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •