Home of the Squeezebox™ & Transporter® network music players.
Page 159 of 264 FirstFirst ... 59109149157158159160161169209259 ... LastLast
Results 1,581 to 1,590 of 2636
  1. #1581
    Junior Member
    Join Date
    Jan 2018
    Posts
    7
    Quote Originally Posted by philippe_44 View Post
    I don't have any more a roon account. Maybe you can tell him to shoot me an email and we can discuss then. Or you can simply ask them if they have now enable a mimic of the cli service - they might have
    I'll get in touch with Roon on this, see if they are willing to help on this. Thanks Philippe!

  2. #1582
    Junior Member
    Join Date
    Jan 2018
    Posts
    7
    Quote Originally Posted by philippe_44 View Post
    I don't have any more a roon account. Maybe you can tell him to shoot me an email and we can discuss then. Or you can simply ask them if they have now enable a mimic of the cli service - they might have
    Philippe,

    See Brian's response:

    Brian Luczkiewicz Roon Labs: CTO:

    They are free to contact me with questions, and I will help informally as I have before, but we do not drive this sort of communication from our end, as this is not part of our product.

    For now-playing data, we mimic the interfaces that the SB Touch and SB Radio use, based on observing their behavior. Iím not sure exactly which subset of the LMS APIs that is, but itís pretty straightforward to sniff the traffic going back and forth between one of those + Roon and find out. All of the source code for these protocols (both sides) is open, so there are generally few mysteries with Squeezeboxes.

  3. #1583
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    5,101
    Quote Originally Posted by MichaelvdW View Post
    Philippe,

    See Brian's response:

    Brian Luczkiewicz Roon Labs: CTO:

    They are free to contact me with questions, and I will help informally as I have before, but we do not drive this sort of communication from our end, as this is not part of our product.

    For now-playing data, we mimic the interfaces that the SB Touch and SB Radio use, based on observing their behavior. Iím not sure exactly which subset of the LMS APIs that is, but itís pretty straightforward to sniff the traffic going back and forth between one of those + Roon and find out. All of the source code for these protocols (both sides) is open, so there are generally few mysteries with Squeezeboxes.
    This is what I think they'd do, but that only works for devices that are actually Touch or Radio (I think when I tried a year ago my Boom just displayed "streaming from Roon"). When a device says to be a squeezelite, then nothing will be sent to it. The way my bridge works is that I query the LMS server to gather what's being played, it's not sent to me by LMS proactively. But as Roon is not a real LMS server, it does not answre those queries ... so no metadata
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  4. #1584
    Junior Member
    Join Date
    May 2009
    Posts
    25
    Quote Originally Posted by philippe_44 View Post
    Make sure you've compiled with debug symbols and run the bridge with gdb (don't use the autolaunch by LMS for the moment, just disable the plugin there and launch the app manually). I need to know exactly where it crashes. There are more than a few things where I've not flagged FREEBSD correctly ...
    Hello philippe_44,

    attached you find the gdb trace you requested and the Makefile i used to build LMS-to-uPnP.
    It seems to be that there are some problems comparing the mac address / uuid.
    Attached Files Attached Files

  5. #1585
    Junior Member
    Join Date
    Jan 2018
    Posts
    7
    Quote Originally Posted by philippe_44 View Post
    This is what I think they'd do, but that only works for devices that are actually Touch or Radio (I think when I tried a year ago my Boom just displayed "streaming from Roon"). When a device says to be a squeezelite, then nothing will be sent to it. The way my bridge works is that I query the LMS server to gather what's being played, it's not sent to me by LMS proactively. But as Roon is not a real LMS server, it does not answre those queries ... so no metadata
    Thanks Philippe, it's a pity, but it is what it is...

  6. #1586
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    5,101
    Quote Originally Posted by x11max View Post
    Hello philippe_44,

    attached you find the gdb trace you requested and the Makefile i used to build LMS-to-uPnP.
    It seems to be that there are some problems comparing the mac address / uuid.
    I did correct one thing wrt CLI connection and FreeBSD. With that, I can't reproduce an issue on my VM, it works. Even w/o this correction, I was just missing the metadata, but it was working. My libupnp is configure with "./configure --disable-blocking_tcp_connections --disable-samples" but that would not explain. I've uploaded a version with my build on FreeBSD, let me if it works for you - mayb we should rather continue on github
    LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000, ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5

  7. #1587

    share GGMM E5 setup experience

    Hi Philippe,

    Thank you for your great plugins.
    Just want to share my setup experience for the GGMM E5.

    Triggered by this thread I purchased a GGMM E5, and got it working after some evenings ...
    In my case I did not succeed to have any music from the GGMM E5, which later was solved by removing some codecs in the configuration file.
    Once I looked in the log files, it was clear that the issue was with the codec when playing flac files. (That was my big mistake, not to a look in the log file earlier ....).
    When I tried to play mp3, it worked fine. After I removed all codecs except flc, mp3, also flac is playing now without problem (I removed aiff, pcm).
    It was not immediately clear to me that pre defined player profiles could be fetched (I assumed having only one player that I could use common configuration, and did not see the drop down menu ...).
    But the pre defined profile contained the pcm, aiff codecs, which in my case caused the fail when trying to play flac files.
    (lms and plug in running on raspberry pi 3.)

    But now I am quite happy to have my new device acting as another squeezebox.
    Next step is to try the Airplay plugin have the device detected, not successful yet (other thread :-) ).
    Squeezebox 3 // Squeezebox Touch // Squeezebox Boom// Squeezebox Radio// Raspberry pi

  8. #1588
    Junior Member
    Join Date
    May 2009
    Posts
    25
    Quote Originally Posted by philippe_44 View Post
    I did correct one thing wrt CLI connection and FreeBSD. With that, I can't reproduce an issue on my VM, it works. Even w/o this correction, I was just missing the metadata, but it was working. My libupnp is configure with "./configure --disable-blocking_tcp_connections --disable-samples" but that would not explain. I've uploaded a version with my build on FreeBSD, let me if it works for you - mayb we should rather continue on github
    Just test it with your bin file: The result is a little bit different to mine. The bin file crashes immediately after starting and is restarting in a loop afterwards.

    In the trace i see the same message comparing to trace regarding the uuid : #1 0x000000000042ddd1 in uuid_compare ()

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # gdb --args /Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin/squeeze2upnp-bsd-x64 -Z -I -b 192.168.10.33 -d all=debug -x /Library/LMS/slimserver/prefs/upnpbridge.xml
    GNU gdb 6.1.1 [FreeBSD]
    Copyright 2004 Free Software Foundation, Inc.
    GDB is free software, covered by the GNU General Public License, and you are
    welcome to change it and/or distribute copies of it under certain conditions.
    Type "show copying" to see the conditions.
    There is absolutely no warranty for GDB. Type "show warranty" for details.
    This GDB was configured as "amd64-marcel-freebsd"...(no debugging symbols found)...
    (gdb) run
    Starting program: /Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin/squeeze2upnp-bsd-x64 -Z -I -b 192.168.10.33 -d all=debug -x /Library/LMS/slimserver/prefs/upnpbridge.xml
    (no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[08:46:32.900378] main:1569 Starting squeeze2upnp version: v0.3.0.0.2 (Jan 29 2018 @ 20:38:28)
    [08:46:32.900782] uPNPInitialize:1317 UPnP initialized
    [08:46:33.007734] AddMRDevice:1194 [0x6ac840]: adding renderer ([TV]Samsung LED40)
    [08:46:33.007749] GetProtocolInfo:336 uPNP http://192.168.10.81:7676/smp_20_ GetProtocolInfo
    [08:46:33.203154] GetProtocolInfo:347 [0x6ac840]: ProtocolInfo http-get:*:.......
    ......
    08:46:33.203413] sq_run_device:1153 Buffer path /tmp/
    [08:46:33.203441] stream_thread_init:296 [0x64d730] streambuf size: 2457600
    [08:46:33.204212] output_mr_thread_init:810 [0x64d730] init output media renderer
    [08:46:33.204243] UpdateThread:1054 Updating configuration /Library/LMS/slimserver/prefs/upnpbridge.xml
    [08:46:33.204274] discover_server:782 [0x64d730] sending discovery
    [08:46:33.204389] discover_server:811 [0x64d730] got response from: 192.168.10.33:3483
    [08:46:33.204397] slimproto:837 squeezelite [0x64d730] <=> player [0x6ac840]
    [08:46:33.204399] slimproto:838 [0x64d730] connecting to 192.168.10.33:3483
    [08:46:33.204425] slimproto:869 [0x64d730] connected
    [08:46:33.204429] sendHELO:109 [0x64d730] mac: 90:f1:aa:2a:11:fa
    [08:46:33.204432] sendHELO:110 [0x64d730] cap: Model=squeezelite,ModelName=SqueezeLite,AccuratePl ayPoints=0,HasDigitalOut=1,MaxSampleRate=48000,pcm ,flc,mp3
    [08:46:33.254940] UpdateThread:991 [0x6ac840] UPnP keep alive: [TV]Samsung LED40
    [08:46:33.254951] UpdateThread:1001 [0x6ac840] UPnP keep alive: [TV]Samsung LED40
    [08:46:33.306255] process:530 [0x64d730] strm
    [08:46:33.306265] process_strm:219 [0x64d730] strm command q
    [08:46:33.306267] output_flush:843 [0x64d730]: flush output buffer
    [08:46:33.306287] sq_callback:325 [0x6ac840]: device off or not controlled by LMS
    [08:46:33.306356] process:530 [0x64d730] strm
    [08:46:33.306360] process_strm:219 [0x64d730] strm command q
    [08:46:33.306362] output_flush:843 [0x64d730]: flush output buffer
    [08:46:33.306370] sq_callback:325 [0x6ac840]: device off or not controlled by LMS
    [08:46:33.306413] process:530 [0x64d730] setd
    [08:46:33.306416] sendSETDName:204 set playername: [TV]Samsung LED40
    [08:46:33.306425] process:530 [0x64d730] setd
    [08:46:33.306486] process:530 [0x64d730] aude
    [08:46:33.306489] process_aude:422 [0x64d730] on/off using aude 1
    [08:46:33.306491] sq_callback:321 [0x6ac840]: device set on/off 1
    [08:46:33.306539] process:530 [0x64d730] audg
    [08:46:33.306542] process_audg:436 [0x64d730] (old) audg gainL: 46 gainR: 46
    [08:46:33.354967] CheckAndLock:468 device is NULL
    [08:46:33.354978] CheckAndLock:468 device is NULL
    [08:46:33.354980] CheckAndLock:468 device is NULL
    [...
    [08:46:33.361987] MasterHandler:888 [0x6ac840]: subscribe success
    [08:46:33.362280] _ProcessVolume:629 [0x6ac840]: UPnP Volume local change 8

    Program received signal SIGFPE, Arithmetic exception.
    0x000000000041361b in MasterHandler ()
    (gdb) bt
    #0 0x000000000041361b in MasterHandler ()
    #1 0x000000000042ddd1 in uuid_compare ()
    #2 0x0000000000000000 in ?? ()
    (gdb) q
    The program is running. Exit anyway? (y or n) y
    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin #

    My system environment:

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # bsdinfo

    OS: FreeBSD amd64
    Hostname: freebsd
    Kernel: 11.1-RELEASE-p4
    RAM: 4007M / 16193M
    Processes: 114
    CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # uname -UK
    1101001 1101001
    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # uname -a
    FreeBSD freebsd 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin #
    changed.

    Further i have installed 4 additional upnp ports i need for other applications. I will go to delete them to see whether or not the pattern will be changed.

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # pkg info | grep -u upnp
    gupnp-1.0.2_2 Framework for UPnP devices
    hupnp-1.0.0_1 Library for building UPnP devices and control points
    kio-upnp-ms-1.0.0.g20110808_7 KIO slave to access UPnP MediaServers
    upnp-1.6.22,1 Universal Plug and Play Software Development Kit
    Last edited by x11max; 2018-01-31 at 01:58.

  9. #1589
    Junior Member
    Join Date
    May 2009
    Posts
    25
    Quote Originally Posted by x11max View Post
    Just test it with your bin file: The result is a little bit different to mine. The bin file crashes immediately after starting and is restarting in a loop afterwards.

    In the trace i see the same message comparing to trace regarding the uuid : #1 0x000000000042ddd1 in uuid_compare ()

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # gdb --args /Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin/squeeze2upnp-bsd-x64 -Z -I -b 192.168.10.33 -d all=debug -x /Library/LMS/slimserver/prefs/upnpbridge.xml
    GNU gdb 6.1.1 [FreeBSD]
    Copyright 2004 Free Software Foundation, Inc.
    GDB is free software, covered by the GNU General Public License, and you are
    welcome to change it and/or distribute copies of it under certain conditions.
    Type "show copying" to see the conditions.
    There is absolutely no warranty for GDB. Type "show warranty" for details.
    This GDB was configured as "amd64-marcel-freebsd"...(no debugging symbols found)...
    (gdb) run
    Starting program: /Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin/squeeze2upnp-bsd-x64 -Z -I -b 192.168.10.33 -d all=debug -x /Library/LMS/slimserver/prefs/upnpbridge.xml
    (no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[08:46:32.900378] main:1569 Starting squeeze2upnp version: v0.3.0.0.2 (Jan 29 2018 @ 20:38:28)
    [08:46:32.900782] uPNPInitialize:1317 UPnP initialized
    [08:46:33.007734] AddMRDevice:1194 [0x6ac840]: adding renderer ([TV]Samsung LED40)
    [08:46:33.007749] GetProtocolInfo:336 uPNP http://192.168.10.81:7676/smp_20_ GetProtocolInfo
    [08:46:33.203154] GetProtocolInfo:347 [0x6ac840]: ProtocolInfo http-get:*:.......
    ......
    08:46:33.203413] sq_run_device:1153 Buffer path /tmp/
    [08:46:33.203441] stream_thread_init:296 [0x64d730] streambuf size: 2457600
    [08:46:33.204212] output_mr_thread_init:810 [0x64d730] init output media renderer
    [08:46:33.204243] UpdateThread:1054 Updating configuration /Library/LMS/slimserver/prefs/upnpbridge.xml
    [08:46:33.204274] discover_server:782 [0x64d730] sending discovery
    [08:46:33.204389] discover_server:811 [0x64d730] got response from: 192.168.10.33:3483
    [08:46:33.204397] slimproto:837 squeezelite [0x64d730] <=> player [0x6ac840]
    [08:46:33.204399] slimproto:838 [0x64d730] connecting to 192.168.10.33:3483
    [08:46:33.204425] slimproto:869 [0x64d730] connected
    [08:46:33.204429] sendHELO:109 [0x64d730] mac: 90:f1:aa:2a:11:fa
    [08:46:33.204432] sendHELO:110 [0x64d730] cap: Model=squeezelite,ModelName=SqueezeLite,AccuratePl ayPoints=0,HasDigitalOut=1,MaxSampleRate=48000,pcm ,flc,mp3
    [08:46:33.254940] UpdateThread:991 [0x6ac840] UPnP keep alive: [TV]Samsung LED40
    [08:46:33.254951] UpdateThread:1001 [0x6ac840] UPnP keep alive: [TV]Samsung LED40
    [08:46:33.306255] process:530 [0x64d730] strm
    [08:46:33.306265] process_strm:219 [0x64d730] strm command q
    [08:46:33.306267] output_flush:843 [0x64d730]: flush output buffer
    [08:46:33.306287] sq_callback:325 [0x6ac840]: device off or not controlled by LMS
    [08:46:33.306356] process:530 [0x64d730] strm
    [08:46:33.306360] process_strm:219 [0x64d730] strm command q
    [08:46:33.306362] output_flush:843 [0x64d730]: flush output buffer
    [08:46:33.306370] sq_callback:325 [0x6ac840]: device off or not controlled by LMS
    [08:46:33.306413] process:530 [0x64d730] setd
    [08:46:33.306416] sendSETDName:204 set playername: [TV]Samsung LED40
    [08:46:33.306425] process:530 [0x64d730] setd
    [08:46:33.306486] process:530 [0x64d730] aude
    [08:46:33.306489] process_aude:422 [0x64d730] on/off using aude 1
    [08:46:33.306491] sq_callback:321 [0x6ac840]: device set on/off 1
    [08:46:33.306539] process:530 [0x64d730] audg
    [08:46:33.306542] process_audg:436 [0x64d730] (old) audg gainL: 46 gainR: 46
    [08:46:33.354967] CheckAndLock:468 device is NULL
    [08:46:33.354978] CheckAndLock:468 device is NULL
    [08:46:33.354980] CheckAndLock:468 device is NULL
    [...
    [08:46:33.361987] MasterHandler:888 [0x6ac840]: subscribe success
    [08:46:33.362280] _ProcessVolume:629 [0x6ac840]: UPnP Volume local change 8

    Program received signal SIGFPE, Arithmetic exception.
    0x000000000041361b in MasterHandler ()
    (gdb) bt
    #0 0x000000000041361b in MasterHandler ()
    #1 0x000000000042ddd1 in uuid_compare ()
    #2 0x0000000000000000 in ?? ()
    (gdb) q
    The program is running. Exit anyway? (y or n) y
    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin #

    My system environment:

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # bsdinfo

    OS: FreeBSD amd64
    Hostname: freebsd
    Kernel: 11.1-RELEASE-p4
    RAM: 4007M / 16193M
    Processes: 114
    CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # uname -UK
    1101001 1101001
    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # uname -a
    FreeBSD freebsd 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin #
    changed.

    Further i have installed 4 additional upnp ports i need for other applications. I will go to delete them to see whether or not the pattern will be changed.

    root@freebsd:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # pkg info | grep -u upnp
    gupnp-1.0.2_2 Framework for UPnP devices
    hupnp-1.0.0_1 Library for building UPnP devices and control points
    kio-upnp-ms-1.0.0.g20110808_7 KIO slave to access UPnP MediaServers
    upnp-1.6.22,1 Universal Plug and Play Software Development Kit
    Hi philippe_44,

    I got it working. I recompiled LMS-to-uPnP with the new version (squeeze2upnp version: v0.3.0.0.2) and it is working fine now on my hardware. Pls. see attachment.
    If you would like to have the bin files let me know, pls.

    Now i will do the same for freebsd 12 running on RPI3, where i have the same issue.
    Attached Files Attached Files
    Last edited by x11max; 2018-01-31 at 01:57.

  10. #1590
    Junior Member
    Join Date
    May 2009
    Posts
    25
    Quote Originally Posted by x11max View Post
    Hi philippe_44,

    I got it working. I recompiled LMS-to-uPnP with the new version (squeeze2upnp version: v0.3.0.0.2) and it is working fine now on my hardware. Pls. see attachment.
    If you would like to have the bin files let me know, pls.

    Now i will do the same for freebsd 12 running on RPI3, where i have the same issue.
    squeeze2upnp version: v0.3.0.0.2 also running on RPI3:
    root@raspberry:/Library/LMS/slimserver/prefs # uname -a
    FreeBSD raspberry 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r326378: Thu Nov 30 13:34:13 UTC 2017 root@releng3.nyi.freebsd.org:/usr/ob...rc/arm64.aarch64/sys/GENERIC arm64

    root@raspberry:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin # ls -ltr *arm64*
    -rwxr-xr-x 1 lms lms 396816 Jan 31 11:57 squeeze2upnp-arm64
    -rwxr-xr-x 1 lms lms 1479608 Jan 31 11:57 squeeze2upnp-arm64-static
    root@raspberry:/Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin #

    Starting Squeeze2upnp: /Library/LMS/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin/squeeze2upnp-arm64 -Z -I -b 192.168.10.3 -f /Library/LMS/slimserver/Logs/upnpbridge.log -d all=debug -x /Library/LMS/slimserver/prefs/upnpbridge.xml
    [12:04:55.739040] main:1569 Starting squeeze2upnp version: v0.3.0.0.2 (Jan 31 2018 @ 11:57:15)
    [12:04:55.753633] uPNPInitialize:1317 UPnP initialized
    [12:05:06.953950] AddMRDevice:1194 [0xe02c0]: adding renderer (TechniMedia UHD+)
    [12:05:06.954362] GetProtocolInfo:336 uPNP http://192.168.10.80:9085/dev1/srv0/control GetProtocolInfo
    [12:05:06.974249] GetProtocolInfo:347 [0xe02c0]: ProtocolInfo http-get:*:audio/mpegLNA.ORG_PN=MP3,http-get:*:audio/x-ms-wmaLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wmaLNA.ORG_PN=WMAFULL,http-get:*:audio/x-ms-wm
    12:05:07.011182] slimproto:838 [0x811c0] connecting to 192.168.10.3:3483
    [12:05:07.011730] UpdateThread:991 [0xe02c0] UPnP keep alive: TechniMedia UHD+
    [12:05:07.011805] UpdateThread:1001 [0xe02c0] UPnP keep alive: TechniMedia UHD+
    [12:05:07.011956] slimproto:869 [0x811c0] connected
    [12:05:07.012030] sendHELO:109 [0x811c0] mac: 00:08:c9:78:48:70
    [12:05:07.012094] sendHELO:110 [0x811c0] cap: Model=squeezelite,ModelName=SqueezeLite,AccuratePl ayPoints=0,HasDigitalOut=1,MaxSampleRate=48000,pcm ,flc,mp3
    [12:05:07.177664] UpdateThread:991 [0xe02c0] UPnP keep alive: TechniMedia UHD+

    Now it's time to get ride of my macOS x86-tosh and replace it with my RPI3.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •