Home of the Squeezebox™ & Transporter® network music players.
Page 120 of 370 FirstFirst ... 2070110118119120121122130170220 ... LastLast
Results 1,191 to 1,200 of 3691
  1. #1191
    Senior Member
    Join Date
    Apr 2013
    Posts
    190
    Quote Originally Posted by castalla View Post
    Has anybody tried the upnpbridge with Bose soundtouch devices?
    I came here to ask the same question. I am really curious to know if the Soundtouch will work with the bridge. Anyone???

  2. #1192
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,572
    Quote Originally Posted by usc95 View Post
    I came here to ask the same question. I am really curious to know if the Soundtouch will work with the bridge. Anyone???
    I seriously doubt it will work - I've searched and posted without success. Bose seem uninterested in implementing a standard DLNA protocol. They've also removed Airplay from all their later models and extol the virtues of bluetooth (???!!!) as the way forward.

    Not a viable option for LMS users, sadly.
    ------------------------------------------------------------------------------------

  3. #1193
    Junior Member
    Join Date
    Dec 2015
    Posts
    28

    Configuration for PhilipsNP3900

    Hello
    I just want to share the setting for my Philips NP3900



    note : LMS volume changes must be "ignore all change" or "transparent forward" if select "only when playing" only the first song work next change stop playing

    thank you for your pluging
    Attached Images Attached Images  

  4. #1194
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,897
    Quote Originally Posted by yogui View Post
    Hello
    I just want to share the setting for my Philips NP3900



    note : LMS volume changes must be "ignore all change" or "transparent forward" if select "only when playing" only the first song work next change stop playing

    thank you for your pluging
    Thanks for sharing - that's strange though, it means it's a bug in my plugin because there should be no such correlation
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  5. #1195
    Junior Member
    Join Date
    Dec 2015
    Posts
    28
    Quote Originally Posted by philippe_44 View Post
    Thanks for sharing - that's strange though, it means it's a bug in my plugin because there should be no such correlation
    Hi
    Do you need more information ?
    A other bug I found if i change volume over the plugin the sound goes unless up and down

  6. #1196
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,897
    Quote Originally Posted by yogui View Post
    Hi
    Do you need more information ?
    A other bug I found if i change volume over the plugin the sound goes unless up and down
    Do you mean the sound changes constantly? Did you try disable the volume feedback
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  7. #1197
    Junior Member
    Join Date
    Dec 2015
    Posts
    28
    Yes I try and it works

  8. #1198
    Senior Member
    Join Date
    Mar 2008
    Location
    Paris
    Posts
    204
    Philippe,
    Using your last sq2upnp dev version 0.2.10.0, Roon (emulating LMS) is now streaming to UPnP renderers !
    Big thanks to you for that !

    I'm still testing but looks promising.
    Additionally sq2cast dev 0.2.4.0 seems to work with Roon and Chromecast devices using the same mechanism.

    I've downloaded the new versions from:
    sq2upnp 0.2.10.0 dev: https://sourceforge.net/projects/lms-to-upnp/
    sq2cast 0.2.4.0 dev: https://sourceforge.net/projects/lms-to-cast/


    I've also checked https://github.com/philippe44 for the source code.


    The new default_on parameter must be set to 1 to use the bridges with Roon.

    Name:  Sq2u-roon-foobar.jpg
Views: 656
Size:  184.1 KB

    My config.xml with Roon

    <?xml version="1.0"?>
    <squeeze2upnp>
    <common>
    <streambuf_size>2457600</streambuf_size>
    <output_size>2457600</output_size>
    <default_on>1</default_on>
    <buffer_dir>?</buffer_dir>
    <buffer_limit>-1</buffer_limit>
    <stream_length>-3</stream_length>
    <stream_pacing_size>1048576</stream_pacing_size>
    <max_GET_bytes>-1</max_GET_bytes>
    <keep_buffer_file>0</keep_buffer_file>
    <enabled>1</enabled>
    <process_mode>2</process_mode>
    <codecs>pcm,flc,mp3</codecs>
    <sample_rate>48000</sample_rate>
    <L24_format>1</L24_format>
    <flac_header>1</flac_header>
    <allow_flac>0</allow_flac>
    <seek_after_pause>0</seek_after_pause>
    <byte_seek>0</byte_seek>
    <send_icy>0</send_icy>
    <volume_on_play>1</volume_on_play>
    <volume_feedback>1</volume_feedback>
    <send_metadata>1</send_metadata>
    <send_coverart>1</send_coverart>
    <max_volume>100</max_volume>
    <accept_nexturi>1</accept_nexturi>
    <min_gapless>0</min_gapless>
    <upnp_remove_count>1</upnp_remove_count>
    <raw_audio_format>raw</raw_audio_format>
    <match_endianness>1</match_endianness>
    <auto_play>0</auto_play>
    <server>?</server>
    </common>
    <upnp_socket>?</upnp_socket>
    <slimproto_log>warn</slimproto_log>
    <stream_log>warn</stream_log>
    <output_log>warn</output_log>
    <decode_log>warn</decode_log>
    <web_log>warn</web_log>
    <main_log>info</main_log>
    <slimmain_log>info</slimmain_log>
    <upnp_log>info</upnp_log>
    <util_log>warn</util_log>
    <upnp_scan_interval>30</upnp_scan_interval>
    <upnp_scan_timeout>15</upnp_scan_timeout>
    <log_limit>-1</log_limit>
    <device>
    <udn>uuid:e8cd7863-e738-2750-ae36-5c5465792b23</udn>
    <name>foobar2000 Renderer (Bruno) [NUCI5]</name>
    <friendly_name>foobar2000 Renderer (Bruno) [NUCI5]</friendly_name>
    <mac>bb:bb:ed:eb:37:18</mac>
    <enabled>1</enabled>
    <default_on>1</default_on>
    </device>
    </squeeze2upnp>
    Last edited by volpone; 2016-10-21 at 01:28.
    SqueezeBoxServer 7.9 / ReadyNas Pro (x86) | SBTouch - SB3 - Duet - Boom - Ipeng
    SBTouch => Rega DAC => Rega Brio R amp => Harbeth SLH5 speakers
    see details & photos here, 4 slides

  9. #1199
    Senior Member
    Join Date
    Mar 2008
    Location
    Paris
    Posts
    204
    Hi Philippe,


    After a little more tests (not much) some observations concerning sq2u 0.2.10.0 and Roon streaming to Foobar2000 (WIN10)
    Using the auto generated config.xml (i only edit one line to set default_on to 1):


    0) No metadata and cover art on Foobar UI


    1) I've successfuly played audio files from Roon: AAC, MP3, MP4, FLAC, TIDAL and Internet Radio (all 16b) OK


    2) Latency is very good ! OK


    3) Unable to play: 24b / 192khZ FLAC KO (i have to investigate more because i have very few 192k files and i'm not sure it is a sq2u issue)


    4) No problem when i load and play individual track OK


    5) Sometimes (not always) in a playlist or album mode (even with the same audio format on all tracks):
    - When playing a track if i skip to the next track (via > button) the next track doesn't play (no errors on the sq2u & foobar console). If i skip forward again the next track is played (N+2).
    - If i skip backward (via <button) it seems to work better

    Questions:

    1) How to write sq2u logs ?
    i've tried squeeze2upnp-win.exe -I config.xml -f sq2u.log -d all=error
    No joy ... no sq2.log in the current directory

    2) Is sq2u OpenHome compliant ? (usable with LINN devices for example)


    Thank you
    Last edited by volpone; 2016-10-19 at 19:10.
    SqueezeBoxServer 7.9 / ReadyNas Pro (x86) | SBTouch - SB3 - Duet - Boom - Ipeng
    SBTouch => Rega DAC => Rega Brio R amp => Harbeth SLH5 speakers
    see details & photos here, 4 slides

  10. #1200
    Junior Member
    Join Date
    Oct 2016
    Posts
    5

    Roon with Sonos

    Hi Phillippe,

    I was referred here by Bruno (Volpone).

    I'm trying to connect Sonos with Roon but could not get the sound out.
    I am able to get the audio settings for the sonos on roon, but there is no sound from the sonos.

    From the log, i can see that the sonos was found (192.168.0.17) but further down the line, it says that the "device off or not controlled by LMS".
    Could you please let me know if there are mandatory tags that i need to have in the config.xml to connect Roon to Sonos? I have already have default_on set to 1.

    Below is the log
    I'm using Mac Mini with Mac OS 10.11.6


    sudo ./squeeze2upnp-osx-multi -x configVolpone.xml -d all=debug
    [16:11:05.263012] main:1554 Starting squeeze2upnp version: v0.2.10.0 (Oct 15 2016 @ 16:13:42)

    [16:11:05.263546] decode_init:126 init decode, include codecs: exclude codecs:
    [16:11:05.263558] main:1584 Buffer path /var/tmp/
    [16:11:05.264310] uPNPInitialize:1131 uPNP init success - 192.168.0.17:49153
    [16:11:05.264325] uPNPInitialize:1142 ControlPoint registered
    [16:11:05.264329] uPNPInitialize:1153 WebServer enabled
    [16:11:05.264335] uPNPInitialize:1164 VirtualDir set for Squeezelite
    [16:11:05.264339] uPNPInitialize:1181 Callbacks registered for VirtualDir

    [16:11:05.605477] CallbackEventHandler:768 Answer to uPNP search 16780504


    [16:11:05.930479] CallbackEventHandler:768 Answer to uPNP search 16780504

    [16:11:06.084278] CallbackEventHandler:768 Answer to uPNP search 41943768
    [16:11:06.366686] CallbackEventHandler:768 Answer to uPNP search 16780504
    [16:11:20.004476] UpdateMRThread:946 Begin UPnP devices update
    [16:11:20.039155] AddMRDevice:1262 [0x1000d3ee0]: adding renderer (192.168.0.68 - Sonos PLAY:1)
    [16:11:20.052140] GetProtocolInfo:299 uPNP XXXXX GetProtocolInfo (cookie 0x0)
    [16:11:20.060636] HandleStateEvent:613 [0x1000d3ee0]: device off, ignored
    [16:11:20.070207] CallbackEventHandler:813 [0x1000d3ee0]: ProtocolInfo http-get:*:audio/mp3:*,x-file-cifs:*:audio/mp3:*,http-get:*:audio/mp4:*,x-file-cifs:*:audio/mp4:*,http-get:*:audio/mpeg:*,x-file-cifs:*:audio/mpeg:*,http-get:*:audio/mpegurl:*,x-file-cifs:*:audio/mpegurl:*,real.com-rhapsody-http-1-0:*:audio/mpegurl:*,file:*:audio/mpegurl:*,http-get:*:audio/x-mpegurl:*,x-file-cifs:*:audio/x-mpegurl:*,http-get:*:application/x-mpegurl:*,x-file-cifs:*:application/x-mpegurl:*,http-get:*:application/apple.vnd.mpegurl:*,x-file-cifs:*:application/apple.vnd.mpegurl:*,http-get:*:audio/mpeg3:*,x-file-cifs:*:audio/mpeg3:*,http-get:*:audio/wav:*,x-file-cifs:*:audio/wav:*,http-get:*:audio/wma:*,x-file-cifs:*:audio/wma:*,http-get:*:audio/x-ms-wma:*,x-file-cifs:*:audio/x-ms-wma:*,http-get:*:audio/aiff:*,x-file-cifs:*:audio/aiff:*,http-get:*:audio/flac:*,x-file-cifs:*:audio/flac:*,http-get:*:application/ogg:*,x-file-cifs:*:application/ogg:*,http-get:*:audio/audible:*,x-file-cifs:*:audio/audible:*,real.com-rhapsody-http-1-0:*:audio/x-ms-wma:*,real.com-rhapsody-direct:*:audio/mp3:*,sonos.com-mms:*:audio/x-ms-wma:*,sonos.com-http:*:audio/mp3:*,sonos.com-http:*:audio/mpeg:*,sonos.com-http:*:audio/mpeg3:*,sonos.com-http:*:audio/wma:*,sonos.com-http:*:audio/mp4:*,sonos.com-http:*:audio/wav:*,sonos.com-http:*:audio/aiff:*,sonos.com-http:*:audio/flac:*,sonos.com-http:*:application/ogg:*,sonos.com-spotify:*:audio/x-spotify:*,sonos.com-rtrecent:*:audio/x-sonos-recent:*,real.com-rhapsody-http-1-0:*:audio/x-rhap-radio:*,real.com-rhapsody-direct:*:audio/x-rhap-radio:*,pandora.com-pndrradio:*:audio/x-pandora-radio:*,pandora.com-pndrradio-http:*:audio/mpeg3:*,sirius.com-sirradio:*:audio/x-sirius-radio:*,x-rincon:*:*:*,x-rincon-mp3radio:*:*:*,x-rincon-playlist:*:*:*,x-rincon-queue:*:*:*,x-rincon-stream:*:*:*,x-sonosapi-stream:*:*:*,x-sonosapi-hls:*:*:*,x-sonosapi-hls-static:*:*:*,x-sonosapi-radio:*:audio/x-sonosapi-radio:*,x-sonosapi-iqradio:*:audio/x-sonosapi-iqradio:*,x-rincon-cpcontainer:*:*:*,last.fm-radio:*:audio/x-lastfm-radio:*,last.fm-radio-http:*:audio/mpeg3:* (cookie 0x0)
    [16:11:20.075177] AddMRDevice:1339 [0x1000d3ee0]: waited 20 ms for protocolinfo
    [16:11:20.075329] stream_thread_init:296 [0x1000713d0] streambuf size: 2457600
    [16:11:20.075405] output_mr_thread_init:824 [0x1000713d0] init output media renderer
    [16:11:20.075429] decode_thread_init:153 [0x1000713d0]: init decode
    [16:11:20.075482] discover_server:830 [0x1000713d0] sending discovery
    [16:11:20.076267] discover_server:859 [0x1000713d0] got response from: 192.168.0.17:3483
    [16:11:20.076311] slimproto_thread_init:1004 [0x1000713d0] connecting to 192.168.0.17:3483
    [16:11:20.076509] slimproto:913 [0x1000713d0] connected
    [16:11:20.076524] sendHELO:132 [0x1000713d0] mac: bb:bb:37:88:f1:26
    [16:11:20.076532] sendHELO:133 [0x1000713d0] cap: Model=squeezelite,ModelName=SqueezeLite,AccuratePl ayPoints=0,HasDigitalOut=0,MaxSampleRate=48000,pcm ,flc,mp3
    [16:11:20.078708] process:572 [0x1000713d0] setd
    [16:11:20.078722] sendSETDName:227 set playername: 192.168.0.68 - Sonos PLAY:1
    [16:11:20.079237] process:572 [0x1000713d0] vers
    [16:11:20.079253] process_vers:545 [0x1000713d0] version 7.7.5
    [16:11:20.079695] process:572 [0x1000713d0] strm
    [16:11:20.079707] process_strm:242 [0x1000713d0] strm command t
    [16:11:20.079718] sendSTAT:168 [0x1000713d0] STAT: STMt
    [16:11:20.081250] process:572 [0x1000713d0] audg
    [16:11:20.081271] process_audg:480 [0x1000713d0] (old) audg gainL: 33 gainR: 33
    [16:11:20.081283] sq_callback:299 [0x1000d3ee0]: device off or not controlled by LMS
    [16:11:20.109596] process:572 [0x1000713d0] strm
    [16:11:20.109625] process_strm:242 [0x1000713d0] strm command q
    [16:11:20.109632] decode_flush:198 [0x1000713d0]: decode flush
    [16:11:20.109638] output_flush:902 [0x1000713d0]: flush output buffer
    [16:11:20.109660] sq_callback:299 [0x1000d3ee0]: device off or not controlled by LMS
    [16:11:20.333425] AddMRDevice:1262 [0x1000d5cd8]: adding renderer (192.168.0.67 - Sonos PLAY:1)
    [16:11:20.349940] GetProtocolInfo:299 uPNP XXX GetProtocolInfo (cookie 0x0)
    [16:11:20.364332] HandleStateEvent:613 [0x1000d5cd8]: device off, ignored



    Thank you very much for your help,
    Bastian
    Attached Images Attached Images  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •