Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,334

    WebUI Interface Settings?

    In the WebUI -> Settings -> Interface I have set Title Format to display "TRACKNUM. TITLE DURATION GENRE", This works just fine in the left pane, however in the right pane it always adds "from <album> by <artist>". Is there any way to get rid of that? It's enough to have the album and artist at the top of the right hand pane. Why can't it just use the same song display code used in the left pane? Seems like this would also reduce the code maintenance if the song entries were displayed from a common sub-routine. This is on 7.8.0 Windows version of LMS.
    Attached Images Attached Images  
    Main system - Rock Solid with LMS 7.9.1 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.1 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  2. #2
    Senior Member get.amped's Avatar
    Join Date
    Feb 2007
    Location
    Upstate NY
    Posts
    788
    Settings -> Player -> Basic -> Title Format should control that:

    Name:  titleformat.jpg
Views: 179
Size:  47.8 KB
    Home: Win7Pro(x64)[3.3Ghz i5, 8GB RAM, 120GB SSD system, 15TB storage], LMS 7.9.0 -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic -> NAD C160 -> 2 x NAD C272 -> Quad 22L2
    Portable: FreeNAS 9.3 [HP Microserver Gen8, 10GB RAM, 16GB flash boot, 120GB SSD for LMS 7.9.0 in FreeBSD jail, 5 x 4TB WD Red HD ZFS RAIDZ1] -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic: XLR out -> Soundmaster Diamond 12-2 mixing board -> P.A.

  3. #3
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,334
    Really, that may be true for the SB3, but not for the Duet receiver. What LMS version are you running?

    Name:  Webui1.JPG
Views: 174
Size:  31.2 KB

    Could be that what your showing is for the display on the player rather than the right hand pane of the WebUI.
    Last edited by w3wilkes; 2015-02-24 at 15:10.
    Main system - Rock Solid with LMS 7.9.1 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.1 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  4. #4
    Senior Member get.amped's Avatar
    Join Date
    Feb 2007
    Location
    Upstate NY
    Posts
    788
    Right, should be here for the web UI (running 7.9 but it's been here for a long time):

    Name:  titleformat2.jpg
Views: 174
Size:  83.4 KB
    Home: Win7Pro(x64)[3.3Ghz i5, 8GB RAM, 120GB SSD system, 15TB storage], LMS 7.9.0 -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic -> NAD C160 -> 2 x NAD C272 -> Quad 22L2
    Portable: FreeNAS 9.3 [HP Microserver Gen8, 10GB RAM, 16GB flash boot, 120GB SSD for LMS 7.9.0 in FreeBSD jail, 5 x 4TB WD Red HD ZFS RAIDZ1] -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic: XLR out -> Soundmaster Diamond 12-2 mixing board -> P.A.

  5. #5
    Senior Member get.amped's Avatar
    Join Date
    Feb 2007
    Location
    Upstate NY
    Posts
    788
    I just tested it by changing from my current selection to one of the other ones in the list. Refreshing the web page resulted in changing the format of the right pane with the now playing list.
    Home: Win7Pro(x64)[3.3Ghz i5, 8GB RAM, 120GB SSD system, 15TB storage], LMS 7.9.0 -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic -> NAD C160 -> 2 x NAD C272 -> Quad 22L2
    Portable: FreeNAS 9.3 [HP Microserver Gen8, 10GB RAM, 16GB flash boot, 120GB SSD for LMS 7.9.0 in FreeBSD jail, 5 x 4TB WD Red HD ZFS RAIDZ1] -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic: XLR out -> Soundmaster Diamond 12-2 mixing board -> P.A.

  6. #6
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,334
    Here's my settings as stated in the OP and you can see in the OP that the right hand pane has the "from <album> by <artist>" even though that is NOT what I have in the interface settings. Does the right hand pane in 7.9 also have the "from <album> by <artist>" when NOT set in the interface settings?
    Attached Images Attached Images  
    Main system - Rock Solid with LMS 7.9.1 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.1 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  7. #7
    Senior Member get.amped's Avatar
    Join Date
    Feb 2007
    Location
    Upstate NY
    Posts
    788
    That's quite unusual. It definitely works as expected for me.

    *Ahem* Paging M. Herger to the courtesy phone...
    Home: Win7Pro(x64)[3.3Ghz i5, 8GB RAM, 120GB SSD system, 15TB storage], LMS 7.9.0 -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic -> NAD C160 -> 2 x NAD C272 -> Quad 22L2
    Portable: FreeNAS 9.3 [HP Microserver Gen8, 10GB RAM, 16GB flash boot, 120GB SSD for LMS 7.9.0 in FreeBSD jail, 5 x 4TB WD Red HD ZFS RAIDZ1] -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic: XLR out -> Soundmaster Diamond 12-2 mixing board -> P.A.

  8. #8
    Senior Member
    Join Date
    Jul 2005
    Location
    Vancouver, Canada
    Posts
    270
    I get this behaviour also. Regardless of the Title Format I choose in Settings>Interface, the WUI right panel always includes from and by after the song title. I'm using 7.9. I seldom use the WUI when listening so it doesn't bother me, but it does seem unusual.

    Edit: I tried a few other settings and some exclude the from but all seem to include by
    Last edited by jfo; 2015-02-24 at 21:12.

  9. #9
    Senior Member get.amped's Avatar
    Join Date
    Feb 2007
    Location
    Upstate NY
    Posts
    788
    I did a little more testing and it appears that it also depends on whether album art is hidden. With this setting:

    Name:  titleformat3.jpg
Views: 148
Size:  54.8 KB

    The list looks like this with album art displayed:

    Name:  titleformat4.jpg
Views: 148
Size:  46.1 KB

    And like this with it hidden:

    Name:  titleformat5.jpg
Views: 149
Size:  53.9 KB

    In either case though it would appear to be buggy and in need of a fix.
    Home: Win7Pro(x64)[3.3Ghz i5, 8GB RAM, 120GB SSD system, 15TB storage], LMS 7.9.0 -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic -> NAD C160 -> 2 x NAD C272 -> Quad 22L2
    Portable: FreeNAS 9.3 [HP Microserver Gen8, 10GB RAM, 16GB flash boot, 120GB SSD for LMS 7.9.0 in FreeBSD jail, 5 x 4TB WD Red HD ZFS RAIDZ1] -> Logitech Squeezebox Classic V.3 -> Cambridge Audio DacMagic: XLR out -> Soundmaster Diamond 12-2 mixing board -> P.A.

  10. #10
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,531
    This has always behaved like this. The idea is that in a mixed artist and album playlist, if your title format doesn't include artist and album, then you can't see them in the playlist. All you might have is song titles. So they're added.

    You might note that LMS does also add them in the browse pane on the left, and it does so intelligently. If you're looking at an album track list, the album name won't be appended, since it's shown above. If that album is by a single artist, the artist also won't be appended, as it's the same on every track. However, on a compilation album, or an album where the track artists differ from the album artist, they're added.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •