Home of the Squeezebox™ & Transporter® network music players.
Page 15 of 16 FirstFirst ... 513141516 LastLast
Results 141 to 150 of 157
  1. #141
    Senior Member
    Join Date
    May 2009
    Location
    Clacton-on-Sea, Essex. UK
    Posts
    513
    I've just found out how to carry out a start or restart of LMS on Windows and use the --nomysqueezebox parameter if anyone is interested.

    net restart squeezesrv --nomysqueezebox

    It can be used at the command line if 'cmd' is started as administrator, or by using Task Scheduler.
    start, stop and restart are all allowed as are any additional parameters.

    Bob
    1 x Touch
    1 x Radio
    1 x Boom
    1 x Intel-NUC server/squeezelite running LMS 7.91 on Windows 10
    1 X Odroid-XU4 server/squeezelite running LMS 7.91 on Ubuntu 16.04
    WaveIO USB into Lavry DA-10 DAC
    Starfish Pre-amp : Based on NAIM NAC 72
    Heavily modified NAIM NAP 250 Power-amp
    Behringer DEQ2496
    Linn Isobarik DMS

  2. #142
    Senior Member
    Join Date
    Jul 2005
    Posts
    310
    Quote Originally Posted by bobertuk View Post
    I've just found out how to carry out a start or restart of LMS on Windows and use the --nomysqueezebox parameter if anyone is interested.

    net restart squeezesrv --nomysqueezebox

    It can be used at the command line if 'cmd' is started as administrator, or by using Task Scheduler.
    start, stop and restart are all allowed as are any additional parameters.

    Bob
    Not on all versions of Windows. On my Windows 10 Pro OS, there is no "net restart" command. I use:

    net stop squeezesvc & net start squeezesvc --nomysqueezebox

    (If desired, you can use && instead; in that case, the start command won't run if LMS isn't already running)

  3. #143

    macOS

    Just in case anybody runs LMS on macOS and wants to try this - here's how I got --nomysqueezebox to work on macOS (10.12):

    When the server starts it (sometimes?) seems to reset the LMS launchagent (path in my case: ~/Library/LaunchAgents/Squeezebox.plist) to its default state deleting any modifications, i.e. --nomysqueezebox.
    So I made a copy of Squeezebox.plist, then opened the original in a text editor, "emptied", saved, and locked the file (to prevent any changes).
    I renamed the copy and added the --nomysqueezebox as program arguments:

    Code:
    <plist version="1.0">
    	<dict>
    		<key>Label</key>
    		<string>Squeezebox</string>
    		<key>RunAtLoad</key>
    		<true />
    		<key>Program</key>
    			<string>/Library/PreferencePanes/Squeezebox.prefPane/Contents/server/slimserver.pl</string>
    		<key>ProgramArguments</key>
    		<array>
            	    <string>/Library/PreferencePanes/Squeezebox.prefPane/Contents/server/slimserver.pl</string>
            	    <string>--nomysqueezebox</string>
    		</array>
    		<key>WorkingDirectory</key>
    		<string>/Library/PreferencePanes/Squeezebox.prefPane/Contents/server</string>
    		<key>StandardOutPath</key>
    		<string>/Users/YOUR_USERNAME/Library/Logs/Squeezebox/server.log</string>
    		<key>StandardErrorPath</key>
    		<string>/Users/YOUR_USERNAME/Library/Logs/Squeezebox/server.log</string>
    	</dict>
    </plist>

  4. #144
    Junior Member
    Join Date
    May 2017
    Posts
    3
    Quote Originally Posted by mherger View Post
    If you want to play with this kind of external image proxy, add my test
    repository to your plugin settings:
    Michael, it looks like the plugin has gone from your repos. I use LMS behind a reverse proxy, and port 9000 is not available. Consequently, the image proxy breaks. Any suggestions?

  5. #145
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,985
    Quote Originally Posted by dasos View Post
    Michael, it looks like the plugin has gone from your repos. I use LMS behind a reverse proxy, and port 9000 is not available. Consequently, the image proxy breaks. Any suggestions?
    I'm not sure I do understand how that plugin would help your issue. Maybe you want to elaborate?

    FWIW: I added the plugin back to my test repository.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  6. #146
    Junior Member
    Join Date
    May 2017
    Posts
    3
    For some reason, Apache (my reverse proxy) seems to be choking on the encoded URL, unless it is passed as a parameter. I was hoping to adjust the URL to something like this: <domain>/imageproxy/?<image url> (instead of this:<domain>/imageproxy/<image url>)

    I think you made a copy-paste error while editing www.herger.net/slim-plugins/test.xml - the XML at the end is malformed.

    Thanks!

  7. #147
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,985

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > For some reason, Apache (my reverse proxy) seems to be choking on the
    > encoded URL, unless it is passed as a parameter. I was hoping to adjust
    > the URL to something like this: <domain>/imageproxy/?<image url>
    > (instead of this:<domain>/imageproxy/<image url>)


    Unfortunately this won't change at all using a custom image proxy. Only
    what LMS would do with that URL will change.

    But this rather sounds like a proxy issue. How does it choke on the URL?

    > I think you made a copy-paste error while editing
    > www.herger.net/slim-plugins/test.xml - the XML at the end is malformed.


    Thanks - should be fixed now.

    --

    Michael

  8. #148
    Junior Member
    Join Date
    May 2017
    Posts
    3
    Got it. I thought that changing the image proxy would result in changes to the generated HTML (ie, the img src tags), but the proxy appears to be used on the backend. My misunderstanding, and now I think about it, obvious.

    For anyone else who is having trouble, I finally got Apache to accept the URLs by following this great SO post: https://stackoverflow.com/a/9933890 As a note, I needed to disable the image proxy plugin that Micheal provided.
    Last edited by dasos; 2018-02-15 at 03:38. Reason: Wrong URL

  9. #149
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,985

    --nomysqueezebox: disable allmysb.comintegration in LMS 7.9

    > For anyone else who is having trouble, I finally got Apache to accept
    > the URLs by following this great SO post:
    > https://stackoverflow.com/a/4443129


    Wow... good catch!

    > As a note, I needed to disable the
    > image proxy plugin that Micheal provided.


    Why did you have to change it? How did it fail? It doesn't have any
    "active code" (eg. code which would be used to catch the image), but is
    only an enabler, setting prefs. If with this plugin you were having
    issues, then most likely it's because of the image proxy you tried to
    use. Well possible that one of them is broken or no longer available. Or
    you were using the placeholder you'd have had to replace with your own
    server ;-).

    --

    Michael

  10. #150
    @mherger
    will you add the --nomysqueezebox switch to the settings page eventually as part of LMS?
    I'm asking because right now when I restart the server from iPeng or after installing a plugin it starts with mysqueezebox.com and I always have to restart manually with the switch.
    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •