Home of the Squeezebox™ & Transporter® network music players.
Page 11 of 13 FirstFirst ... 910111213 LastLast
Results 101 to 110 of 130
  1. #101
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,624

    New in 7.9: Fulltext search

    >> And that's where it stops? There's no error message, not even a
    >> suspicious last SQL query to be run... Would you mind sharing your
    >> library.db with me?

    >
    > Sure, the library.db is 'here'
    > (http://melvincentral.com/xfer/library.db).


    Thanks, I'll look into this. Just one more thing: how much memory do you
    have on that machine? And did you enable the high memory settings in
    Advanced/Performance?

    --

    Michael

  2. #102
    Quote Originally Posted by mherger View Post
    Just one more thing: how much memory do you have on that machine? And did you enable the high memory settings in Advanced/Performance?
    The machine has 8GB. Database Memory Config is set to Maximum. During a scan, the process(es) seem to take just a few percent of the total memory. Total memory usage on the system is ~5GB.

  3. #103
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,624

    New in 7.9: Fulltext search

    > Sure, the library.db is 'here'

    I don't get it. It took my MacBook about 10s to create the fulltext
    index using that library.db file. And it finished without a hiccup.

    Would the scan always stop on the same track?

    Edward Maya Feat. Vika Jigulina/Stereo Love/03 - Stereo Love \(Extended
    Version\).mp3

    --

    Michael

  4. #104
    Quote Originally Posted by mherger View Post
    Would the scan always stop on the same track?
    It does appear to stop on the same track. What I find odd is that if I remove the playlist files from the playlist folder and rescan (look for changed), it still has the same error. Shouldn't it recognize those playlists are gone and not try to index them? At that point the playlists still show up in the web interface.

    Edit:

    If I remove the playlist files from the folder and clear-rescan, then it completes okay. If I then add the playlist with the track that caused the problem before (PL1) and rescan-changed, it completes without a problem. Adding another playlist (PL2, leaving PL1 and PL2 in the folder) is the same. Then substituting a third playlist (PL3) for those two and rescan-changed results in the same termination, on the same track as before (which is not contained in the PL3 playlist remaining in the playlist folder but instead in PL1, which is no longer in the folder). Running clear-rescan at that point completes without a problem. And a further rescan-changed completes without a problem (still just PL3), and no problem after adding PL2. Finally, adding PL1 at that point (so all three in the folder) causes termination. I'm having a hard time figuring out what might cause the issue.
    Last edited by jwmelvin; 2014-11-06 at 11:43.

  5. #105
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,624

    New in 7.9: Fulltext search

    > It does appear to stop on the same track. What I find odd is that if I
    > remove the playlist files from the playlist folder and rescan (look for
    > changed), it still has the same error. Shouldn't it recognize those
    > playlists are gone and not try to index them?


    It should indeed, but reportedly doesn't. There is a bug report which
    was mentioned only a few days ago.

    --

    Michael

  6. #106
    Senior Member
    Join Date
    Jan 2006
    Location
    South Coast, NSW, Australia
    Posts
    1,298
    jwmelvin, there is a new build - 1415720123 @ Tue Nov 11 - that should have fixed the crash while scanning playlists.
    The bug was chased down in this thread http://forums.slimdevices.com/showth...l=1#post796046
    A camel is a racehorse designed by a committee.

    Seen sprayed on the outside wall of the local library -
    Three things I hate in life :
    1. Vandalism
    2. Irony
    3. Lists

  7. #107
    That's great, thank you. I will wait for it to be out on the nightly server and will check it out. I appreciate the notice.

  8. #108
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,582
    Question:

    I have an album, "Bouncing with Bud", where all of the tracks have the following comment:

    Recorded live in Copenhagen at Cafe Montmartre, April 26, 1962

    I do a search for "cafe" and the search returns all of the tracks from the album in the song list, but it doesn't return the album in the album list. Is that how it should work?

  9. #109
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,582
    And here's a scanning bug. I'm not sure if it's related to the fulltext scan, but I think it may not be. I noticed several typos in that comment, so I retagged all of the files in the album, changing

    Recorded live in Copehagen at Cafe Montmarte, April 26, 1962
    to
    Recorded live in Copenhagen at CafÚ Montmartre, April 26, 1962

    On the songinfo page I now see the following, which must mean both versions of the comment are now in the database:

    Comment: Recorded live in Copehagen at Cafe Montmarte, April 26, 1962 / Recorded live in Copenhagen at CafÚ Montmartre, April 26, 1962

    I can see from both the View Tags page and within a binary file editor, only the corrected version exists in the files. They do not have two comment tags. If I now search for 'montmarte', the fulltext search returns nothing, but the Advanced Search returns the files if this is searched for in the Comment field.

  10. #110
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,624

    New in 7.9: Fulltext search

    > I have an album, "Bouncing with Bud", where all of the tracks have the
    > following comment:
    >
    > Recorded live in Copenhagen at Cafe Montmartre, April 26, 1962
    >
    > I do a search for "cafe" and the search returns all of the tracks from
    > the album in the song list, but it doesn't return the album in the album
    > list. Is that how it should work?


    Heh... I totally skipped any track information in the album index.
    Should probably add some. Thanks for the heads up!

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •