Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2

Threaded View

  1. #1
    Junior Member
    Join Date
    Mar 2014

    [Solved] Google All Play Music Plugin - TroubleShooting Questions?

    OK - I've had this plugin working for a while but after I upgraded from Linux Mint 16 to Mint 17 it has stopped working. After the initial install everything looks good (music is found as expected), however no music is retrieved from the server. Checking the logs reveals the '403 Forbidden' error (which AFAIK was previously reporteted as fixed by using a new version of the gmusicsapi).

    >>Error Log<<
    [14-07-28 00:47:05.1508] Plugins::GoogleMusic::ProtocolHandler::getNextTrac k (103) Looking up stream url for url googlemusic:track:721b58d5-ca14-3e27-b13e-94ffb8d2be83 failed: CallFailure: GetStreamUrl: 403 Client Error: Forbidden
    >>Error Log<<

    I reinstalled both LMS and the plugin twice now and continue to get the '403 Forbidden Error'. In each case I tried to ensure that I removed all traces of previous installs (to prevent errors due to cached data being reused - however I'm not 100% sure that I covered all the bases on this).

    What is badly needed here is some sort of troubleshooting guide to test and ensure that everything works correctly, and (more importantly) documentation or checklist of steps to back out changes and retest. (FWIW I expect Google API to be a moving target and some test procedure to confirm any changes will be useful).

    Can anyone out there confirm if this error has really been fixed - at the monment I'm stumped rewhat to do next - going back to my previous install is*NOT* an option.
    It would also be helpful if someone could identify any specific uninstall steps that need to be followed (I have a nagging feeling that I've missed some steps, but can't think what they are).

    Last edited by PatrickJ; 2014-07-29 at 10:53. Reason: Added Solution

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts