Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    962

    Controller playing up, continuous rebooting and wifii problems

    I have a Duet. The Receiver is fine and most of the time I control it from iPeng HD. But I do still have a Controller and I use it occasionally. But over the last few months it's been losing the wireless network and needing reconnecting, or getting stuck in an endless loop of continually rebooting (I leave it and after a few hours it recovers) and so on. Some days I can't get it to work at all, then it will go a week working flawlessly.

    I've now upgraded to LMS 7.8.0 (I was on 7.7.3 since it came out) and the Controller was upgraded. Since it rebooted at the end of the upgrade it's not been able to see the network, and has now forgotten the name of the player. If I go into Diagnostics -> Wireless Info it shows no data. Diagnostics -> Networking won't enter the meny, when I click on Networking I get the right/left screen wobble which says this can't be done.

    Is there are hope for this Controller? Is this a known fault that I can do something about? I'm happy to have a go at opening it up and unplugging/replugging a wifi card and cleaning contacts etc. if that is what it needs.

    I'm about to try a "Restore Factory Settings" and see if that does any good.

  2. #2
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    962
    Doesn't look good. I had to remove the battery to get it to restart and display the screen saying factory settings had been restored. When it rebooted again from there and displayed the Choose Language menu, I clicked English and it rebooted. I'm back at Choose Language again, this time selecting English says "Loading English" but after it's done that I'm back at the Choose Language menu. Scrolling up and down the Choose Language menu is also very slow.

  3. #3
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,469
    The 7.8.0 is working fine on both my controllers so I doubt it is a controller firmware problem. What's the signal strength for your wifi when trying to set up the controller? If you're far away and have a weak signal or signal interference you could have problems. I guess it's also possible that the firmware update itself had some type issue. You could reload the firmware using the method of inserting a SD card into the controller to remove the possibility of your network connection being a problem. I believe the SD card upgrade method is documented in one of the wiki pages.
    Main system - Rock Solid with LMS 7.9.4 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.4 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Test system - LMS 8.0 nightly on Win10Pro - Squeezeplay
    Squeezebox Boom - "At Large" player around both home and cabin
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  4. #4
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,469
    Found the wiki page on methods of updating controller...
    http://wiki.slimdevices.com/index.ph...ezeOS_Upgrades
    Main system - Rock Solid with LMS 7.9.4 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.4 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Test system - LMS 8.0 nightly on Win10Pro - Squeezeplay
    Squeezebox Boom - "At Large" player around both home and cabin
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  5. #5
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    962
    Quote Originally Posted by w3wilkes View Post
    The 7.8.0 is working fine on both my controllers so I doubt it is a controller firmware problem. What's the signal strength for your wifi when trying to set up the controller? If you're far away and have a weak signal or signal interference you could have problems. I guess it's also possible that the firmware update itself had some type issue. You could reload the firmware using the method of inserting a SD card into the controller to remove the possibility of your network connection being a problem. I believe the SD card upgrade method is documented in one of the wiki pages.
    Signal strength is around 80% so I doubt that's the issue.

  6. #6
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    962
    Quote Originally Posted by w3wilkes View Post
    Found the wiki page on methods of updating controller...
    http://wiki.slimdevices.com/index.ph...ezeOS_Upgrades
    The SD Card methods looks like my best chance. But the jive.bin file the wiki links to does not exist, nor can I find one in any of the current nightly builds. I've looked in my 7.7.2, 7.7.3 and 7.8.0 downloaded binaries directories (I grab everything for all platforms for official releases) and there isn't one there either. Nor is there one in the installed LMS 7.8.0 directory in C:\Program Files on my server, which is rather strange since the network download process found the file from somewhere. Maybe it has a different filename?

  7. #7
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,469
    You are in luck. You can find every firmware version for every squeeze device here...
    http://update.slimdevices.com/update/firmware/
    Main system - Rock Solid with LMS 7.9.4 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.4 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Test system - LMS 8.0 nightly on Win10Pro - Squeezeplay
    Squeezebox Boom - "At Large" player around both home and cabin
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  8. #8
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    962
    Quote Originally Posted by w3wilkes View Post
    You are in luck. You can find every firmware version for every squeeze device here...
    http://update.slimdevices.com/update/firmware/
    Thanks for that. But surely it must be somewhere within my installed LMS 7.8.0? Or are we still reliant on Logitech for the web site? I thought 7.8.0 got rid of any reliance on Logitech servers.

  9. #9
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,469
    Don't know about WHSv1, but on WHS2011 and Win7 the updates are here;
    C:\ProgramData\Squeezebox\Cache\updates
    You might find them somewhere like here on WHSv1;
    C:\Users\All Users\Squeezebox\Cache\updates
    Main system - Rock Solid with LMS 7.9.4 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.4 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Test system - LMS 8.0 nightly on Win10Pro - Squeezeplay
    Squeezebox Boom - "At Large" player around both home and cabin
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  10. #10
    Senior Member
    Join Date
    Dec 2010
    Location
    Cambridge, UK
    Posts
    962
    Quote Originally Posted by w3wilkes View Post
    Don't know about WHSv1, but on WHS2011 and Win7 the updates are here;
    C:\ProgramData\Squeezebox\Cache\updates
    You might find them somewhere like here on WHSv1;
    C:\Users\All Users\Squeezebox\Cache\updates
    Ah, seems to be in:

    C:\Documents and Settings\All Users\Application Data\Squeezebox\Cache\updates

    but this only contains jive_7.8.0_r16739.bin and jive.version so it looks to me as if LMS downloads the player updates on demand from the Logitech web sites.

    I say again, I thought 7.8.0 was supposed to remove all dependencies on Logitech servers? That to me should mean it comes with all the updates for all players bundled into the server installation. Otherwise if I install it in 10 years time or whatever, it won't necessarily work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •