Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 42 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 420

Thread: LMS 7.9 and DSD

  1. #31
    Senior Member
    Join Date
    Dec 2008
    Posts
    276
    Quote Originally Posted by Triode View Post
    That sounds right to me.

    Have you done a full wipe and rescan to clear the database from any old information about the files before you upgraded?
    I have indeed; upgraded then a reset and full scan.

  2. #32
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by local.bin View Post
    I have indeed; upgraded then a reset and full scan.
    OK so when you try to play a file what log messages do you get? Suggest enabling player.source logging at info level and see what this says when you try to play a file.

  3. #33
    Senior Member
    Join Date
    Dec 2008
    Posts
    276
    Quote Originally Posted by local.bin View Post
    I've now updated with unfortunately the same result



    It gives me the error: Problem: Can't open file for <filename>


    Oops, will check the log ...

  4. #34
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by local.bin View Post


    Oops, will check the log ...
    You should see more info than that with logging enabled.

  5. #35
    Senior Member
    Join Date
    Dec 2008
    Posts
    276
    See attached.server.log

  6. #36
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by local.bin View Post
    See attached.server.log
    I don't see anything wrong with that - can you run:
    ldd /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/dsdplay

    Does it give any error messages?

    Do you have libFLAC installed on the machine?

  7. #37
    Senior Member
    Join Date
    Dec 2008
    Posts
    276
    Quote Originally Posted by Triode View Post
    I don't see anything wrong with that - can you run:
    ldd /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/dsdplay

    Does it give any error messages?

    Do you have libFLAC installed on the machine?
    root@Tower:/mnt/cache/data/lms.79/Logs# ldd /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/dsdplay
    linux-gate.so.1 => (0x4001f000)
    libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0x40026000)
    libsoxr.so.0 => /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/libsoxr.so.0 (0x40076000)
    libm.so.6 => /lib/libm.so.6 (0x400b0000)
    libc.so.6 => /lib/libc.so.6 (0x400d6000)
    libogg.so.0 => /usr/lib/libogg.so.0 (0x4023a000)
    libgomp.so.1 => not found
    libpthread.so.0 => /lib/libpthread.so.0 (0x4023f000)
    /lib/ld-linux.so.2 (0x40000000)

    Not sure if this helps, but these are the setting as I don't believe my Sony UDA-1 support DoP; but I recall you saying that wont work anyway with the Touch.

    Soxr Quality = Very High Quality

    Soxr Filter = Linear Phase

    Soxr Steep Filter = Soxr Steep Filter
    Last edited by local.bin; 2014-06-17 at 13:52.

  8. #38
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Quote Originally Posted by local.bin View Post
    root@Tower:/mnt/cache/data/lms.79/Logs# ldd /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/dsdplay
    linux-gate.so.1 => (0x4001f000)
    libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0x40026000)
    libsoxr.so.0 => /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/libsoxr.so.0 (0x40076000)
    libm.so.6 => /lib/libm.so.6 (0x400b0000)
    libc.so.6 => /lib/libc.so.6 (0x400d6000)
    libogg.so.0 => /usr/lib/libogg.so.0 (0x4023a000)
    libgomp.so.1 => not found
    libpthread.so.0 => /lib/libpthread.so.0 (0x4023f000)
    /lib/ld-linux.so.2 (0x40000000)


    Soxr Quality = Very High Quality

    Soxr Filter = Linear Phase

    Soxr Steep Filter = Soxr Steep Filter
    libgomp.so.1 not found is likely to be a problem... Can you look to install this for your machine. I need to look at the build of libsoxr.so.0 to see if I can disable that. Otherwise try installing libsoxr on the machine if you can and renaming /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/libsoxr.so.0 to something else.
    Last edited by Triode; 2014-06-17 at 14:10.

  9. #39
    Senior Member
    Join Date
    Dec 2008
    Posts
    276
    Quote Originally Posted by Triode View Post
    libomp.so.1 not found is likely to be a problem... Can you look to install this for your machine. I need to look at the build of libsoxr.so.0 to see if I can disable that. Otherwise try installing libsoxr on the machine if you can and renaming /mnt/cache/data/lms.79/Cache/InstalledPlugins/Plugins/PlayDSD/Bin/i386-linux/libsoxr.so.0 to something else.
    Ok, will take a look; will be tomorrow now, cheers

  10. #40
    Senior Member
    Join Date
    Mar 2011
    Posts
    210
    I updated to latest LMS 7.9.0 on OSX, PlayDSD v0.5 is installed and listed as active. Still getting the message "PlayDSD does not currently include a version of dsdplay which supports your server. DSD playback has been disabled for this player." Does this mean that OSX code is not yet included in the plugin? Or is it something else I can fix at my end?

    --------------
    More info:

    Logitech Media Server Version: 7.9.0 - 1402991900 @ Tue Jun 17 03:21:22 PDT 2014
    Operating system: OS X 10.9.3 - EN - utf8
    Platform Architecture: x86_64
    Perl Version: 5.16.2 - darwin-thread-multi-2level
    Audio::Scan: 0.94
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 2

    SBT1 (with EDO)
    Player Model: Squeezebox Touch
    Firmware: 7.7.2-r9663
    Player IP Address: 10.0.1.45

    SBT2 (with EDO)
    Player Model: Squeezebox Touch
    Firmware: 7.7.2-r9663
    Player IP Address: 10.0.1.59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •