I have the same problem as below. PiCorePlayer 4.1.0 is installed and DSDPlayer plugin v1.0 is installed in LMS 7.9.2 - 1543258616. Squeezelite is turned off on the Raspberry Pi 3B+ that is used as an LMS server. I can stream native DSD to a Squeezelite player that is attached to a USB DAC that supports it. I cannot transcode DSD to any other players. Like hellrider77, transcoding options are greyed out for DSF -> FLAC or DFF -> FLAC under File Types. In the player menu, I get "DSDPlayer will transcode DSD to PCM for this player. Use the settings below to tune resampling parameters," but there are no options displayed.

Is this a Linux problem? It works just fine on my Windows 10 PC if I run the server there.

Quote Originally Posted by hellrider77 View Post
Hello and nice to meet you.
This is my first post here as I am trying to get my Yamaha CD-S3000 to play DSD via piCorePlayer.

My environment looks like this:

LMS on Synology DS214:


Logitech Media Server Version: 7.9.2 - 0011.1527861596 @ Fri Jun 1 16:21:00 CEST 2018
Hostname: DiskStation
Operating system: Synology DiskStation - EN - utf8
Platform Architecture: armle-linux
Perl Version: 5.24.0 - armle-linux
Audio::Scan: 0.95
IO::Socket::SSL: 2.037
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)


pCP running on Raspberry Pi 2B+:

piCorePlayer | piCorePlayer v4.1.0 | linux 4.14.81-pcpCore_v7 | piCore v9.2pCP | Squeezelite v1.9.0-1121-pCP |

USB DAC: Yamaha CD-S3000, 24/192 max PCM, Native DSD 128 max
The problem is that in order for Yamaha to work in Windows with DSD, it requires an Steinberg ASIO driver.
The device does not accept DSD via DoP, only native.


The only way I got it to work correctly in pCP was to leave blank the output setting, all devices listed did not work or worked in 48Khz resolution

I have installed DSDPlayer (now version 1.02) , in LMS under player -> DSDPlayer i get "This player supports native playback of DSD files. DSD-over-PCM should be configured on the player configuration interface."

Under File Types I only get:

DFF DFF Native or Disabled
FLAC Greyed out - Disabled

DSF DSF Native or Disabled
FLAC Greyed out - Disabled

I tried all recommendations on Soundcheck's blog: "soundcheck-audio.blogspot.com/2018/01/raspberry-pi-audio-engine-part-6-dsd" (cannot post links as this is my first post)

DSD does not play at all, with any of the settings recommended above. I don't know what -W, -D commands stand for...

I had partial success by entering in pCP under "Device supports DSD/DoP" the value "0:dop". Yamaha plays DSD64 this way, but not DSD128.

I have no clue about squeezelite commands or linux but I am pretty good at following instructions.

Might help: I found a post regarding Yamaha CD-S2100 (probably the same USB receiver) here on the forums, as I cannot post links yet , I am copy / pasting the original post:



The OP was not interested into getting DSD working, he just left the Output Setting field blank, it worked, and moved on.

Thank you.

Sorin