Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    12

    Logitech Media Server died. Restarting.

    Hi

    I am trying to run Logitech Media Server on an Orange Pi Zero+ H5 - running Armbian. The idea is to have a small compact squeezeserver + squeezebox to bring with traveling (I am spending much time at hotels).


    I installed using dpkg, and used the latest build:
    logitechmediaserver_7.9.1~1523344273_all.deb

    ....I tried an older 7.8 build as well with same result.

    The service is constantly dying and respawing, I get this in /var/log/squeezebox/server.log:

    2018-04-12 06:24:35 Logitech Media Server died. Restarting.
    2018-04-12 06:24:40 Logitech Media Server died. Restarting.
    2018-04-12 06:24:45 Logitech Media Server died. Restarting.
    2018-04-12 06:24:50 Logitech Media Server died. Restarting.
    2018-04-12 06:24:55 Logitech Media Server died. Restarting.
    2018-04-12 06:25:00 Logitech Media Server died. Restarting
    .
    .



    The box is running Perl 5.22.1 (This is perl 5, version 22, subversion 1 (v5.22.1) built for aarch64-linux-gnu-thread-multi)

    I can find no other log info, except that it is constantly restarting......

    Does anyone have a clue?

    /macsat

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    19,960

    Logitech Media Server died. Restarting.

    > The box is running Perl 5.22.1 (This is perl 5, version 22, subversion 1
    > (v5.22.1) built for aarch64-linux-gnu-thread-multi)


    We don't have binaries for this platform. Is Armbian up to date? The
    Armbian I installed on my Rock64 came with a more recent Perl. We do
    have binaries for AARCH64 for Perl 5.24 and 5.26.

    Or you could compile the required modules yourself. It's usually pretty
    straight forward:

    https://github.com/Logitech/slimserv...ublic/7.9/CPAN

    --

    Michael

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    12
    Thank you for pointing me to sources.


    I think it is actually up to date. I just installed about a week ago from freshly downloaded image, and did an apt-get update;apt-get upgrade

    Compiling directly on the device worked, and didn't even take too long. These small devices are getting fast

    BR
    Kasper

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •