Home of the Squeezebox™ & Transporter® network music players.
Page 161 of 163 FirstFirst ... 61111151159160161162163 LastLast
Results 1,601 to 1,610 of 1622
  1. #1601
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    I think that there is a command line option in LMS to tell it what to listen on.
    If you can find it ... give it the IP4 address/net interface.

    (Am away from computer to check myself)
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  2. #1602
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    I think a HTTP connection is coming into LMS from an IPv6 source.
    If you can find where that is coming from, perhaps you can stop it (for now) and see if the error goes away.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  3. #1603
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    938
    Quote Originally Posted by Lestrad View Post
    I tried following these instructions, but no cigar...

    http://ask.xmodulo.com/disable-ipv6-linux.html
    You should disable IPv6 as it is described on the arch wiki:

    One can also avoid assigning IPv6 addresses to specific network interfaces by adding the following sysctl config to /etc/sysctl.d/40-ipv6.conf:
    Code:
    # Disable IPv6
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1
    net.ipv6.conf.eth0.disable_ipv6 = 1
    Note 2, if disabling IPv6 by sysctl, you should comment out the IPv6 hosts in your /etc/hosts:

    Code:
    #<ip-address> <hostname.domain.org> <hostname>
    127.0.0.1 localhost.localdomain localhost
    #::1 localhost.localdomain localhost
    dhcpcd
    add the following to /etc/dhcpcd.conf:

    Code:
    noipv6rs
    noipv6

    Reboot, check ifconfig if there are any IPv6 addresses assigned.
    Next, check your LAN router and disable IPv6 for your LAN

    If the problem persists, edit /usr/lib/systemd/system/logitechmediaserver.service and change line 14 from
    Code:
    --noimage --novideo
    to
    Code:
    --noimage --novideo --httpaddr 0.0.0.0 --cliaddr 0.0.0.0
    restart LMS, check:
    Code:
    ps -ef|grep httpaddr
    netstat -a -t|grep 9000
    Various SW: Web Interface | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

  4. #1604
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    938
    Quote Originally Posted by Lestrad View Post
    What exactly enables a PC or Squeezebox device to access LMS via port 9000?
    LMS

    With squeezelite and LMS installed, what more do I need to do?
    If you just want your Touch to work, LMS only.
    squeezelite is a LMS client to play music from LMS on the device it is installed on
    Various SW: Web Interface | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

  5. #1605
    Senior Member Lestrad's Avatar
    Join Date
    Oct 2010
    Posts
    313
    Quote Originally Posted by Roland0 View Post
    You should disable IPv6 as it is described on the arch wiki:



    Reboot, check ifconfig if there are any IPv6 addresses assigned.
    Next, check your LAN router and disable IPv6 for your LAN

    If the problem persists, edit /usr/lib/systemd/system/logitechmediaserver.service and change line 14 from
    Code:
    --noimage --novideo
    to
    Code:
    --noimage --novideo --httpaddr 0.0.0.0 --cliaddr 0.0.0.0
    restart LMS, check:
    Code:
    ps -ef|grep httpaddr
    netstat -a -t|grep 9000
    I've followed all the instructions to disable ipv6 except for disabling ipv6 on my router, which my ISP (Free) will not allow me to do. After reboot I still seem to be getting ipv6 addresses:

    Code:
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.0.13  netmask 255.255.255.0  broadcast 192.168.0.255
            inet6 fe80::21f:7bff:feb4:1754  prefixlen 64  scopeid 0x20<link>
            inet6 2a01:e35:8788:26a0:21f:7bff:feb4:1754  prefixlen 64  scopeid 0x0<global>
            ether 00:1f:7b:b4:17:54  txqueuelen 1000  (Ethernet)
            RX packets 9060  bytes 961138 (938.6 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 5512  bytes 998053 (974.6 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    I edited the line in /usr/lib/systemd/system/logitechmediaserver.service as you suggested. Still no luck. However until I did all that, when I entered "192.xxx.x.xx:9090" in the browser, I was getting a "transferring data from 192.xxx.x.xx" message, but it wouldn't go away. Now I'm no longer getting that. Also, I had enabled LMS and I notice that it no longer starts on boot. Systemctl shows logitechmediaserver.service as "Inactive dead".

    It looks as if I'll have to reinstall LMS.

    One thing I should mention: I ran http.pm from the command line in debug mode and got the following:

    Code:
    Can't locate Slim/Networking/Select.pm in @INC (you may need to install the Slim::Networking::Select module) (@INC contains: /usr/lib/perl5/5.30/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.30/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.30/core_perl /usr/share/perl5/core_perl) at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 40.
     at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 40.
    	Slim::Web::HTTP::BEGIN() called at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 40
    	eval {...} called at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 40
    BEGIN failed--compilation aborted at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 40.
     at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 40.
    Don't know if that means anything...
    __________________________________________________ _____________________
    Logitech Media Server Version: Logitech Media Server Version: 7.9.2 - ARCH-AUR-REL.7.9.2.arch2 running on Wandboard Quad, music library on SATA HDD
    Squeezebox Touch plugged into run-of-the-mill stereo rig via Musical Fidelity X-Act, extra speakers in kitchen, basement, and bedroom connected by ordinary (not unidirectional) copper cable.

  6. #1606
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    use 9000 not 9090 when connecting from a browser.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  7. #1607
    Senior Member Lestrad's Avatar
    Join Date
    Oct 2010
    Posts
    313
    Hello Paul. I uninstalled squeezelite and LMS, then reinstalled LMS (v7.9.2, ARCH-AUR-REL.7.9.2.arch2) and rebooted. Logitechmediaserver.service is running. But I still can't connect. I get the same error message in server.log:

    Code:
    19-09-12 10:19:40.3761] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Web::HTTP::acceptHTTP: Bad arg length for Socket::inet_ntoa, length is 16, should be 4 at /opt/logitechmediaserver/Slim/Web/HTTP.pm line 248.
    ; fh=HTTP::Daemon=GLOB(0x3564730)
    Your explanation (ipv6 address where ipv4 is expected) makes sense to me, but I've installed the "latest stable version" from the AUR and my ArchLinux installation is fully up to date. I can't understand why that sort of problem wouldn't have been taken into account.

    Any suggestions will be much appreciated.

    TIA

    Les
    __________________________________________________ _____________________
    Logitech Media Server Version: Logitech Media Server Version: 7.9.2 - ARCH-AUR-REL.7.9.2.arch2 running on Wandboard Quad, music library on SATA HDD
    Squeezebox Touch plugged into run-of-the-mill stereo rig via Musical Fidelity X-Act, extra speakers in kitchen, basement, and bedroom connected by ordinary (not unidirectional) copper cable.

  8. #1608
    Senior Member Lestrad's Avatar
    Join Date
    Oct 2010
    Posts
    313

    Progress

    This time I succeeded with the editing of /usr/lib/systemd/system/logitechmediaserver.service, line 14.

    Code:
    [alarm@alarm ~]$ ps -ef|grep httpaddr
    logitec+   358     1 13 14:27 ?        00:00:10 /usr/bin/perl /opt/logitechmediaserver/slimserver.pl --prefsdir /opt/logitechmediaserver/prefs --cachedir /opt/logitechmediaserver/cache --logdir /opt/logitechmediaserver/Logs --noimage --novideo --httpaddr 0.0.0.0 --cliaddr 0.0.0.0
    I rebooted, and now in response to 192.168.0.13:9000 on the browser I get:

    Code:
    403 Forbidden: settings/server/wizard.html
    What now?
    __________________________________________________ _____________________
    Logitech Media Server Version: Logitech Media Server Version: 7.9.2 - ARCH-AUR-REL.7.9.2.arch2 running on Wandboard Quad, music library on SATA HDD
    Squeezebox Touch plugged into run-of-the-mill stereo rig via Musical Fidelity X-Act, extra speakers in kitchen, basement, and bedroom connected by ordinary (not unidirectional) copper cable.

  9. #1609
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    As an experiment ... change the 2 0.0.0.0 to 192.168.0.13
    If it works - then try to reserve that IP address (192.168.0.13) on your router as being for your LMS machine.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  10. #1610
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    938
    Quote Originally Posted by Lestrad View Post
    I've followed all the instructions to disable ipv6 except for disabling ipv6 on my router, which my ISP (Free) will not allow me to do. After reboot I still seem to be getting ipv6 addresses:
    First, after a reboot, check:

    Code:
    systemctl status systemd-sysctl.service
    sysctl net.ipv6.conf.all.disable_ipv6 net.ipv6.conf.lo.disable_ipv6 net.ipv6.conf.eth0.disable_ipv6
    should indicate systemd-sysctl as Active: active (exited)
    and:
    Code:
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1
    net.ipv6.conf.eth0.disable_ipv6 = 1

    Maybe systemd-networkd is interfering:
    Code:
    systemctl status systemd-networkd.service
    If it is active / enabled, disable IPv6 for it as well.
    Basically, the [Network] section of /etc/systemd/network/20-wired.network should look similar to this:
    Code:
    [Network]
    DHCP=ipv4
    LinkLocalAddressing=ipv4
    IPv6AcceptRA=no
    Check before rebooting:
    systemctl restart systemd-networkd.service
    Various SW: Web Interface | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •