Home of the Squeezebox™ & Transporter® network music players.
Page 7 of 7 FirstFirst ... 567
Results 61 to 68 of 68
  1. #61
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,531
    Quote Originally Posted by Philip Meyer View Post
    With the original behaviour, there was one list of artists, that you could configure a bit. In Settings > My Music, there are some options to configure the single Artists list, one of them being the option to either:
    List compilation albums under each artist
    Group compilation albums together

    Track-only artists are by default not displayed in the artist list. i.e. artists that only appear as guests on songs, and not at album context, do not get displayed in the list. This was to prevent the list becoming unweildy with many artists cluttering the list that only have one or two songs on compilation albums.

    If you select "List compilation albums under each artist", you will probably see all artists.
    Except that it only works with artists found on compilation albums. The album described above is not a compilation. See this old bug:

    http://bugs.slimdevices.com/show_bug.cgi?id=17867

    You can easily have track-only artists that appear on non-compilations and have no way of getting them to appear in the artist list.

  2. #62
    Thank you for your answers. First of all it's good to know that this is a software bug indeed and not me being stupid. Call me vain, but that's how I feel.

    First thing I did was change the setting for compilation albums and rescan As JJZolx remarked, this works only for artists that are on discs that have the compilation flag (compilation=1). But for these it works.

    As I use Daphile, I'll have to ask Kimmo about using LMS 7.9. now that. I know there is a solution down the road, waiting is not a problem.

    Thanks again both of you.
    vanye

  3. #63
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,531
    You might try setting COMPILATION=1 and seeing how that works. If you have an ALBUMARTIST set for the album, there may not be much difference in overall behavior if LMS thinks the album is a compilation.

  4. #64
    Senior Member Philip Meyer's Avatar
    Join Date
    Apr 2005
    Location
    UK
    Posts
    5,596

    Multiple Artist Tags

    >Except that it only works with artists found on compilation albums. The
    >album described above is not a compilation. See this old bug:
    >

    Ah, I see. I thought that option did cause the Artists list to show all artists, album artists and track artists. Fairly sure it used to, but I have so many single-song artists (guests or on compilations), that I always hide them from the artist list. I'd never browse for them; usually I'd play the album and just expect a guest artist name to come up when the track is playing, or otherwise search.

    I think artists on songs not associated with albums would also appear, as "No Album" ends up being a compilation. So it is a bit strange that guest artists appearing on another artists album are excluded. Surely it makes more sense and would be easier to have an option to include all artists, rather than find all artists on compilations.

  5. #65
    Member
    Join Date
    Jul 2015
    Location
    Australia
    Posts
    60

    Still Confused

    I have read this thread multiple times and am still confused.

    With the song "Under Pressure" by David Bowie & Queen, how do I get this song to appear under each artist?
    ATM I have Album Artist = Queen and of course it appears under Queen only.

    My setup;
    * Running LMS 7.9.1
    * I use Album Artists only when searching.
    * All files in FLAC
    * Using LMS setting = 'Use 2 seperate lists for album Artists & All artists"

  6. #66
    Senior Member
    Join Date
    Oct 2008
    Location
    The Hague, Netherlands
    Posts
    110
    Quote Originally Posted by Jeddie View Post
    I have read this thread multiple times and am still confused.

    With the song "Under Pressure" by David Bowie & Queen, how do I get this song to appear under each artist?
    ATM I have Album Artist = Queen and of course it appears under Queen only.

    My setup;
    * Running LMS 7.9.1
    * I use Album Artists only when searching.
    * All files in FLAC
    * Using LMS setting = 'Use 2 seperate lists for album Artists & All artists"
    You can tag the song to have multiple 'artists', for example with mp3tag. With mp3tag you can for example use
    Artist = Queen\\David Bowie

    That way, LMS will show the song under both Queen and David Bowie.
    It is also possible to tag multiple 'album artists' with mp3tag if you would like to.
    Living: Ultrarendu -> Benchmark DAC2 HGC -> Benchmark AHB2 -> ATC SCM19 v2 & Sennheiser HD650
    Kitchen: SB Touch -> Audio Pro Addon T10 gen2
    Kids rooms: SB Booms
    Bedroom: SB Boom & SB Radio
    Controls: iPeng & LMS via internet
    Server: Windows 10 Pro with LMS 7.9.2
    Spare: 2 SB Touch, 1 SB3, 2 SB Radio

  7. #67
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,092
    By accident of design Material displays only the first item it finds in the JSOn array that LMS produces so using your example I would tag as follows

    Artist (Track Artist) - “Queen & David Bowie”

    Album Artist - Queen & David Bowie\\Queen\\David Bowie

    When you look in artists you will find the album under all three entries but when you play the track your player will display Queen & David Bowie. Likewise if you were to look under albums it would be shown in Material as by Queen & David Bowie. In LMS GUI you would see all 3 entries and isn’t quite as neat as the way Material behaves in this respect.

    Note also that if you tag this way MAI will give you 3 options to choose from when you ask for Artist Info. Material i button will operate on Queen & David Bowie but the 3 options are exposed under More

    If using mp3tag then be aware that \\ creates multiple tags but you can also use ; which creates only one tag but when scanning LMS reads 3 items into the database which is the same as reading the 3 separate tags.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  8. #68
    Senior Member
    Join Date
    Mar 2017
    Posts
    1,099
    Quote Originally Posted by d6jg View Post
    Note also that if you tag this way MAI will give you 3 options to choose from when you ask for Artist Info. Material i button will operate on Queen & David Bowie but the 3 options are exposed under More
    LMS should provide Material with a list of artist IDs, and if Material has a list it will ask MAI for the bio for each ID - and append these to the displayed text. So, it should show bios for all. I've just noticed, and fixed, a slight typo that might affect this - but not certain.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •