No announcement yet.

Copy files over network to Touch USB/SD ?

  • Filter
  • Time
  • Show
Clear All
new posts

    Copy files over network to Touch USB/SD ?

    Is it possible to copy files over the network directly to a USB stick or SD card that is plugged into the Touch?
    I guess the Touch would almost need to be an NAS device at that point?

    I would like to maintain my music library with iTunes on another computer but when I get some new music (downloaded or ripped) I'd like to then just copy those new files directly to the Touch's USB or SD memory over the network.
    That would be easier to keep the Touch up to date with my library rather than always keeping the computer running for streaming or manually moving the USB stick/SD card back and forth between my computer and the Touch ...

    Yes you can!

    You have to first enable USB sharing on the Touch then you can access it from another computer on your network.

    To enable sharing select the menu item:

    Settings->Advanced->USB SD Device->sharing

    Select sharing (the square turns blue when its turned on)

    You will be given a name and password, you will need these later on.

    At this point it should be visible on other computers. IF you are using Windows you should see it in network neighborhood. IF you have changed the workgroup name on your computer it won't show up since the Touch uses WORKGROUP as its workgroup name. IF this is the case you can access it from windows explorer (not internet explorer). In the address bar type in:


    For example on mine this is

    You can get the IP address from the diagnostics page:

    When you first connect you will be asked for username and password. The username is root, the passwowrd is what you got when you enabled sharing.

    Now you can just copy files over to the USB device.

    John S.


      Great! Thanks John!


        this is good wiki fodder

        ... perhaps you could add an entry?


          Although the procedure outlined by John works perfectly, in practice it is IMO only a workable solution to add one (or at the most a few) albums to the library on the Touch drive(s). This procedure is simply too slow to add a lot of files. In that case the best solution still is to plug the USB device (or SD card) into a computer, add the files, and attach it to the Touch again.


            This sync procedure works good and I use it here, too, but the squeezebox often crashes/stops the server after changing many files. Sometimes it restarts the indexing which takes REALLY long on the 500GB disk.
            Any ideas how to avoid this?
            SB Touch+SB Radio, Sheevaplug Server, Squeeze Commander


              Works for me, but...

              I used the setup described above and it worked fine with the SD card: I was able to transfer MP3 files to the SD card. Now I use a hard disk on the touch and I do not seem to be able to connect to the SB Touch using my XP computer.

              Sharing is still on.

              If I change the password or username at the Squeezebox and then try to login using Windows XP (the SB is listed in "my network places"). Unfortunately, access is refused because - according to Windows - I do not have the right network privileges for the device (unfortunately, the message is in Dutch, so I don't know the exact translation).

              Does anyone have an idea why this might happen?
              Thanks in advance!


                Originally posted by sendermen View Post
                I used the setup described above and it worked fine with the SD card: I was able to transfer MP3 files to the SD card. Now I use a hard disk on the touch and I do not seem to be able to connect to the SB Touch using my XP computer.
                The hard drive has a different share name than the SD card. If you're trying to connect to the old link left in My Network Places then you're still trying to connect to the SD card.

                An easy way to see the current shares available is to enter the Touch's name in Windows explorer. For example:




                  Thanks for your help!

                  Yes, I was trying to connect to the old SD card. I am unable to discover the Squeezebox in my network.

                  I can successfully ping the squeezebox at

                  'The Dude' - some network discovery program - is able to see MySqueezeboxname at

                  I cannot connect to the squeezebox at the same ip using \\ (= server does not respond)

                  I cannot see the Squeezebox using \\SqueezeboxName
                  (= File not found. Firefox can't find the file at ///SingelFavoliedjes.)

                  This happens when I try IE of FF or Windows Explorer.

                  Sharing is on. Squeezebox server is running. Wireless network is functioning correctly.

                  Any idea why I don't see the SB in Windows network and why I am unable to access it? It does seem to be at the correct address as I can ping it and find it with The Dude.


                    Originally posted by sendermen View Post
                    I cannot connect to the squeezebox at the same ip using \\ (= server does not respond)
                    Are you trying this from Windows Explorer? That should work if the IP address is correct. From accounts in the forums, the file sharing on the Touch has definitely been flaky. Some people have speculated that the Samba server may be crashing due to memory or other problems on the Touch.

                    You can SSH into the Touch and restart the Samba server, which sometimes works in getting it going again, or just try rebooting the Touch.

                    To restart Samba:

                    First, enable remote login through Settings > Advanced > Remote Login > Enable SSH.

                    Then, using an SSH client (such as PuTTY for Windows), SSH into the Touch (port 22) with username=root, password=1234.

                    Restart Samba with:

                    # /etc/init.d/samba restart


                      SSH works but still no network

                      I was able to login with SSH, but still, the device isn't accessible. If I goto the SB Touch that is listed as one of the computers in my workgroup, I'm not asked for a login and password, but I only get that good old message saying (in Dutch) that:

                      the SB is not accessible. I do not have the right permissions for this network source. Contact the administrator of the server if you want to know whether you have the access permissions.
                      Cannot find the network path.

                      There is no SD card in the SB and the HD is spinning. I restarted Samba. I restarted the SB.

                      But wait. While the doesn't work, entering \\SBname now does work!
                      So you seem to be right about samba. Well, let me see whether I'm able to work with the SB as a network drive.
                      Thanks a lot!


                        but it is flaky indeed

                        The connection is flaky indeed: Samba crashed again. But at least I got in for a short while.


                          Still trying

                          - Sorry, managed to get in again. Ignore this message, please.
                          Last edited by sendermen; 2010-10-22, 14:09.



                            I could see "squeezebox touch“ in Windows XP "workplace" folder but when I clicked it, I was told I didn't have permission to access this server (the Touch) and I needed to contact its administrator. I was not asked the username or password. I couldn't open (my Touch) either.

                            Could anyone help me? What is Samba? Thank you.


                              same situation. Everithing with xp connects and nothing with 7. Changed a lot of options under security management, encription, password etc without success.